aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-04-04 18:11:13 +0800
committerjbeich <jbeich@FreeBSD.org>2018-04-04 18:11:13 +0800
commit8e31a9a26d7fc3a30bb7c428ff876ef50be127c6 (patch)
tree4a00c955ed6d2e528df0dfd89aa4206c9362c599
parentdf3371ab92758e7ba43c4ba9a65ce08f29cb5400 (diff)
downloadfreebsd-ports-gnome-8e31a9a26d7fc3a30bb7c428ff876ef50be127c6.tar.gz
freebsd-ports-gnome-8e31a9a26d7fc3a30bb7c428ff876ef50be127c6.tar.zst
freebsd-ports-gnome-8e31a9a26d7fc3a30bb7c428ff876ef50be127c6.zip
games/0ad: unbreak with ICU 61
In file included from ../../../source/lobby/XmppClient.cpp:26: ../../../source/i18n/L10n.h:89:2: error: unknown type name 'Locale'; did you mean 'icu::Locale'? Locale GetCurrentLocale() const; ^~~~~~ icu::Locale /usr/local/include/unicode/unistr.h:77:7: note: 'icu::Locale' declared here class Locale; // unicode/locid.h ^ In file included from ../../../source/lobby/XmppClient.cpp:26: ../../../source/i18n/L10n.h:133:24: error: unknown type name 'Locale'; did you mean 'icu::Locale'? bool SaveLocale(const Locale& locale) const; ^~~~~~ icu::Locale /usr/local/include/unicode/unistr.h:77:7: note: 'icu::Locale' declared here class Locale; // unicode/locid.h ^ In file included from ../../../source/lobby/XmppClient.cpp:26: ../../../source/i18n/L10n.h:235:54: error: unknown type name 'Locale'; did you mean 'icu::Locale'? std::wstring GetFallbackToAvailableDictLocale(const Locale& locale) const; ^~~~~~ icu::Locale /usr/local/include/unicode/unistr.h:77:7: note: 'icu::Locale' declared here class Locale; // unicode/locid.h ^ In file included from ../../../source/lobby/XmppClient.cpp:26: ../../../source/i18n/L10n.h:283:66: error: unknown type name 'Locale'; did you mean 'icu::Locale'? void GetDictionaryLocale(const std::string& configLocaleString, Locale& outLocale) const; ^~~~~~ icu::Locale /usr/local/include/unicode/unistr.h:77:7: note: 'icu::Locale' declared here class Locale; // unicode/locid.h ^ In file included from ../../../source/lobby/XmppClient.cpp:26: ../../../source/i18n/L10n.h:314:28: error: unknown type name 'Locale'; did you mean 'icu::Locale'? bool ValidateLocale(const Locale& locale) const; ^~~~~~ icu::Locale /usr/local/include/unicode/unistr.h:77:7: note: 'icu::Locale' declared here class Locale; // unicode/locid.h ^ In file included from ../../../source/lobby/XmppClient.cpp:26: ../../../source/i18n/L10n.h:411:98: error: unknown type name 'Locale'; did you mean 'icu::Locale'? UDate ParseDateTime(const std::string& dateTimeString, const std::string& dateTimeFormat, const Locale& locale) const; ^~~~~~ icu::Locale /usr/local/include/unicode/unistr.h:77:7: note: 'icu::Locale' declared here class Locale; // unicode/locid.h ^ In file included from ../../../source/lobby/XmppClient.cpp:26: ../../../source/i18n/L10n.h:427:85: error: use of undeclared identifier 'DateFormat'; did you mean 'icu::DateFormat'? std::string LocalizeDateTime(const UDate dateTime, const DateTimeType& type, const DateFormat::EStyle& style) const; ^~~~~~~~~~ icu::DateFormat /usr/local/include/unicode/smpdtfmt.h:46:7: note: 'icu::DateFormat' declared here class DateFormat; ^ In file included from ../../../source/lobby/XmppClient.cpp:26: ../../../source/i18n/L10n.h:508:2: error: unknown type name 'Locale'; did you mean 'icu::Locale'? Locale currentLocale; ^~~~~~ icu::Locale /usr/local/include/unicode/unistr.h:77:7: note: 'icu::Locale' declared here class Locale; // unicode/locid.h ^ In file included from ../../../source/lobby/XmppClient.cpp:26: ../../../source/i18n/L10n.h:519:14: error: use of undeclared identifier 'Locale' std::vector<Locale*> availableLocales; ^ ../../../source/i18n/L10n.h:519:21: error: expected expression std::vector<Locale*> availableLocales; ^ ../../../source/i18n/L10n.h:590:2: error: unknown type name 'DateFormat'; did you mean 'UDateFormat'? DateFormat* CreateDateTimeInstance(const DateTimeType& type, const DateFormat::EStyle& style, const Locale& locale) const; ^~~~~~~~~~ UDateFormat /usr/local/include/unicode/udat.h:153:15: note: 'UDateFormat' declared here typedef void* UDateFormat; ^ In file included from ../../../source/lobby/XmppClient.cpp:26: ../../../source/i18n/L10n.h:590:69: error: use of undeclared identifier 'DateFormat'; did you mean 'icu::DateFormat'? DateFormat* CreateDateTimeInstance(const DateTimeType& type, const DateFormat::EStyle& style, const Locale& locale) const; ^~~~~~~~~~ icu::DateFormat /usr/local/include/unicode/smpdtfmt.h:46:7: note: 'icu::DateFormat' declared here class DateFormat; ^ In file included from ../../../source/lobby/XmppClient.cpp:26: ../../../source/i18n/L10n.h:590:102: error: unknown type name 'Locale'; did you mean 'icu::Locale'? DateFormat* CreateDateTimeInstance(const DateTimeType& type, const DateFormat::EStyle& style, const Locale& locale) const; ^~~~~~ icu::Locale /usr/local/include/unicode/unistr.h:77:7: note: 'icu::Locale' declared here class Locale; // unicode/locid.h ^ ../../../source/lobby/XmppClient.cpp:948:81: error: use of undeclared identifier 'Locale'; did you mean 'icu::Locale'? return g_L10n.ParseDateTime(msg.when()->stamp().to_string(), "Y-M-d'T'H:m:sZ", Locale::getUS()) / 1000.0; ^~~~~~ icu::Locale /usr/local/include/unicode/unistr.h:77:7: note: 'icu::Locale' declared here class Locale; // unicode/locid.h ^ https://ssl.icu-project.org/trac/changeset/40705 PR: 227042 Reported by: antoine (via exp-run)
-rw-r--r--games/0ad/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/games/0ad/Makefile b/games/0ad/Makefile
index a87cb220d563..0c156c2be41a 100644
--- a/games/0ad/Makefile
+++ b/games/0ad/Makefile
@@ -29,6 +29,7 @@ LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-alpha
BUILD_WRKSRC= ${WRKSRC}/build/workspaces/gcc
MAKE_ARGS= config=release
+CPPFLAGS+= -DU_USING_ICU_NAMESPACE=1
USES= compiler:c++11-lib dos2unix gmake iconv jpeg openal:al \
pkgconfig python:build tar:xz
USE_GNOME= libxml2 gtk20