aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2012-03-02 05:27:36 +0800
committercrees <crees@FreeBSD.org>2012-03-02 05:27:36 +0800
commit8e38c9f11fb16964f93e4be85683c33917aefff1 (patch)
tree26979e162d006c2c55354543919b852458521576
parentbdc7b9516967478e45604a3b7f649c143c6571f3 (diff)
downloadfreebsd-ports-gnome-8e38c9f11fb16964f93e4be85683c33917aefff1.tar.gz
freebsd-ports-gnome-8e38c9f11fb16964f93e4be85683c33917aefff1.tar.zst
freebsd-ports-gnome-8e38c9f11fb16964f93e4be85683c33917aefff1.zip
Update to 0.5.4
PR: ports/164832 Submitted by: RyoTa SimaMoto <liangtai.s4@gmail.com> (maintainer)
-rw-r--r--multimedia/qmmp/Makefile28
-rw-r--r--multimedia/qmmp/distinfo4
-rw-r--r--multimedia/qmmp/pkg-descr14
-rw-r--r--multimedia/qmmp/pkg-plist4
4 files changed, 26 insertions, 24 deletions
diff --git a/multimedia/qmmp/Makefile b/multimedia/qmmp/Makefile
index cc7ec1a9b9a7..c8fdb05e141c 100644
--- a/multimedia/qmmp/Makefile
+++ b/multimedia/qmmp/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= qmmp
-PORTVERSION= 0.5.2
-PORTREVISION= 3
+PORTVERSION= 0.5.4
CATEGORIES= multimedia
MASTER_SITES= http://qmmp.ylsoftware.com/files/ \
${MASTER_SITE_GOOGLE_CODE}
@@ -31,7 +30,7 @@ OPTIONS= SKINNEDUI "Skinned GUI" on \
OSS "Support the OSS output" on \
OSS4 "Support the OSS4 output" off \
JACK "Support the JACK output" on \
- NULLOUT "Support a null output" on \
+ NULLOUT "Support a null output" on \
FLAC "Support to playback FLAC files" on \
MUSEPACK "Support to playback MPC files" on \
FFMPEG "Support to playback FFMPEG files" on \
@@ -40,13 +39,13 @@ OPTIONS= SKINNEDUI "Skinned GUI" on \
GME "Support video game music files" on \
MAD "Support to playback MAD files" on \
VORBIS "Support to playback Vorbis/OGG files" on \
- SNDFILE "Support to playback Sndfile files" on \
- WAVPACK "Support to playback WAVPack files" on \
+ SNDFILE "Support to playback Sndfile files" on \
+ WAVPACK "Support to playback WAVPack files" on \
CUE "Support to CUE sheets" on \
CDIO "Support to playback compact discs" on \
FAAD "Support to playback through FAAD decoder" on \
LADSPA "Support the LADSPA effect" on \
- CROSSFADE "Support cross-fade effect" on \
+ CROSSFADE "Support cross-fade effect" on \
BS2B "Support the Bauer stereophonic2binaural effect" on \
STEREO "Support stereo effect" on \
SRCONV "Support the sample rate converter" on \
@@ -65,7 +64,7 @@ OPTIONS= SKINNEDUI "Skinned GUI" on \
FILEOPS "Support file operation" on \
COVER "Support to show cover images" on \
KDENOTIFY "Support to popup notifier for KDE" on \
- HAL "Support removable disc detection using HAL" on \
+ HAL "Support removable disc detection using HAL" on \
UDISKS "Support removable disc detection using UDisks" on \
QMMP_DIALOG "An original dialog" on
@@ -149,8 +148,12 @@ PLUGIN_OPTIONS_CMAKE+= -DUSE_GME:BOOL=FALSE
.ifndef(WITHOUT_FFMPEG)
PLIST_SUB+= FFMPEG=""
-LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
PLUGIN_OPTIONS_CMAKE+= -DUSE_FFMPEG:BOOL=TRUE
+. if exists(${LOCALBASE}/include/libavcodec/vda.h)
+LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg-devel
+. else
+LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
+. endif
.else
PLIST_SUB+= FFMPEG="@comment "
PLUGIN_OPTIONS_CMAKE+= -DUSE_FFMPEG:BOOL=FALSE
@@ -456,11 +459,10 @@ INSTALLS_ICONS= yes
CMAKE_ARGS+= ${PLUGIN_OPTIONS_CMAKE} \
-DCMAKE_REQUIRED_INCLUDES:PATH=${LOCALBASE}/include
CMAKE_OUTSOURCE=yes
-CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
post-patch:
- ${REINPLACE_CMD} -e 's| -ldl| $${CMAKE_DL_LIBS}|' \
- ${WRKSRC}/src/plugins/Effect/ladspa/CMakeLists.txt
${REINPLACE_CMD} -e 's|/usr/|${LOCALBASE}/|g' \
${WRKSRC}/src/plugins/Output/oss4/CMakeLists.txt
${REINPLACE_CMD} -e 's|DESTINATION bin|DESTINATION libexec|' \
@@ -488,9 +490,9 @@ post-install:
cd ${WRKSRC}/doc/html/search && \
${INSTALL_MAN} *.html *.png *.css *.js ${DOCSDIR}/html/search ; \
${RM} -f ${WRKDIR}/PLIST.doc ; \
- ${FIND} ${DOCSDIR}/html -type f | ${SED} 's|${LOCALBASE}/||' \
+ ${FIND} ${DOCSDIR}/html -type f | ${SED} 's|${PREFIX}/||' \
>> ${WRKDIR}/PLIST.doc ; \
- ${FIND} ${DOCSDIR}/html -type d | ${SED} 's|${LOCALBASE}/|@dirrm |' \
+ ${FIND} ${DOCSDIR}/html -type d | ${SED} 's|${PREFIX}/|@dirrm |' \
| ${SORT} -r >> ${WRKDIR}/PLIST.doc ; \
cd ${WRKDIR} ; ${SED} -i -e '/PLIST.doc/ r PLIST.doc' ${TMPPLIST}
.endif
diff --git a/multimedia/qmmp/distinfo b/multimedia/qmmp/distinfo
index 97e089bb64f3..99dac1dea54f 100644
--- a/multimedia/qmmp/distinfo
+++ b/multimedia/qmmp/distinfo
@@ -1,2 +1,2 @@
-SHA256 (qmmp-0.5.2.tar.bz2) = 6391dec020d2a381d7f4b7890fae6c49eadf88b3c9aef571fe3c5e96140822ec
-SIZE (qmmp-0.5.2.tar.bz2) = 704517
+SHA256 (qmmp-0.5.4.tar.bz2) = 6f95d1bb97cb1ef91b9d664f4d5ce013c6cc93f3aefb24cd64cf2500a525be0f
+SIZE (qmmp-0.5.4.tar.bz2) = 708421
diff --git a/multimedia/qmmp/pkg-descr b/multimedia/qmmp/pkg-descr
index 9b722a67515b..455e7a139461 100644
--- a/multimedia/qmmp/pkg-descr
+++ b/multimedia/qmmp/pkg-descr
@@ -2,21 +2,21 @@ This program is an audio-player, written with help of Qt library.
Supported formats:
MPEG1 layer 2/3, Ogg Vorbis, Native FLAC, Ogg FLAC, Musepack, WavePack,
tracker modules (mod, s3m, it, xm, etc.), ADTS AAC, CD Audio, MIDI,
- WMA-Monkey's Audio (and other formats provided by FFmpeg library),
- PCM Wave (and other formats provided by libsndfile library), and
- chiptune formats (AY, GBS, GYM, HES, KSS, NSF, NSFE, SAP, SPC, VGM, VGZ, VTX)
+ WMA-Monkey's Audio (and other formats provided by FFmpeg library), PCM
+ Wave (and other formats provided by libsndfile library), and Chiptune
+ formats (AY, GBS, GYM, HES, KSS, NSF, NSFE, SAP, SPC, VGM, VGZ, VTX)
DSP effects:
Bauer Stereophonic-to-Binaural effect, sample rate conversion,
- LADSPA effects, extra stereo effect, and crossfade effect
+ LADSPA effects, extra stereo effect, and crossfade effect
Visual effects:
Spectrum Analyzer, and projectM audio visulaliser
Output system support:
PulseAudio, OSS, OSS4, jack, and ALSA
Other features:
- 10-band equalizer, Last.fm/Libre.fm scrobbler, MMS support, global hotkey,
+ 10-band equalizer, Last.fm/Libre.fm scrobbler, global hotkey, MPRIS,
streaming (MP3, Vorbis, AAC, AAC+ via IceCast/ShoutCast), CDDB support,
- removable device detection (via HAL or UDisks), MPRIS, cover art support,
- multiple playlists, ReplayGain support, CUE sheet support,
+ removable device detection (via HAL or UDisks), cover art support,
+ multiple playlists, ReplayGain support, CUE sheet support, MMS support,
embedded CUE support (for FLAC and WavPack), MPRIS (1.0 and 2.0),
automatic charset detection for cue files and ShoutCast metadata,
video playback via Mplayer, lyrics (using lyrics.wikia.com), and
diff --git a/multimedia/qmmp/pkg-plist b/multimedia/qmmp/pkg-plist
index c4bc398452cd..40edcb1a924d 100644
--- a/multimedia/qmmp/pkg-plist
+++ b/multimedia/qmmp/pkg-plist
@@ -43,10 +43,10 @@ include/qmmpui/playlistparser.h
include/qmmpui/templateeditor.h
lib/libqmmp.so
lib/libqmmp.so.0
-lib/libqmmp.so.0.5.2
+lib/libqmmp.so.0.5.4
lib/libqmmpui.so
lib/libqmmpui.so.0
-lib/libqmmpui.so.0.5.2
+lib/libqmmpui.so.0.5.4
lib/qmmp/CommandLineOptions/libincdecvolumeoption.so
lib/qmmp/CommandLineOptions/libseekoption.so
lib/qmmp/CommandLineOptions/libstatusoption.so