aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2015-01-12 12:16:23 +0800
committergerald <gerald@FreeBSD.org>2015-01-12 12:16:23 +0800
commit8e7de7caf7e6644c747c9f281299b5bcb2056a87 (patch)
tree7640a157a4881a026c51115ed661ef68230c151f
parent38539f04c1135f24598f9250bf0f81e401b2d2d6 (diff)
downloadfreebsd-ports-gnome-8e7de7caf7e6644c747c9f281299b5bcb2056a87.tar.gz
freebsd-ports-gnome-8e7de7caf7e6644c747c9f281299b5bcb2056a87.tar.zst
freebsd-ports-gnome-8e7de7caf7e6644c747c9f281299b5bcb2056a87.zip
Tweak a comment and fix whitespace in the new ARM support.
-rw-r--r--lang/gcc/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/gcc/Makefile b/lang/gcc/Makefile
index d6e69b47886d..aac13b993983 100644
--- a/lang/gcc/Makefile
+++ b/lang/gcc/Makefile
@@ -59,8 +59,8 @@ CONFIGURE_ENV+= UNAME_m="powerpc64"
.endif
.if ${ARCH} == "armv6" || ${ARCH} == "armv6hf"
-# We have to override the sys.mk -O CFLAG since it breaks libgomp building.
-CFLAGS:= ${CFLAGS:S/-O/-O2/g}
+# Override sys.mk including -O in CFLAGS which breaks libgomp building.
+CFLAGS:= ${CFLAGS:S/-O/-O2/g}
. if ${COMPILER_TYPE} == clang
. if empty(PORT_OPTIONS:MBOOTSTRAP)
MAKE_ARGS+=CXXFLAGS=-fbracket-depth=512