aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2014-01-23 18:15:01 +0800
committerknu <knu@FreeBSD.org>2014-01-23 18:15:01 +0800
commit8f3054d080189c409fd2a98d042ceb8fa41fae69 (patch)
treee8f5dc7d4c3599016947e55f00144f04bb41e5a7
parentf95264f0aa201d4f01e67debf01b79edef8d3a37 (diff)
downloadfreebsd-ports-gnome-8f3054d080189c409fd2a98d042ceb8fa41fae69.tar.gz
freebsd-ports-gnome-8f3054d080189c409fd2a98d042ceb8fa41fae69.tar.zst
freebsd-ports-gnome-8f3054d080189c409fd2a98d042ceb8fa41fae69.zip
Add USE_GCC=4.2+ for FreeBSD 10+.
Properly declare a dependency on Perl5 (for bin/q4m-forward) and bump PORTREVISION for this.
-rw-r--r--databases/mysql-q4m/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/databases/mysql-q4m/Makefile b/databases/mysql-q4m/Makefile
index b15dc5f4738b..82c8de5554c3 100644
--- a/databases/mysql-q4m/Makefile
+++ b/databases/mysql-q4m/Makefile
@@ -3,6 +3,7 @@
PORTNAME= q4m
PORTVERSION= 0.9.10
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= http://q4m.kazuhooku.com/dist/
PKGNAMEPREFIX= mysql${MYSQL_VER}-
@@ -13,13 +14,13 @@ COMMENT= A message queue that works as a pluggable storage engine of MySQL
FETCH_DEPENDS+= ${NONEXISTENT}:${PORTSDIR}/databases/mysql${MYSQL_VER}-server:build
RUN_DEPENDS= ${LOCALBASE}/libexec/mysqld:${PORTSDIR}/databases/mysql${MYSQL_VER}-server
-USE_PERL5= yes
-USE_GMAKE= yes
+USES= gmake perl5
USE_AUTOTOOLS= libtool
USE_MYSQL= yes
+USE_GCC= 4.2+
GNU_CONFIGURE= yes
-CPPFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include -DDBUG_OFF
+CPPFLAGS+= -I${LOCALBASE}/include -DDBUG_OFF
LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib -L${LOCALBASE}/lib/mysql
CONFIGURE_ARGS= --prefix="${PREFIX}" \
--libdir="${PREFIX}/lib/mysql/plugin" \
@@ -56,7 +57,7 @@ post-install:
.endif
install-functions:
- mysql -u root -f mysql < ${EXAMPLESDIR}/install.sql
+ mysql -u root -p -f mysql < ${EXAMPLESDIR}/install.sql
test:
cd ${WRKSRC}; ./run_tests.pl