aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-11-19 07:04:41 +0800
committeryuri <yuri@FreeBSD.org>2018-11-19 07:04:41 +0800
commit8fc59863483974c6eacdb6866e25b5306a81425e (patch)
treeaaaf6c53dd082c9355188c513bce520ab08b21cc
parent80993205c647f50a56bff452e99c80b2b18257e2 (diff)
downloadfreebsd-ports-gnome-8fc59863483974c6eacdb6866e25b5306a81425e.tar.gz
freebsd-ports-gnome-8fc59863483974c6eacdb6866e25b5306a81425e.tar.zst
freebsd-ports-gnome-8fc59863483974c6eacdb6866e25b5306a81425e.zip
New port: math/py-cvxpy: Domain-specific language for modeling convex optimization problems
-rw-r--r--math/Makefile1
-rw-r--r--math/py-cvxpy/Makefile29
-rw-r--r--math/py-cvxpy/distinfo3
-rw-r--r--math/py-cvxpy/pkg-descr5
4 files changed, 38 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 6c5a8198370c..3cbd9f24fc94 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -692,6 +692,7 @@
SUBDIR += py-colormath
SUBDIR += py-cryptominisat
SUBDIR += py-cvxopt
+ SUBDIR += py-cvxpy
SUBDIR += py-cyipopt
SUBDIR += py-ecos
SUBDIR += py-fastcluster
diff --git a/math/py-cvxpy/Makefile b/math/py-cvxpy/Makefile
new file mode 100644
index 000000000000..1726b075fa5e
--- /dev/null
+++ b/math/py-cvxpy/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= cvxpy
+DISTVERSION= 1.0.10
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Domain-specific language for modeling convex optimization problems
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYNUMPY}
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}ecos>=2:math/py-ecos@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}fastcache>0:devel/py-fastcache@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}multiprocess>0:devel/py-multiprocess@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}osqp>0:math/py-osqp@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0.19:science/py-scipy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scs>=1.1.3:math/py-scs@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}toolz>0:devel/py-toolz@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/math/py-cvxpy/distinfo b/math/py-cvxpy/distinfo
new file mode 100644
index 000000000000..56a7725e3e62
--- /dev/null
+++ b/math/py-cvxpy/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1542573041
+SHA256 (cvxpy-1.0.10.tar.gz) = bd362f638c661cd532451948892647580d8726d5b70b557cdca3ebb993a23282
+SIZE (cvxpy-1.0.10.tar.gz) = 900149
diff --git a/math/py-cvxpy/pkg-descr b/math/py-cvxpy/pkg-descr
new file mode 100644
index 000000000000..dac6ae8c29d9
--- /dev/null
+++ b/math/py-cvxpy/pkg-descr
@@ -0,0 +1,5 @@
+CVXPY is a Python-embedded modeling language for convex optimization problems.
+It allows you to express your problem in a natural way that follows the math,
+rather than in the restrictive standard form required by solvers.
+
+WWW: https://www.cvxpy.org/