aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-03-22 21:41:53 +0800
committermakc <makc@FreeBSD.org>2013-03-22 21:41:53 +0800
commit904fc890d1dc712abfaeaddde7864519df50915c (patch)
tree61087236aa78ab5d8af8658afd62fc2140586fb4
parentf624662187a1d84302eec54e046158bb5c20849e (diff)
downloadfreebsd-ports-gnome-904fc890d1dc712abfaeaddde7864519df50915c.tar.gz
freebsd-ports-gnome-904fc890d1dc712abfaeaddde7864519df50915c.tar.zst
freebsd-ports-gnome-904fc890d1dc712abfaeaddde7864519df50915c.zip
- Get rid of no longer needed KDE4_BUILDENV
- Convert USE_CMAKE to USES
-rw-r--r--devel/kdevelop-custom-buildsystem/Makefile2
-rw-r--r--devel/kdevelop-kde4/Makefile2
-rw-r--r--devel/kdevelop-pg-qt/Makefile2
-rw-r--r--devel/kdevelop-php-docs/Makefile2
-rw-r--r--devel/kdevelop-php/Makefile2
-rw-r--r--devel/kdevplatform/Makefile2
6 files changed, 6 insertions, 6 deletions
diff --git a/devel/kdevelop-custom-buildsystem/Makefile b/devel/kdevelop-custom-buildsystem/Makefile
index 3673e58fe854..6898370a8216 100644
--- a/devel/kdevelop-custom-buildsystem/Makefile
+++ b/devel/kdevelop-custom-buildsystem/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= kdevplatforminterfaces:${PORTSDIR}/devel/kdevplatform
USE_KDE4= kdehier kdelibs kdeprefix automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
USE_BZIP2= yes
-USE_CMAKE= yes
+USES= cmake
MAKE_JOBS_SAFE= yes
PLIST_FILES= lib/kde4/kcm_kdevcustombuildsystem.so \
diff --git a/devel/kdevelop-kde4/Makefile b/devel/kdevelop-kde4/Makefile
index 18eca24db060..77a0eb0630cd 100644
--- a/devel/kdevelop-kde4/Makefile
+++ b/devel/kdevelop-kde4/Makefile
@@ -19,7 +19,7 @@ LATEST_LINK= ${PORTNAME}-kde4
USE_KDE4= kdehier kdelibs kdeprefix sharedmime workspace automoc4
USE_QT4= qmake_build moc_build uic_build rcc_build
USE_BZIP2= yes
-USE_CMAKE= yes
+USES= cmake
USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
diff --git a/devel/kdevelop-pg-qt/Makefile b/devel/kdevelop-pg-qt/Makefile
index 87ed8629d3ce..15827374d882 100644
--- a/devel/kdevelop-pg-qt/Makefile
+++ b/devel/kdevelop-pg-qt/Makefile
@@ -20,7 +20,7 @@ USE_GCC= 4.6+
USE_BZIP2= yes
USES= bison
USE_KDE4= automoc4 kdehier kdelibs kdeprefix
-KDE4_BUILDENV= yes
+USES+= cmake:outsource
USE_QT4= qmake_build moc_build uic_build rcc_build
MAKE_JOBS_SAFE= yes
diff --git a/devel/kdevelop-php-docs/Makefile b/devel/kdevelop-php-docs/Makefile
index 2cbb08800d5b..0274854619ac 100644
--- a/devel/kdevelop-php-docs/Makefile
+++ b/devel/kdevelop-php-docs/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= kdevplatforminterfaces:${PORTSDIR}/devel/kdevplatform
USE_KDE4= kdehier kdelibs kdeprefix automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
USE_BZIP2= yes
-USE_CMAKE= yes
+USES= cmake
MAKE_JOBS_SAFE= yes
.include <bsd.port.options.mk>
diff --git a/devel/kdevelop-php/Makefile b/devel/kdevelop-php/Makefile
index 77bec90e3030..3a764ca52d49 100644
--- a/devel/kdevelop-php/Makefile
+++ b/devel/kdevelop-php/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= ${KDE4_PREFIX}/bin/kdev-pg-qt:${PORTSDIR}/devel/kdevelop-pg-qt
USE_KDE4= kdehier kdelibs kdeprefix automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
USE_BZIP2= yes
-USE_CMAKE= yes
+USES= cmake
USE_GMAKE= yes
MAKE_JOBS_UNSAFE= yes
diff --git a/devel/kdevplatform/Makefile b/devel/kdevplatform/Makefile
index 23098076f846..8354847d81cb 100644
--- a/devel/kdevplatform/Makefile
+++ b/devel/kdevplatform/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= svn_client-1:${PORTSDIR}/devel/subversion \
USE_KDE4= kate_run kdehier kdelibs kdeprefix automoc4
USE_QT4= qmake_build moc_build uic_build rcc_build
USE_BZIP2= yes
-USE_CMAKE= yes
+USES= cmake
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes