aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2012-07-18 02:01:34 +0800
committerjohans <johans@FreeBSD.org>2012-07-18 02:01:34 +0800
commit910b06f9086ffed2b23c7221b6ed4ccc51b38e54 (patch)
tree3122fce93559a311979c5e3a141510b534dc8a16
parent7b074d46b232d988dc15388362e755bbfb121e6d (diff)
downloadfreebsd-ports-gnome-910b06f9086ffed2b23c7221b6ed4ccc51b38e54.tar.gz
freebsd-ports-gnome-910b06f9086ffed2b23c7221b6ed4ccc51b38e54.tar.zst
freebsd-ports-gnome-910b06f9086ffed2b23c7221b6ed4ccc51b38e54.zip
- [1] Fix the use of SRV resource queries via DNS;
caused by failure to detect resolv.h and res_query() http://lists.gnu.org/archive/html/help-shishi/2012-07/msg00001.html - Minor style cleanups - Bump PORTREVISION Submitted by: Mats Erik Andersson <openbsd@gisladisker.se> [1]
-rw-r--r--security/shishi/Makefile9
-rw-r--r--security/shishi/files/patch-configure59
-rw-r--r--security/shishi/pkg-plist2
3 files changed, 65 insertions, 5 deletions
diff --git a/security/shishi/Makefile b/security/shishi/Makefile
index b70a2c77f0a7..169a2d08e738 100644
--- a/security/shishi/Makefile
+++ b/security/shishi/Makefile
@@ -8,16 +8,17 @@
PORTNAME= shishi
PORTVERSION= 1.0.1
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= GNU
MAINTAINER= johans@FreeBSD.org
COMMENT= A free implementation of the Kerberos 5 network security system
-LIB_DEPENDS= idn.17:${PORTSDIR}/dns/libidn \
- tasn1.4:${PORTSDIR}/security/libtasn1 \
- gcrypt.18:${PORTSDIR}/security/libgcrypt \
- gnutls.47:${PORTSDIR}/security/gnutls
+LIB_DEPENDS= idn:${PORTSDIR}/dns/libidn \
+ tasn1:${PORTSDIR}/security/libtasn1 \
+ gcrypt:${PORTSDIR}/security/libgcrypt \
+ gnutls:${PORTSDIR}/security/gnutls
USE_AUTOTOOLS= libtool
USE_PERL5_BUILD= yes
diff --git a/security/shishi/files/patch-configure b/security/shishi/files/patch-configure
new file mode 100644
index 000000000000..5139ad56b1c0
--- /dev/null
+++ b/security/shishi/files/patch-configure
@@ -0,0 +1,59 @@
+The upstream configuration is not able to properly detect
+the use of "resolv.h" and res_query() on BSD systems.
+As a consequence of this the built library libshishi.so
+is not able to question a DNS server for SRV resources.
+
+http://lists.gnu.org/archive/html/help-shishi/2012-07/msg00001.html
+
+--- configure.bak 2012-07-17 17:41:29.000000000 +0200
++++ configure 2012-07-17 17:48:44.000000000 +0200
+@@ -6688,10 +6688,11 @@
+
+ fi
+
+-for ac_header in termios.h pwd.h syslog.h resolv.h arpa/nameser.h netinet/in6.h
++for ac_header in termios.h pwd.h syslog.h arpa/nameser.h netinet/in6.h
+ do :
+ as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
+-ac_fn_c_check_header_mongrel "$LINENO" "$ac_header" "$as_ac_Header" "$ac_includes_default"
++ac_fn_c_check_header_mongrel "$LINENO" "$ac_header" "$as_ac_Header" "$ac_includes_default
++"
+ if eval test \"x\$"$as_ac_Header"\" = x"yes"; then :
+ cat >>confdefs.h <<_ACEOF
+ #define `$as_echo "HAVE_$ac_header" | $as_tr_cpp` 1
+@@ -6701,6 +6702,15 @@
+
+ done
+
++# Check for resolv.h
++ac_fn_c_check_header_mongrel "$LINENO" "resolv.h" "as_ac_resolv_h" "$ac_includes_default
++#include <sys/types.h>
++#include <netinet/in.h>"
++if test "x$as_ac_resolv_h" = x"yes"; then :
++ cat >>confdefs.h <<_ACEOF
++#define HAVE_RESOLV_H 1
++_ACEOF
++fi
+
+ # Used when creating libshishi-XX.def.
+ SOVERSION=`expr ${LT_CURRENT} - ${LT_AGE}`
+@@ -33526,7 +33536,7 @@
+ fi
+
+ # Checks for library functions.
+-for ac_func in signal select ngettext gethostbyname getpwnam getuid
++for ac_func in signal select ngettext gethostbyname getpwnam getuid res_query
+ do :
+ as_ac_var=`$as_echo "ac_cv_func_$ac_func" | $as_tr_sh`
+ ac_fn_c_check_func "$LINENO" "$ac_func" "$as_ac_var"
+--- lib/resolv.c.bak 2012-02-08 13:17:44.000000000 +0100
++++ lib/resolv.c 2012-07-17 17:41:29.000000000 +0200
+@@ -30,7 +30,7 @@
+
+ #include "internal.h"
+
+-#ifdef HAVE_LIBRESOLV
++#ifdef HAVE_RES_QUERY
+
+ /* the largest packet we'll send and receive */
+ #if PACKETSZ > 1024
diff --git a/security/shishi/pkg-plist b/security/shishi/pkg-plist
index d8651d7b604c..31fcec117f7b 100644
--- a/security/shishi/pkg-plist
+++ b/security/shishi/pkg-plist
@@ -35,4 +35,4 @@ libdata/pkgconfig/shishi.pc
@dirrmtry etc/shishi
@dirrmtry lib/security
@exec mkdir -m 0700 -p /var/shishi
-@dirrmtry /var/shishi
+@unexec rmdir /var/shishi 2>/dev/null || true