aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-11-30 16:02:41 +0800
committerJan Beich <jbeich@FreeBSD.org>2019-11-30 16:02:41 +0800
commit9114bdad78c43451acdc5ef7dd55d1323d7d5ce2 (patch)
treedf91dd79062f09f734c9df3d4d4ecd5944375e3a
parent8202ac49102fa73db34235f80662a7b83ce6bbc0 (diff)
downloadfreebsd-ports-gnome-9114bdad78c43451acdc5ef7dd55d1323d7d5ce2.tar.gz
freebsd-ports-gnome-9114bdad78c43451acdc5ef7dd55d1323d7d5ce2.tar.zst
freebsd-ports-gnome-9114bdad78c43451acdc5ef7dd55d1323d7d5ce2.zip
devel/dmlc-core: drop devel/llvm80 dependency
find_package(OpenMP) was fixed in r497948, so use devel/openmp but only on FreeBSD 12.0 as later versions have /usr/lib/libomp.so.
-rw-r--r--devel/dmlc-core/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/devel/dmlc-core/Makefile b/devel/dmlc-core/Makefile
index 421b17b76c90..b90110c5a62b 100644
--- a/devel/dmlc-core/Makefile
+++ b/devel/dmlc-core/Makefile
@@ -4,7 +4,7 @@ PORTNAME= dmlc-core
DISTVERSIONPREFIX= v
DISTVERSION= 0.3-105
DISTVERSIONSUFFIX= -g32d9fe7
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
MAINTAINER= yuri@FreeBSD.org
@@ -12,18 +12,18 @@ COMMENT= Common library for scalable and portable distributed machine learning
LICENSE= APACHE20
-BUILD_DEPENDS= llvm80>0:devel/llvm80
-
-USES= cmake
+USES= cmake compiler:c++11-lang
USE_GITHUB= yes
GH_ACCOUNT= dmlc
USE_LDCONFIG= yes
CMAKE_ON= BUILD_SHARED_LIBS
-# use clang from ports because otherwise OpenMP isn't detected on some systems (ex. 12.0-RELEASE-p9)
-CPP= clang-cpp80
-CC= clang80
-CXX= clang++80
+.include <bsd.port.pre.mk>
+
+# XXX Drop after FreeBSD 12.0 EOL
+.if ${CHOSEN_COMPILER_TYPE} == clang && !exists(/usr/include/omp.h)
+LIB_DEPENDS+= libomp.so:devel/openmp
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>