aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2009-06-17 05:58:31 +0800
committeracm <acm@FreeBSD.org>2009-06-17 05:58:31 +0800
commit9248fdb92ed7575e3bd456845fa34fb3a81e05af (patch)
tree876fc761666b1a01dbf0b484e8eff7e121d1ac16
parent7109aa32bb44873a03ce58b6b3cff9e0d7a8ff93 (diff)
downloadfreebsd-ports-gnome-9248fdb92ed7575e3bd456845fa34fb3a81e05af.tar.gz
freebsd-ports-gnome-9248fdb92ed7575e3bd456845fa34fb3a81e05af.tar.zst
freebsd-ports-gnome-9248fdb92ed7575e3bd456845fa34fb3a81e05af.zip
- Update to 4.0.1
- Take maintainership - Remove pkg-message file. Now it can install filter ports optionally
-rw-r--r--print/foomatic-filters/Makefile86
-rw-r--r--print/foomatic-filters/distinfo6
-rw-r--r--print/foomatic-filters/pkg-descr2
-rw-r--r--print/foomatic-filters/pkg-message12
-rw-r--r--print/foomatic-filters/pkg-plist21
5 files changed, 92 insertions, 35 deletions
diff --git a/print/foomatic-filters/Makefile b/print/foomatic-filters/Makefile
index a080fe36c39d..092026f2fd93 100644
--- a/print/foomatic-filters/Makefile
+++ b/print/foomatic-filters/Makefile
@@ -6,30 +6,98 @@
#
PORTNAME= foomatic-filters
-PORTVERSION= 3.0.2
-PORTREVISION= 4
+PORTVERSION= 4.0.1
CATEGORIES= print
MASTER_SITES= http://www.linuxprinting.org/download/foomatic/ \
- http://www.linuxprinting.org/download/foomatic/oldstuff/
+ http://www.openprinting.org/download/foomatic/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= acm@FreeBSD.org
COMMENT= Foomatic wrapper scripts
+USE_AUTOTOOLS= autoheader:262
USE_PERL5= yes
+USE_GHOSTSCRIPT=yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_path_A2PS=${LOCALBASE}/bin/a2ps \
ac_cv_path_CUPS=${LOCALBASE}/libexec/cups \
ac_cv_path_CUPS_FILTERS=${LOCALBASE}/libexec/cups/filter \
+ ac_cv_path_CUPS_BACKENDS=${LOCALBASE}/libexec/cups/backend \
ac_cv_path_ENSCRIPT=${LOCALBASE}/bin/enscript \
ac_cv_path_MPAGE=${LOCALBASE}/bin/mpage \
ac_cv_path_PPR=${LOCALBASE}/lib/ppr \
ac_cv_path_PPR_INTERFACES=${LOCALBASE}/lib/ppr/interfaces \
ac_cv_path_PPR_LIB=${LOCALBASE}/lib/ppr/lib \
- ac_cv_path_TEXTTOPS=${LOCALBASE}/libexec/cups/filter/texttops
+ ac_cv_path_TEXTTOPS=${LOCALBASE}/libexec/cups/filter/texttops \
+ CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
-MAN1= foomatic-gswrapper.1 foomatic-rip.1
+OPTIONS= CUPS_IMAGE "Install cups image utilities" on \
+ A2PS_A4 "Install a2ps convertor (A4)" on \
+ A2PS_LETTER "Install a2ps convertor (letter)" off \
+ A2PS_LETTERDJ "Install a2ps convertor (letterdj)" off \
+ ENSCRIPT_A4 "Install enscript convertor (A4)" on \
+ ENSCRIPT_LETTER "Install enscript convertor (letter)" off \
+ ENSCRIPT_LETTERDJ "Install enscript convertor (letterdj)" off \
+ MPAGE "Print multiple pages per sheet of paper" on
-post-install:
- @${CAT} ${PKGMESSAGE}
+MAN1= foomatic-rip.1
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_CUPS_IMAGE)
+RUN_DEPENDS+= ${LOCALBASE}/lib/libcupsimage.so:${PORTSDIR}/print/cups-image
+.endif
+
+.if defined(WITH_A2PS_A4)
+. if defined(WITH_A2PS_LETTER) || defined(WITH_A2PS_LETTERDJ)
+IGNORE= Please select only one option of a2ps-[a4|letter|letterdj] convertor
+. else
+RUN_DEPENDS+= a2ps:${PORTSDIR}/print/a2ps-a4
+. endif
+.endif
+
+.if defined(WITH_A2PS_LETTER)
+. if defined(WITH_A2PS_A4) || defined(WITH_A2PS_LETTERDJ)
+IGNORE= Please select only one option of a2ps-[a4|letter|letterdj] convertor
+. else
+RUN_DEPENDS+= a2ps:${PORTSDIR}/print/a2ps-letter
+. endif
+.endif
+
+.if defined(WITH_A2PS-LETTERDJ)
+. if defined(WITH_A2PS-A4) || defined(WITH_A2PS_LETTER)
+IGNORE= Please select only one option of a2ps-[a4|letter|letterdj] convertor
+. else
+RUN_DEPENDS+= a2ps:${PORTSDIR}/print/a2ps-letterdj
+. endif
+.endif
+
+.if defined(WITH_ENSCRIPT_A4)
+. if defined(WITH_ENSCRIPT_LETTER) || defined(WITH_ENSCRIPT_LETTERDJ)
+IGNORE= Please just select one option of enscript-[a4|letter|letterdj] convertor
+. else
+RUN_DEPENDS+= enscript:${PORTSDIR}/print/enscript-a4
+. endif
+.endif
+
+.if defined(WITH_ENSCRIPT_LETTER)
+. if defined(WITH_ENSCRIPT_A4) || defined(WITH_ENSCRIPT_LETTERDJ)
+IGNORE= Please just select one option of enscript-[a4|letter|letterdj] convertor
+. else
+RUN_DEPENDS+= enscript:${PORTSDIR}/print/enscript-letter
+. endif
+.endif
+
+.if defined(WITH_ENSCRIPT_LETTERDJ)
+. if defined(WITH_ENSCRIPT_A4) || defined(WITH_ENSCRIPT_LETTER)
+IGNORE= Please just select one option of enscript-[a4|letter|letterdj] convertor
+. else
+RUN_DEPENDS+= enscript:${PORTSDIR}/print/enscript-letterdj
+. endif
+.endif
+
+.if defined(WITH_MPAGE)
+RUN_DEPENDS+= mpage:${PORTSDIR}/print/mpage
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/print/foomatic-filters/distinfo b/print/foomatic-filters/distinfo
index 102645609edb..1ea05ede75e0 100644
--- a/print/foomatic-filters/distinfo
+++ b/print/foomatic-filters/distinfo
@@ -1,3 +1,3 @@
-MD5 (foomatic-filters-3.0.2.tar.gz) = f0f4c90fa0ae346f53bf19a165e071a6
-SHA256 (foomatic-filters-3.0.2.tar.gz) = 161dc80957cdbcb0c43dc4f1db08968e3ee645b64eff9342294b33fe95436792
-SIZE (foomatic-filters-3.0.2.tar.gz) = 125875
+MD5 (foomatic-filters-4.0.1.tar.gz) = 40487f6619522eb60eede529747d7a69
+SHA256 (foomatic-filters-4.0.1.tar.gz) = e435de7297493a0f088f56ae8cee3375632dad55a6f1eea5f149cac397a5d05f
+SIZE (foomatic-filters-4.0.1.tar.gz) = 237419
diff --git a/print/foomatic-filters/pkg-descr b/print/foomatic-filters/pkg-descr
index 7e5786c84d4c..51a02099cb11 100644
--- a/print/foomatic-filters/pkg-descr
+++ b/print/foomatic-filters/pkg-descr
@@ -2,4 +2,4 @@ Filter scripts used by the printer spoolers to convert the incoming
PostScript data into the printer's native format using a
printer/driver specific, but spooler-independent PPD file.
-WWW: http://www.linuxprinting.org
+WWW: http://www.openprinting.org
diff --git a/print/foomatic-filters/pkg-message b/print/foomatic-filters/pkg-message
deleted file mode 100644
index 51b350c6f42e..000000000000
--- a/print/foomatic-filters/pkg-message
+++ /dev/null
@@ -1,12 +0,0 @@
-
-*******************************************************************************
-
-Foomatic-rip requires at least one filter to convert text to postscript, please
-install one of these filters/ports in order to complete your installation:
-
- a2ps - print/a2ps-[a4|letter|letterdj]
- enscript - print/enscript-[a4|letter|letterdj]
- mpage - print/mpage
- texttops - print/cups-base
-
-*******************************************************************************
diff --git a/print/foomatic-filters/pkg-plist b/print/foomatic-filters/pkg-plist
index 31a49f048c08..46295036f696 100644
--- a/print/foomatic-filters/pkg-plist
+++ b/print/foomatic-filters/pkg-plist
@@ -1,15 +1,16 @@
-bin/foomatic-gswrapper
bin/foomatic-rip
@unexec if cmp -s %D/etc/foomatic/filter.conf %D/etc/foomatic/filter.conf.sample; then rm -f %D/etc/foomatic/filter.conf; fi
etc/foomatic/filter.conf.sample
+libexec/cups/backend/beh
+libexec/cups/filter/foomatic-rip
lib/ppr/interfaces/foomatic-rip
lib/ppr/lib/foomatic-rip
-libexec/cups/filter/foomatic-rip
-@exec /bin/mkdir -p %D/etc/foomatic/direct
-@unexec /bin/rmdir %D/etc/foomatic/direct 2>/dev/null || true
-@unexec /bin/rmdir %D/libexec/cups/filter 2>/dev/null || true
-@unexec /bin/rmdir %D/libexec/cups 2>/dev/null || true
-@dirrm lib/ppr/lib
-@dirrm lib/ppr/interfaces
-@dirrm lib/ppr
-@unexec /bin/rmdir %D/etc/foomatic 2>/dev/null || true
+@dirrmtry libexec/cups/backend
+@dirrmtry libexec/cups/filter
+@dirrmtry etc/foomatic/direct
+@dirrmtry etc/foomatic
+@dirrmtry lib/ppr/lib
+@dirrmtry lib/ppr/interfaces
+@dirrmtry lib/ppr
+@dirrmtry libexec/cups/filter
+@dirrmtry libexec/cups