aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2019-05-06 11:13:22 +0800
committerpi <pi@FreeBSD.org>2019-05-06 11:13:22 +0800
commit92cc73c3b39ccb8874e13bf2b87ab17fb0789730 (patch)
tree4772d1ba75f36a7a39325372a2aa8fdf3e9bed5f
parent87e114932482349457fa960d5df2048b2550c7f3 (diff)
downloadfreebsd-ports-gnome-92cc73c3b39ccb8874e13bf2b87ab17fb0789730.tar.gz
freebsd-ports-gnome-92cc73c3b39ccb8874e13bf2b87ab17fb0789730.tar.zst
freebsd-ports-gnome-92cc73c3b39ccb8874e13bf2b87ab17fb0789730.zip
New port: emulators/pcem: PC-Compatible low-level emulator striving for accuracy
A very accurate (and not very fast) PC and PC-compatible emulator. Support currently ranges from the original IBM PC to Socket 7 motherboards. It also supports a wide range of peripherals, including Voodoo Graphics! WWW: https://www.pcem-emulator.co.uk PR: 237376 Submitted by: Salvador Pardinas <darkfm@vera.com.uy> Reviewed by: tobik
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/pcem/Makefile36
-rw-r--r--emulators/pcem/distinfo3
-rw-r--r--emulators/pcem/files/patch-configure.ac32
-rw-r--r--emulators/pcem/pkg-descr5
5 files changed, 77 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 4fa460f8815f..78c68b2d0a1d 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -101,6 +101,7 @@
SUBDIR += openmsx
SUBDIR += p5-Acme-6502
SUBDIR += parallels-tools
+ SUBDIR += pcem
SUBDIR += pcemu
SUBDIR += pcsxr
SUBDIR += pearpc
diff --git a/emulators/pcem/Makefile b/emulators/pcem/Makefile
new file mode 100644
index 000000000000..afffc88983ce
--- /dev/null
+++ b/emulators/pcem/Makefile
@@ -0,0 +1,36 @@
+# $FreeBSD$
+
+PORTNAME= pcem
+DISTVERSION= 14
+CATEGORIES= emulators
+MASTER_SITES= https://bitbucket.org/pcem_emulator/pcem/get/
+DISTNAME= faf5d6423060
+
+MAINTAINER= darkfm@vera.com.uy
+COMMENT= PC/PC-Compatible low-level emulator striving for accuracy
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libGL.so:graphics/mesa-libs \
+ libopenal.so:audio/openal-soft \
+ libwx_gtk3u_core-3.0.so:x11-toolkits/wxgtk30 \
+ libSDL2.so:devel/sdl20
+
+USES= autoreconf compiler gmake openal:soft pkgconfig sdl zip
+USE_WX= 3.0
+USE_SDL= sdl2
+
+WRKSRC= ${WRKDIR}/pcem_emulator-pcem-faf5d6423060/
+PATCHDIR=files
+PLIST_FILES= bin/pcem
+CONFIGURE_ARGS= --enable-release-build --with-wx-config=wxgtk3u-3.0-config
+GNU_CONFIGURE= yes
+ONLY_FOR_ARCHS= amd64
+
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1300000
+LDFLAGS+= -fuse-ld=bfd
+.endif
+
+.include <bsd.port.mk>
diff --git a/emulators/pcem/distinfo b/emulators/pcem/distinfo
new file mode 100644
index 000000000000..5ebb32de2f5c
--- /dev/null
+++ b/emulators/pcem/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1555640654
+SHA256 (faf5d6423060.zip) = c184c1e279b2d77d89bdc02ed6a87d0f79b98863dcef2feca1fff74554e2f19b
+SIZE (faf5d6423060.zip) = 1792228
diff --git a/emulators/pcem/files/patch-configure.ac b/emulators/pcem/files/patch-configure.ac
new file mode 100644
index 000000000000..f1eacfb448b7
--- /dev/null
+++ b/emulators/pcem/files/patch-configure.ac
@@ -0,0 +1,32 @@
+--- configure.ac.orig 2019-04-17 19:37:48 UTC
++++ configure.ac
+@@ -64,6 +64,10 @@ case "${host_cpu}" in
+ CPU=x86_64
+ AC_MSG_RESULT(${host_cpu})
+ ;;
++ amd64)
++ CPU=x86_64
++ AC_MSG_RESULT(${host_cpu})
++ ;;
+ *)
+ AC_MSG_ERROR([Unsupported CPU.])
+ ;;
+@@ -149,6 +153,18 @@ case "$host" in
+ [echo "You need to install the OpenAL library."
+ exit -1])
+ build_linux="yes"
++ ;;
++ *-*-freebsd*)
++ CFLAGS="$CFLAGS -I/usr/local/include"
++ CXXFLAGS="$CXXFLAGS -I/usr/local/include"
++ LDFLAGS="$LDFLAGS -L/usr/local/lib"
++ AC_CHECK_LIB([GL], [glGetError], [], \
++ [echo "You need to install the OpenGL library."
++ exit -1])
++ AC_CHECK_LIB([openal], [alGetError], [], \
++ [echo "You need to install the OpenAL library."
++ exit -1])
++ build_other="yes"
+ ;;
+ *)
+ AC_CHECK_LIB([GL], [glGetError], [], \
diff --git a/emulators/pcem/pkg-descr b/emulators/pcem/pkg-descr
new file mode 100644
index 000000000000..f4c9887ec130
--- /dev/null
+++ b/emulators/pcem/pkg-descr
@@ -0,0 +1,5 @@
+A very accurate (and not very fast) PC and PC-compatible emulator.
+Support currently ranges from the original IBM PC to Socket 7 motherboards.
+It also supports a wide range of peripherals, including Voodoo Graphics!
+
+WWW: https://www.pcem-emulator.co.uk