aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorstephen <stephen@FreeBSD.org>2015-11-28 13:30:18 +0800
committerstephen <stephen@FreeBSD.org>2015-11-28 13:30:18 +0800
commit92eb0a5e0d60851a9bcecfc493ab81a9675d5d61 (patch)
treeb32e3dbefed8c65c33e7e237b3e3d40edeb6c67f
parenta32683989648166ba242e36bb73f60479788dc81 (diff)
downloadfreebsd-ports-gnome-92eb0a5e0d60851a9bcecfc493ab81a9675d5d61.tar.gz
freebsd-ports-gnome-92eb0a5e0d60851a9bcecfc493ab81a9675d5d61.tar.zst
freebsd-ports-gnome-92eb0a5e0d60851a9bcecfc493ab81a9675d5d61.zip
- Add name mangling so that it will build when science/netcdf is installed.
- Bump portrevision.
-rw-r--r--math/vtk6/Makefile11
-rw-r--r--math/vtk6/pkg-plist2
2 files changed, 12 insertions, 1 deletions
diff --git a/math/vtk6/Makefile b/math/vtk6/Makefile
index 6fbe436320ed..5a1c02be1359 100644
--- a/math/vtk6/Makefile
+++ b/math/vtk6/Makefile
@@ -3,6 +3,7 @@
PORTNAME= vtk
PORTVERSION= 6.2.0
+PORTREVISION= 1
CATEGORIES= math graphics
MASTER_SITES= http://www.vtk.org/files/release/${VTK_SHORT_VER}/
PKGNAMESUFFIX= 6
@@ -81,6 +82,16 @@ CMAKE_ARGS+= -DVTK_INSTALL_LIBRARY_DIR=lib/vtk-${VTK_SHORT_VER} \
SHARED_CMAKE_ON= -DBUILD_SHARED_LIBS:BOOL=ON
SHARED_CMAKE_OFF= -DBUILD_SHARED_LIBS:BOOL=OFF
+# Mangling so that port will build when science/netcdf is installed.
+post-patch:
+ ${MV} ${WRKSRC}/ThirdParty/netcdf/vtknetcdf/include/netcdf.h \
+ ${WRKSRC}/ThirdParty/netcdf/vtknetcdf/include/xxxnetcdf.h
+ ${FIND} ${WRKSRC}/ThirdParty/netcdf -type f | ${XARGS} ${REINPLACE_CMD} \
+ -E 's/[[:<:]]netcdf\.h[[:>:]]/xxxnetcdf.h/'
+# ${FIND} ${WRKSRC}/ThirdParty/netcdf -type f | ${XARGS} ${REINPLACE_CMD} \
+# -E 's/[[:<:]]libnetcdf[[:>:]]/libxxxnetcdf/'
+# ${FIND} ${WRKSRC}/ThirdParty/netcdf -type f | ${XARGS} ${REINPLACE_CMD} \
+# -E 's/[[:<:]]-lnetcdf[[:>:]]/-lxxxnetcdf/'
.include <bsd.port.options.mk>
diff --git a/math/vtk6/pkg-plist b/math/vtk6/pkg-plist
index d69d0d22f723..77493183d2e4 100644
--- a/math/vtk6/pkg-plist
+++ b/math/vtk6/pkg-plist
@@ -4306,7 +4306,7 @@ include/vtk-%%VER2%%/vtkmetaio/metaTypes.h
include/vtk-%%VER2%%/vtkmetaio/metaUtils.h
include/vtk-%%VER2%%/vtkmetaio/metaVesselTube.h
include/vtk-%%VER2%%/vtknetcdf/include/ncvalues.h
-include/vtk-%%VER2%%/vtknetcdf/include/netcdf.h
+include/vtk-%%VER2%%/vtknetcdf/include/xxxnetcdf.h
include/vtk-%%VER2%%/vtknetcdf/include/netcdf.hh
include/vtk-%%VER2%%/vtknetcdf/include/netcdfcpp.h
include/vtk-%%VER2%%/vtknetcdf/include/vtk_netcdf_config.h