aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2012-03-20 06:22:47 +0800
committerjgh <jgh@FreeBSD.org>2012-03-20 06:22:47 +0800
commit9345dbbf25853e620ab734ed0944b74f0c70da50 (patch)
tree3549aa3310bf4d04733cac8e5b66fa9eaa5be0e7
parent9894123a709785995942810749b60c459c89be6c (diff)
downloadfreebsd-ports-gnome-9345dbbf25853e620ab734ed0944b74f0c70da50.tar.gz
freebsd-ports-gnome-9345dbbf25853e620ab734ed0944b74f0c70da50.tar.zst
freebsd-ports-gnome-9345dbbf25853e620ab734ed0944b74f0c70da50.zip
Add new port: java/eclipse-ecj
An incremental Java compiler. Implemented as an Eclipse builder, it is based on technology evolved from VisualAge for Java compiler. In particular, it allows to run and debug code which still contains unresolved errors. WWW: http://www.eclipse.org/ Feature safe: yes
-rw-r--r--java/Makefile1
-rw-r--r--java/eclipse-ecj/Makefile39
-rw-r--r--java/eclipse-ecj/distinfo2
-rw-r--r--java/eclipse-ecj/files/ecj.sh.in3
-rw-r--r--java/eclipse-ecj/pkg-descr5
5 files changed, 50 insertions, 0 deletions
diff --git a/java/Makefile b/java/Makefile
index 5c2f59596581..25cb15afb209 100644
--- a/java/Makefile
+++ b/java/Makefile
@@ -31,6 +31,7 @@
SUBDIR += eclipse-datatools
SUBDIR += eclipse-devel
SUBDIR += eclipse-drjava
+ SUBDIR += eclipse-ecj
SUBDIR += eclipse-emf
SUBDIR += eclipse-examples
SUBDIR += eclipse-findbugs
diff --git a/java/eclipse-ecj/Makefile b/java/eclipse-ecj/Makefile
new file mode 100644
index 000000000000..0b5b8b9e2056
--- /dev/null
+++ b/java/eclipse-ecj/Makefile
@@ -0,0 +1,39 @@
+# New ports collection: eclipse-ecj
+# Date created: 17 March 2012
+# Whom: Jason Helfman
+#
+# $FreeBSD$
+
+PORTNAME= ecj
+PORTVERSION= 3.7.2
+CATEGORIES= java devel
+MASTER_SITES= ECLIPSE
+MASTER_SITE_SUBDIR= R-${PORTVERSION}-${DROPDATE}
+PKGNAMEPREFIX= eclipse-
+DISTNAME= ecjsrc-${PORTVERSION}
+EXTRACT_SUFX= .jar
+
+MAINTAINER= jgh@FreeBSD.org
+COMMENT= Eclipse Java Compiler
+
+LICENSE= EPL
+
+EXTRACT_CMD= ${TAR}
+EXTRACT_BEFORE_ARGS= xf
+EXTRACT_AFTER_ARGS= -C ${WRKDIR}
+
+USE_ANT= yes
+USE_JAVA= yes
+BUILD_WRKSRC= ${WRKDIR}
+SUB_FILES= ecj.sh
+SUB_LIST= JAVAC=${JAVAC}
+
+DROPDATE= 201202080800
+PLIST_FILES= bin/${PORTNAME}.sh \
+ %%JAVAJARDIR%%/${PORTNAME}.jar
+
+do-install:
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}.jar ${JAVAJARDIR}/${PORTNAME}.jar
+ ${INSTALL_SCRIPT} ${WRKDIR}/ecj.sh ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/java/eclipse-ecj/distinfo b/java/eclipse-ecj/distinfo
new file mode 100644
index 000000000000..7dfcf4696091
--- /dev/null
+++ b/java/eclipse-ecj/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ecjsrc-3.7.2.jar) = 755d871c3066f15cfaf5ea84075527eb97c92f9685058c3a326057e797f69e6b
+SIZE (ecjsrc-3.7.2.jar) = 1366333
diff --git a/java/eclipse-ecj/files/ecj.sh.in b/java/eclipse-ecj/files/ecj.sh.in
new file mode 100644
index 000000000000..9fe6061baabd
--- /dev/null
+++ b/java/eclipse-ecj/files/ecj.sh.in
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+%%JAVAC%% -classpath %%JAVAJARDIR%%/ecj.jar $1
diff --git a/java/eclipse-ecj/pkg-descr b/java/eclipse-ecj/pkg-descr
new file mode 100644
index 000000000000..5120ac4d7fb9
--- /dev/null
+++ b/java/eclipse-ecj/pkg-descr
@@ -0,0 +1,5 @@
+An incremental Java compiler. Implemented as an Eclipse builder, it is based on
+technology evolved from VisualAge for Java compiler. In particular, it allows to
+run and debug code which still contains unresolved errors.
+
+WWW: http://www.eclipse.org/