aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-10-24 23:53:22 +0800
committerRenato Botelho <garga@FreeBSD.org>2005-10-24 23:53:22 +0800
commit949cd78dcf417bc4fd6d57a5d80fd9a008feed1a (patch)
tree942ac560ebc48eba65ed26acc427a7633585fd26
parentbb571f09157bbf6224ebb1011bfbfd51af79cbdb (diff)
downloadfreebsd-ports-gnome-949cd78dcf417bc4fd6d57a5d80fd9a008feed1a.tar.gz
freebsd-ports-gnome-949cd78dcf417bc4fd6d57a5d80fd9a008feed1a.tar.zst
freebsd-ports-gnome-949cd78dcf417bc4fd6d57a5d80fd9a008feed1a.zip
Add p5-XML-Filter-DOMFilter-LibXML 0.02, perl SAX Filter allowing DOM
processing of selected subtrees. PR: ports/87902 Submitted by: Andrew Humphrey <ahumphrey@realestate.com.au>
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-XML-Filter-DOMFilter-LibXML/Makefile31
-rw-r--r--textproc/p5-XML-Filter-DOMFilter-LibXML/distinfo2
-rw-r--r--textproc/p5-XML-Filter-DOMFilter-LibXML/pkg-descr3
-rw-r--r--textproc/p5-XML-Filter-DOMFilter-LibXML/pkg-plist8
5 files changed, 45 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 399f3a115209..9ac3f4fd427f 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -468,6 +468,7 @@
SUBDIR += p5-XML-Encoding
SUBDIR += p5-XML-Feed
SUBDIR += p5-XML-Filter-BufferText
+ SUBDIR += p5-XML-Filter-DOMFilter-LibXML
SUBDIR += p5-XML-Filter-DetectWS
SUBDIR += p5-XML-Filter-GenericChunk
SUBDIR += p5-XML-Filter-Reindent
diff --git a/textproc/p5-XML-Filter-DOMFilter-LibXML/Makefile b/textproc/p5-XML-Filter-DOMFilter-LibXML/Makefile
new file mode 100644
index 000000000000..e38292837d8e
--- /dev/null
+++ b/textproc/p5-XML-Filter-DOMFilter-LibXML/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-XML-Filter-DOMFilter-LibXML
+# Date created: 24 October 2005
+# Whom: Andrew Humphrey <ahumphrey@realestate.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-Filter-DOMFilter-LibXML
+PORTVERSION= 0.02
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ahumphrey@realestate.com.au
+COMMENT= Perl SAX Filter allowing DOM processing of selected subtrees
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::Filter::DOMFilter::LibXML.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BROKEN= "Doesn't build with perl < 5.6.x"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-XML-Filter-DOMFilter-LibXML/distinfo b/textproc/p5-XML-Filter-DOMFilter-LibXML/distinfo
new file mode 100644
index 000000000000..070b024ad11d
--- /dev/null
+++ b/textproc/p5-XML-Filter-DOMFilter-LibXML/distinfo
@@ -0,0 +1,2 @@
+MD5 (XML-Filter-DOMFilter-LibXML-0.02.tar.gz) = 9089d02fbd5ff914070af4c3b9142f02
+SIZE (XML-Filter-DOMFilter-LibXML-0.02.tar.gz) = 4215
diff --git a/textproc/p5-XML-Filter-DOMFilter-LibXML/pkg-descr b/textproc/p5-XML-Filter-DOMFilter-LibXML/pkg-descr
new file mode 100644
index 000000000000..eb2584fcd116
--- /dev/null
+++ b/textproc/p5-XML-Filter-DOMFilter-LibXML/pkg-descr
@@ -0,0 +1,3 @@
+Perl SAX Filter allowing DOM processing of selected subtrees
+
+WWW: http://search.cpan.org/dist/XML-Filter-DOMFilter-LibXML/
diff --git a/textproc/p5-XML-Filter-DOMFilter-LibXML/pkg-plist b/textproc/p5-XML-Filter-DOMFilter-LibXML/pkg-plist
new file mode 100644
index 000000000000..3a3bc7061d4a
--- /dev/null
+++ b/textproc/p5-XML-Filter-DOMFilter-LibXML/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/XML/Filter/DOMFilter/LibXML.pm
+@dirrm %%SITE_PERL%%/XML/Filter/DOMFilter
+@dirrm %%SITE_PERL%%/XML/Filter
+%%SITE_PERL%%/mach/auto/XML/Filter/DOMFilter/LibXML/.packlist
+@dirrm %%SITE_PERL%%/mach/auto/XML/Filter/DOMFilter/LibXML
+@dirrm %%SITE_PERL%%/mach/auto/XML/Filter/DOMFilter
+@dirrm %%SITE_PERL%%/mach/auto/XML/Filter
+@dirrm %%SITE_PERL%%/mach/auto/XML