aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2016-03-06 03:00:04 +0800
committerrm <rm@FreeBSD.org>2016-03-06 03:00:04 +0800
commit95cea769a7ec63596f560bf6673c9da407cc0d41 (patch)
treeed3f41232aa5198a0bdf6626ef14f81cd40782f4
parent5265f085dc231d27d4697ba9546ced02b937045e (diff)
downloadfreebsd-ports-gnome-95cea769a7ec63596f560bf6673c9da407cc0d41.tar.gz
freebsd-ports-gnome-95cea769a7ec63596f560bf6673c9da407cc0d41.tar.zst
freebsd-ports-gnome-95cea769a7ec63596f560bf6673c9da407cc0d41.zip
textproc/intltool: fix warnings with perl 5.22
This patch eliminates warnings like this by escaping left brace: """ Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/^(.*)\${ <-- HERE ?([A-Z_]+)}?(.*)$/ at /usr/local/bin/intltool-update line 1065. Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/\${ <-- HERE ?AC_PACKAGE_NAME}?/ at /usr/local/bin/intltool-update line 1193. """ + 7 more warnings like this when building ports involving intltool (gitg, gnome-builder etc) While here replace brackets with braces in download url (porlint warning) and bump PORTREVISION because of package change. PR: 207270 With hat: gnome MFH: 2016Q1
-rw-r--r--textproc/intltool/Makefile3
-rw-r--r--textproc/intltool/files/patch-intltool-update.in51
2 files changed, 53 insertions, 1 deletions
diff --git a/textproc/intltool/Makefile b/textproc/intltool/Makefile
index f38dfabf0d3e..c36ef6f85fd9 100644
--- a/textproc/intltool/Makefile
+++ b/textproc/intltool/Makefile
@@ -3,8 +3,9 @@
PORTNAME= intltool
PORTVERSION= 0.51.0
+PORTREVISION= 1
CATEGORIES= textproc gnome
-MASTER_SITES= https://launchpad.net/intltool/trunk/$(PORTVERSION)/+download/
+MASTER_SITES= https://launchpad.net/intltool/trunk/${PORTVERSION}/+download/
DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
diff --git a/textproc/intltool/files/patch-intltool-update.in b/textproc/intltool/files/patch-intltool-update.in
new file mode 100644
index 000000000000..958e328853c6
--- /dev/null
+++ b/textproc/intltool/files/patch-intltool-update.in
@@ -0,0 +1,51 @@
+This patch eliminates warnings like this by escaping left brace:
+Unescaped left brace in regex is deprecated, passed through in regex;
+marked by <-- HERE in m/^(.*)\${ <-- HERE ?([A-Z_]+)}?(.*)$/ at /usr/local/bin/intltool-update line 1065.
+Unescaped left brace in regex is deprecated, passed through in regex;
+marked by <-- HERE in m/\${ <-- HERE ?AC_PACKAGE_NAME}?/ at /usr/local/bin/intltool-update line 1193.
+
+when building ports involving intltool (gitg, gnome-builder etc)
+
+--- intltool-update.in.orig 2015-03-09 01:39:54 UTC
++++ intltool-update.in
+@@ -1062,7 +1062,7 @@ sub SubstituteVariable
+ }
+ }
+
+- if ($str =~ /^(.*)\${?([A-Z_]+)}?(.*)$/)
++ if ($str =~ /^(.*)\$\{?([A-Z_]+)}?(.*)$/)
+ {
+ my $rest = $3;
+ my $untouched = $1;
+@@ -1190,10 +1190,10 @@ sub FindPackageName
+ $name =~ s/\(+$//g;
+ $version =~ s/\(+$//g;
+
+- $varhash{"PACKAGE_NAME"} = $name if (not $name =~ /\${?AC_PACKAGE_NAME}?/);
+- $varhash{"PACKAGE"} = $name if (not $name =~ /\${?PACKAGE}?/);
+- $varhash{"PACKAGE_VERSION"} = $version if (not $name =~ /\${?AC_PACKAGE_VERSION}?/);
+- $varhash{"VERSION"} = $version if (not $name =~ /\${?VERSION}?/);
++ $varhash{"PACKAGE_NAME"} = $name if (not $name =~ /\$\{?AC_PACKAGE_NAME}?/);
++ $varhash{"PACKAGE"} = $name if (not $name =~ /\$\{?PACKAGE}?/);
++ $varhash{"PACKAGE_VERSION"} = $version if (not $name =~ /\$\{?AC_PACKAGE_VERSION}?/);
++ $varhash{"VERSION"} = $version if (not $name =~ /\$\{?VERSION}?/);
+ }
+
+ if ($conf_source =~ /^AC_INIT\(([^,\)]+),([^,\)]+)[,]?([^,\)]+)?/m)
+@@ -1219,11 +1219,11 @@ sub FindPackageName
+ $version =~ s/\(+$//g;
+ $bugurl =~ s/\(+$//g if (defined $bugurl);
+
+- $varhash{"PACKAGE_NAME"} = $name if (not $name =~ /\${?AC_PACKAGE_NAME}?/);
+- $varhash{"PACKAGE"} = $name if (not $name =~ /\${?PACKAGE}?/);
+- $varhash{"PACKAGE_VERSION"} = $version if (not $name =~ /\${?AC_PACKAGE_VERSION}?/);
+- $varhash{"VERSION"} = $version if (not $name =~ /\${?VERSION}?/);
+- $varhash{"PACKAGE_BUGREPORT"} = $bugurl if (defined $bugurl and not $bugurl =~ /\${?\w+}?/);
++ $varhash{"PACKAGE_NAME"} = $name if (not $name =~ /\$\{?AC_PACKAGE_NAME}?/);
++ $varhash{"PACKAGE"} = $name if (not $name =~ /\$\{?PACKAGE}?/);
++ $varhash{"PACKAGE_VERSION"} = $version if (not $name =~ /\$\{?AC_PACKAGE_VERSION}?/);
++ $varhash{"VERSION"} = $version if (not $name =~ /\$\{?VERSION}?/);
++ $varhash{"PACKAGE_BUGREPORT"} = $bugurl if (defined $bugurl and not $bugurl =~ /\$\{?\w+}?/);
+ }
+
+ # \s makes this not work, why?