aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-08-18 08:13:39 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-08-18 08:13:39 +0800
commit9682319a53e3d3a9366371ffc6c0ef6eebfdc15a (patch)
tree9b34f06d9d3abb2929bbf349fec723c62db45f65
parentf651d1c63aac598ecdaeee74d8fa5a73e2eff67a (diff)
downloadfreebsd-ports-gnome-9682319a53e3d3a9366371ffc6c0ef6eebfdc15a.tar.gz
freebsd-ports-gnome-9682319a53e3d3a9366371ffc6c0ef6eebfdc15a.tar.zst
freebsd-ports-gnome-9682319a53e3d3a9366371ffc6c0ef6eebfdc15a.zip
Add py-publicsuffixlist 0.6.2
Public Suffix List parser implementation for Python. - Compliant with TEST DATA - Support IDN (unicode or punycoded). - Support Python 2.5+ and Python 3.x - Shipped with built-in PSL and the updater script. - Written in Pure Python. No library dependencies. WWW: https://github.com/ko-zu/psl
-rw-r--r--dns/Makefile1
-rw-r--r--dns/py-publicsuffixlist/Makefile27
-rw-r--r--dns/py-publicsuffixlist/distinfo3
-rw-r--r--dns/py-publicsuffixlist/pkg-descr8
4 files changed, 39 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index b1bc929a7173..9bfcdc0ac41f 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -196,6 +196,7 @@
SUBDIR += py-ldns
SUBDIR += py-namebench
SUBDIR += py-publicsuffix
+ SUBDIR += py-publicsuffixlist
SUBDIR += py-py3dns
SUBDIR += py-pycares
SUBDIR += py-pydnstable
diff --git a/dns/py-publicsuffixlist/Makefile b/dns/py-publicsuffixlist/Makefile
new file mode 100644
index 000000000000..8dd12f73b070
--- /dev/null
+++ b/dns/py-publicsuffixlist/Makefile
@@ -0,0 +1,27 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= publicsuffixlist
+PORTVERSION= 0.6.2
+CATEGORIES= dns python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Publicsuffixlist implementation
+
+LICENSE= MPL20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+PATCH_DEPENDS= public_suffix_list>=0:dns/public_suffix_list
+
+USE_PYTHON= autoplist concurrent distutils
+USES= python
+
+NO_ARCH= yes
+
+post-patch:
+ @${CP} ${LOCALBASE}/share/public_suffix_list/public_suffix_list.dat ${WRKSRC}/publicsuffixlist/public_suffix_list.dat
+ @${CP} ${LOCALBASE}/share/public_suffix_list/test_psl.txt ${WRKSRC}/publicsuffixlist/test_psl.txt
+
+.include <bsd.port.mk>
diff --git a/dns/py-publicsuffixlist/distinfo b/dns/py-publicsuffixlist/distinfo
new file mode 100644
index 000000000000..b741d04200d2
--- /dev/null
+++ b/dns/py-publicsuffixlist/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1533662410
+SHA256 (publicsuffixlist-0.6.2.tar.gz) = bbcfca8f251afdf38ce8c4f98b6f53fe9b214f09686095e4817776e31c60813a
+SIZE (publicsuffixlist-0.6.2.tar.gz) = 81153
diff --git a/dns/py-publicsuffixlist/pkg-descr b/dns/py-publicsuffixlist/pkg-descr
new file mode 100644
index 000000000000..8805618c6641
--- /dev/null
+++ b/dns/py-publicsuffixlist/pkg-descr
@@ -0,0 +1,8 @@
+Public Suffix List parser implementation for Python.
+- Compliant with TEST DATA
+- Support IDN (unicode or punycoded).
+- Support Python 2.5+ and Python 3.x
+- Shipped with built-in PSL and the updater script.
+- Written in Pure Python. No library dependencies.
+
+WWW: https://github.com/ko-zu/psl