aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2013-05-25 22:55:19 +0800
committermadpilot <madpilot@FreeBSD.org>2013-05-25 22:55:19 +0800
commit983e229dbb141d5d7f36e4df905fd52bca428c20 (patch)
tree36a8fd3f5f8a819a790eb0868ca94970cb61035a
parent20fe7f7e76a05c82371182620ca4a1d413a42547 (diff)
downloadfreebsd-ports-gnome-983e229dbb141d5d7f36e4df905fd52bca428c20.tar.gz
freebsd-ports-gnome-983e229dbb141d5d7f36e4df905fd52bca428c20.tar.zst
freebsd-ports-gnome-983e229dbb141d5d7f36e4df905fd52bca428c20.zip
- Patch postgrey to use PGY_GROUPNAME by default
- Don't show OPTIONS dialog for just DOCS option - Tidy up port Makefile - Rework rc script - Add UPDATING message and pkg-message to inform users about the rc script changes PR: ports/178644 Submitted by: Darren Pilgrim <ports.maintainer@evilphi.com> (maintainer)
-rw-r--r--UPDATING11
-rw-r--r--mail/postgrey/Makefile15
-rw-r--r--mail/postgrey/files/pkg-install.in9
-rw-r--r--mail/postgrey/files/postgrey.in42
-rw-r--r--mail/postgrey/pkg-message7
5 files changed, 45 insertions, 39 deletions
diff --git a/UPDATING b/UPDATING
index 0cfc792c5ce1..2f3da40c82ec 100644
--- a/UPDATING
+++ b/UPDATING
@@ -6,6 +6,17 @@ You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
20130525:
+ AFFECTS: users of mail/postgrey
+ AUTHOR: Darren Pilgrim <ports.maintainer@evilphi.com>
+
+ The RC script for postgrey has been modified. If you use the
+ default value for postgrey_flags this does not affect you.
+
+ If you have postgrey listening on a unix socket or set any optional
+ values, please read the comments in the RC scripts and check your
+ settings in rc.conf prior to restarting postgrey.
+
+20130525:
AFFECTS: users of x11/xorg and all xorg ports
AUTHOR zeising@FreeBSD.org
diff --git a/mail/postgrey/Makefile b/mail/postgrey/Makefile
index c0a50a646b84..a5758db77a77 100644
--- a/mail/postgrey/Makefile
+++ b/mail/postgrey/Makefile
@@ -3,7 +3,7 @@
PORTNAME= postgrey
PORTVERSION= 1.34
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= mail
MASTER_SITES= http://postgrey.schweikert.ch/pub/ \
http://postgrey.schweikert.ch/pub/old/
@@ -23,14 +23,13 @@ NO_BUILD= yes
POD2MAN?= pod2man
PORTDOCS= README Changes README.exim
SUB_FILES= pkg-install
-SUB_LIST= USER=${PGY_USERNAME} UID=${PGY_USERID} GROUP=${PGY_GROUPNAME} \
- GID=${PGY_GROUPID} ETCFILES="${ETCFILES}" \
+SUB_LIST= USER=${PGY_USERNAME} \
+ GROUP=${PGY_GROUPNAME} \
+ ETCFILES="${ETCFILES}" \
POSTGREYDIR=${PGY_DIR}
ETCFILES= whitelist_clients whitelist_recipients
PGY_USERNAME?= postgrey
-PGY_USERID?= 225
-PGY_GROUPNAME?= ${PGY_USERNAME}
-PGY_GROUPID?= ${PGY_USERID}
+PGY_GROUPNAME?= postgrey
PGY_DIR?= /var/db/postgrey
USERS= ${PGY_USERNAME}
@@ -40,12 +39,10 @@ MAN1= ${PORTNAME}.1 policy-test.1 postgreyreport.1
USES= shebangfix
SHEBANG_FILES= ${WRKSRC}/postgrey
-OPTIONS_DEFINE= DOCS
-OPTIONS_DEFAULT=DOCS
-
.include <bsd.port.options.mk>
post-patch:
+ @${REINPLACE_CMD} -e 's#nogroup#${PGY_GROUPNAME}#' ${WRKSRC}/postgrey
@${REINPLACE_CMD} -e 's#/etc/main.cf#/etc/postfix/main.cf#' ${WRKSRC}/postgrey
@${REINPLACE_CMD} -e 's#/etc/postfix#${PREFIX}&#' ${WRKSRC}/postgrey ${WRKSRC}/postgrey_whitelist_*
@${REINPLACE_CMD} -e 's#/var/spool/postfix/postgrey#${PGY_DIR}#' ${WRKSRC}/postgrey ${WRKSRC}/contrib/postgreyreport
diff --git a/mail/postgrey/files/pkg-install.in b/mail/postgrey/files/pkg-install.in
index 76b14b0912a9..46cff86c0e60 100644
--- a/mail/postgrey/files/pkg-install.in
+++ b/mail/postgrey/files/pkg-install.in
@@ -1,21 +1,16 @@
#! /bin/sh
#
-# $FreeBSD: /tmp/pcvs/ports/mail/postgrey/files/pkg-install.in,v 1.6 2012-04-18 07:54:30 crees Exp $
+# $FreeBSD$
PATH=/bin:/usr/bin:/usr/sbin
case $2 in
PRE-INSTALL)
- echo "---> Starting install script:"
-
- if [ -z "%%POSTGREYDIR%%" -o \
- -z "%%USER%%" -o -z "%%GROUP%%" -o \
- -z "%%UID%%" -o -z "%%GID%%" ]; then
+ if [ -z "%%POSTGREYDIR%%" -o -z "%%USER%%" -o -z "%%GROUP%%" ]; then
echo "ERROR: A required pragma was empty"
exit 1
fi
-
;;
POST-INSTALL)
diff --git a/mail/postgrey/files/postgrey.in b/mail/postgrey/files/postgrey.in
index 55e9e3d2dbcb..60cd94b09967 100644
--- a/mail/postgrey/files/postgrey.in
+++ b/mail/postgrey/files/postgrey.in
@@ -7,41 +7,37 @@
# BEFORE: mail
# KEYWORD: shutdown
-#
# Add the following lines to /etc/rc.conf to enable postgrey:
#
-# postgrey_enable="YES"
+# postgrey_enable (bool) Set to 'YES' to enable
+# Default: NO
+# postgrey_dbdir (path) Location of postgrey database files.
+# Default: /var/db/postgrey
+# postgrey_flags (extra args) Additional command-line parameters.
+# Default: --inet=10023
#
-# See perldoc postgrey for flags
+# Note:
#
+# postgrey_flags must include a --inet or --unix option or postgrey will
+# not run. Change the --dbdir option with postgrey_dbdir. Please see
+# the postgrey(1) man page or perldoc postgrey for more information.
. /etc/rc.subr
name=postgrey
-rcvar=postgrey_enable
-
-command=%%PREFIX%%/sbin/postgrey
-required_dirs=/var/db/postgrey
-extra_commands=reload
-
-stop_postcmd=stop_postcmd
-stop_postcmd()
-{
- rm -f $pidfile
-}
+load_rc_config $name
-# set defaults
+: ${postgrey_enable:=NO}
+: ${postgrey_dbdir:=/var/db/postgrey}
+: ${postgrey_flags:=--inet=10023}
-load_rc_config $name
+command=%%PREFIX%%/sbin/postgrey
+pidfile=/var/run/postgrey.pid
+required_dirs=${postgrey_dbdir}
-postgrey_enable=${postgrey_enable:-"NO"}
-postgrey_greylist_header=${postgrey_greylist_header:-"X-Greylist: delayed %t seconds by postgrey-%v at %h\; %d"}
-postgrey_pidfile=${postgrey_pidfile:-"/var/run/postgrey.pid"}
-postgrey_flags=${postgrey_flags:-"--pidfile=${postgrey_pidfile} \
- --inet=10023 -d --user=%%USER%% --group=%%GROUP%% --dbdir=/var/db/postgrey \
- --x-greylist-header=${postgrey_greylist_header}"}
+command_args="-d --pidfile=${pidfile} --dbdir=${postgrey_dbdir}"
-pidfile="${postgrey_pidfile}"
+stop_postcmd="rm -f ${pidfile}"
run_rc_command "$1"
diff --git a/mail/postgrey/pkg-message b/mail/postgrey/pkg-message
new file mode 100644
index 000000000000..7ac63a44be82
--- /dev/null
+++ b/mail/postgrey/pkg-message
@@ -0,0 +1,7 @@
+
+ATTENTION
+
+The startup script for postgrey will make it listen on TCP port
+10023 by default. If you want to use a different setting, please
+read the comments in the RC script and set the appropriate settings
+via rc.conf before starting postgrey.