aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-04-05 15:15:53 +0800
committersobomax <sobomax@FreeBSD.org>2001-04-05 15:15:53 +0800
commit98699ec6da97ee91350a53f3878ac0eaff40e1d9 (patch)
tree7fbc79756e6b9329df5297a663c93e2dd5b8142c
parent6fe436c09757ab46e17ef1104a70492e6def38da (diff)
downloadfreebsd-ports-gnome-98699ec6da97ee91350a53f3878ac0eaff40e1d9.tar.gz
freebsd-ports-gnome-98699ec6da97ee91350a53f3878ac0eaff40e1d9.tar.zst
freebsd-ports-gnome-98699ec6da97ee91350a53f3878ac0eaff40e1d9.zip
Correct startup shell script - pass command line arguments to the underlying
Python script.
-rw-r--r--benchmarks/pybench/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/benchmarks/pybench/Makefile b/benchmarks/pybench/Makefile
index 2f6de786ffae..bec226a0f0c1 100644
--- a/benchmarks/pybench/Makefile
+++ b/benchmarks/pybench/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pybench
PORTVERSION= 0.8
+PORTREVISION= 1
CATEGORIES= benchmarks python
MASTER_SITES= http://www.lemburg.com/files/python/
@@ -25,7 +26,7 @@ do-install:
@${MKDIR} ${PREFIX}/share/pybench
@(cd ${WRKSRC} && ${TAR} --exclude README -c -f - .) \
| (cd ${PREFIX}/share/pybench && ${TAR} --unlink -x -f -)
- @printf "#!/bin/sh\n${PYTHON_CMD} ${PREFIX}/share/pybench/pybench.py\n" \
+ @printf '#!/bin/sh\n${PYTHON_CMD} ${PREFIX}/share/pybench/pybench.py "$$@"\n' \
> ${WRKDIR}/pybench.sh
@${MKDIR} ${PREFIX}/share/doc/pybench
@${INSTALL_MAN} ${WRKSRC}/README ${PREFIX}/share/doc/pybench