aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarius <marius@FreeBSD.org>2012-12-21 07:13:44 +0800
committermarius <marius@FreeBSD.org>2012-12-21 07:13:44 +0800
commit98ab9baf84895c98de3301732b1f3b3b7b519bcd (patch)
tree6804ff2ee2e2d9edd88088084cf0e684bb8acc06
parentef2d32d3ee306a3d34e3c887a21b5add02bc5ffd (diff)
downloadfreebsd-ports-gnome-98ab9baf84895c98de3301732b1f3b3b7b519bcd.tar.gz
freebsd-ports-gnome-98ab9baf84895c98de3301732b1f3b3b7b519bcd.tar.zst
freebsd-ports-gnome-98ab9baf84895c98de3301732b1f3b3b7b519bcd.zip
Make D-Bus and NLS support options (defaults unchanged). For completeness
sake, also make PDF support optional (still allowing to build a PS-only reader). Approved by: olivierd, bapt
-rw-r--r--graphics/electrix/Makefile31
1 files changed, 24 insertions, 7 deletions
diff --git a/graphics/electrix/Makefile b/graphics/electrix/Makefile
index 3e81ea0dc9f4..7914fb718bb3 100644
--- a/graphics/electrix/Makefile
+++ b/graphics/electrix/Makefile
@@ -13,24 +13,41 @@ COMMENT= An application to view PDF files
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
- poppler-glib:${PORTSDIR}/graphics/poppler-glib
-
USE_BZIP2= yes
USE_GNOME= gtk20 desktopfileutils intltool intlhack
USE_PYTHON= yes
-USE_GETTEXT= yes
USE_PKGCONFIG= build
-
CONFIGURE_ARGS= --prefix=${PREFIX}
-OPTIONS_DEFINE= PS
+OPTIONS_DEFINE= DBUS NLS PDF PS
+OPTIONS_DEFAULT= DBUS PDF
-PS_DESC= PostScript support
+PDF_DESC= Portable Document Format Support
+PS_DESC= PostScript Support
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MDBUS}
+LIB_DEPENDS+= dbus-glib-1:${PORTSDIR}/devel/dbus-glib
+.else
+CONFIGURE_ARGS+= --disable-dbus
+.endif
+
+.if ${PORT_OPTIONS:MNLS}
+PLIST_SUB= NLS=""
+USE_GETTEXT= yes
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB= NLS="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MPDF}
+LIB_DEPENDS= poppler-glib:${PORTSDIR}/graphics/poppler-glib
+.else
+CONFIGURE_ARGS+= --disable-pdf
+.endif
+
.if ${PORT_OPTIONS:MPS}
LIB_DEPENDS+= spectre:${PORTSDIR}/print/libspectre
.else