aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2013-12-04 18:07:23 +0800
committerkoobs <koobs@FreeBSD.org>2013-12-04 18:07:23 +0800
commit98e24bf0ba7d0e5284d296268c8adc3bf8006fa5 (patch)
treed3ccb3504f50d011c8eb4be0ed2fa9bf679c6bbf
parent067116f451147baf49d169b38fe8e54ce93e2e96 (diff)
downloadfreebsd-ports-gnome-98e24bf0ba7d0e5284d296268c8adc3bf8006fa5.tar.gz
freebsd-ports-gnome-98e24bf0ba7d0e5284d296268c8adc3bf8006fa5.tar.zst
freebsd-ports-gnome-98e24bf0ba7d0e5284d296268c8adc3bf8006fa5.zip
devel/py-pbr: Add pip to RUN_DEPENDS as swift and swiftclient need it
swift and swiftclient depend on pbr, output errors on import when pip is not available at runtime, but don't explicitly declare a dependency on pip themselves. While implicit dependencies are not good practice, pbr does declare pip in its requirements, which is not reflected in this ports RUN_DEPENDS. So: - Add py-pip to RUN_DEPENDS Reported by: trociny
-rw-r--r--devel/py-pbr/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/devel/py-pbr/Makefile b/devel/py-pbr/Makefile
index be4956847c19..1a78b17fb502 100644
--- a/devel/py-pbr/Makefile
+++ b/devel/py-pbr/Makefile
@@ -3,6 +3,7 @@
PORTNAME= pbr
PORTVERSION= 0.5.23
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,6 +13,8 @@ COMMENT= Python Build Reasonableness
LICENSE= AL2
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pip>=1.0:${PORTSDIR}/devel/py-pip
+
USE_PYTHON= yes
USE_PYDISTUTILS= easy_install
PYDISTUTILS_AUTOPLIST= yes