aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2009-11-13 09:35:53 +0800
committerwxs <wxs@FreeBSD.org>2009-11-13 09:35:53 +0800
commit98e3fe5393557ee7b66b4c0b6983ad0b073660fc (patch)
tree1ba2c496950a8c424cd667975d3ff09540baac23
parent7ed9d4f59c8f10dbd23554cb84665f44acc6d93b (diff)
downloadfreebsd-ports-gnome-98e3fe5393557ee7b66b4c0b6983ad0b073660fc.tar.gz
freebsd-ports-gnome-98e3fe5393557ee7b66b4c0b6983ad0b073660fc.tar.zst
freebsd-ports-gnome-98e3fe5393557ee7b66b4c0b6983ad0b073660fc.zip
- Update to 1.6.5.2 [1]
- Add PERL, ICONV and CURL options (all on by default). [2] Note that GITWEB requires PERL. PR: [1]: ports/140001 [2]: ports/139993 Submitted by: [1]: Sylvio Cesar <scjamorim@bsd.com.br> [2]: Stef Walter <stef@memberwebs.com>
-rw-r--r--devel/git/Makefile61
-rw-r--r--devel/git/distinfo18
-rw-r--r--devel/git/pkg-plist9
3 files changed, 57 insertions, 31 deletions
diff --git a/devel/git/Makefile b/devel/git/Makefile
index 204655f6e3fc..7e4329392157 100644
--- a/devel/git/Makefile
+++ b/devel/git/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= git
-PORTVERSION= 1.6.5.1
+PORTVERSION= 1.6.5.2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_KERNEL_ORG}
MASTER_SITE_SUBDIR= software/scm/${PORTNAME}
@@ -19,13 +19,6 @@ EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
MAINTAINER= wxs@FreeBSD.org
COMMENT= Distributed source code management tool
-BUILD_DEPENDS= curl:${PORTSDIR}/ftp/curl \
- ${SITE_PERL}/Error.pm:${PORTSDIR}/lang/p5-Error
-RUN_DEPENDS= curl:${PORTSDIR}/ftp/curl \
- ${SITE_PERL}/Error.pm:${PORTSDIR}/lang/p5-Error \
- ${SITE_PERL}/Net/SMTP/SSL.pm:${PORTSDIR}/mail/p5-Net-SMTP-SSL
-LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
-
MAKE_JOBS_SAFE= yes
MAN1= git.1 \
@@ -153,7 +146,6 @@ MAN1= git.1 \
git-web--browse.1 \
git-whatchanged.1 \
git-write-tree.1
-MAN3= Git.3
MAN5= gitattributes.5 \
githooks.5 \
gitignore.5 \
@@ -170,16 +162,9 @@ SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
USE_BZIP2= yes
-USE_PERL5= yes
-USE_ICONV= yes
USE_GMAKE= yes
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
-MAKE_ENV+= CURLDIR=${LOCALBASE} \
- NEEDS_LIBICONV=yes \
- OLD_ICONV=yes \
- PERL_PATH=${PERL} \
- LIBMD_SHA1=yes \
- ICONVDIR=${LOCALBASAE} \
+MAKE_ENV+= LIBMD_SHA1=yes \
V=1
MAKE_ARGS+= prefix="${PREFIX}"
USE_OPENSSL= yes
@@ -192,10 +177,46 @@ OPTIONS= GUI "Enable building of GUI tools" off \
GITWEB "Install gitweb" off \
P4 "Enable Perforce support" on \
CVS "Enable CVS support" on \
- HTMLDOCS "Install additional documentation" off
+ HTMLDOCS "Install additional documentation" off \
+ PERL "Build perl based git tools" on \
+ ICONV "Support for multiple character encodings" on \
+ CURL "Support HTTP push and pull" on
.include <bsd.port.pre.mk>
+.ifdef (WITH_PERL)
+USE_PERL5= yes
+MAKE_ENV+= PERL_PATH=${PERL}
+BUILD_DEPENDS+= ${SITE_PERL}/Error.pm:${PORTSDIR}/lang/p5-Error
+RUN_DEPENDS+= ${SITE_PERL}/Error.pm:${PORTSDIR}/lang/p5-Error \
+ ${SITE_PERL}/Net/SMTP/SSL.pm:${PORTSDIR}/mail/p5-Net-SMTP-SSL
+MAN3= Git.3
+.else
+MAKE_ENV+= NO_PERL=1
+PLIST_SUB+= SITE_PERL="@comment "
+.endif
+
+.ifdef (WITH_ICONV)
+USE_ICONV= yes
+MAKE_ENV+= NEEDS_LIBICONV=yes \
+ OLD_ICONV=yes \
+ ICONVDIR=${LOCALBASE}
+.else
+MAKE_ENV+= NO_ICONV=1
+.endif
+
+.ifdef (WITH_CURL)
+MAKE_ENV+= CURLDIR=${LOCALBASE}
+BUILD_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+RUN_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS+= expat.6:${PORTSDIR}/textproc/expat2
+PLIST_SUB+= CURL=""
+.else
+MAKE_ENV+= NO_CURL=1 \
+ NO_EXPAT=1
+PLIST_SUB+= CURL="@comment "
+.endif
+
.ifdef (WITH_HTMLDOCS)
RUN_DEPENDS+= ${LOCALBASE}/bin/asciidoc:${PORTSDIR}/textproc/asciidoc \
${LOCALBASE}/bin/xsltproc:${PORTSDIR}/textproc/libxslt
@@ -233,6 +254,10 @@ PLIST_SUB+= GITWEB=""
PLIST_SUB+= GITWEB="@comment "
.endif
+.ifdef (WITH_GITWEB) && !defined(WITH_PERL)
+IGNORE= using GITWEB support requires PERL support
+.endif
+
.ifdef (WITH_P4)
#USE_PYTHON= yes
# Can't set USE_PYTHON here just yet. See ports/89648.
diff --git a/devel/git/distinfo b/devel/git/distinfo
index c92a2187995d..83391f292ab9 100644
--- a/devel/git/distinfo
+++ b/devel/git/distinfo
@@ -1,9 +1,9 @@
-MD5 (git-1.6.5.1.tar.bz2) = fd784f407d538705ed36c0498542d4f5
-SHA256 (git-1.6.5.1.tar.bz2) = d78e2c6a55a250f8b57660a2a569df14dc24c9bb338bd2c1e50f3bee227ad9fd
-SIZE (git-1.6.5.1.tar.bz2) = 2243592
-MD5 (git-manpages-1.6.5.1.tar.bz2) = a0e59428400e615904093af3a5c9495e
-SHA256 (git-manpages-1.6.5.1.tar.bz2) = 6d5eda88b136129ca5fee6703a3d000245f38870d4b0292d252bfea786c3f5a3
-SIZE (git-manpages-1.6.5.1.tar.bz2) = 252259
-MD5 (git-1.6.5.1.tar.bz2.sign) = 43ef6ac762cb7d22a6b01be9325b9327
-SHA256 (git-1.6.5.1.tar.bz2.sign) = 582066956b47ea34eec8a8c6789e54f719754bf8abc6c9f3d952f353d48e16ab
-SIZE (git-1.6.5.1.tar.bz2.sign) = 248
+MD5 (git-1.6.5.2.tar.bz2) = 99708c449b23433136dbdfa38bd16d80
+SHA256 (git-1.6.5.2.tar.bz2) = a7050b45a4c5a2b40db83dc67dc3ff4b422ef1864df72316b3221ead2eefb5c1
+SIZE (git-1.6.5.2.tar.bz2) = 2244529
+MD5 (git-manpages-1.6.5.2.tar.bz2) = e4c20bd92b7ec187a421c045ae99978a
+SHA256 (git-manpages-1.6.5.2.tar.bz2) = 893c1abc6729d19aef26e3e1ffff7323fc1bb6e290974c932e8ab51197fdd921
+SIZE (git-manpages-1.6.5.2.tar.bz2) = 256189
+MD5 (git-1.6.5.2.tar.bz2.sign) = e54968c04e27b1fdcd3d4b0c2b237732
+SHA256 (git-1.6.5.2.tar.bz2.sign) = adc9fd3563c30051d4b7c2b50314b61ab37f3053b12a6bc910962a38f6397a69
+SIZE (git-1.6.5.2.tar.bz2.sign) = 248
diff --git a/devel/git/pkg-plist b/devel/git/pkg-plist
index 664988ab4f12..9e4344b534e8 100644
--- a/devel/git/pkg-plist
+++ b/devel/git/pkg-plist
@@ -62,8 +62,8 @@ libexec/git-core/git-grep
%%GUI%%libexec/git-core/git-gui--askpass
libexec/git-core/git-hash-object
libexec/git-core/git-help
-libexec/git-core/git-http-fetch
-libexec/git-core/git-http-push
+%%CURL%%libexec/git-core/git-http-fetch
+%%CURL%%libexec/git-core/git-http-push
libexec/git-core/git-imap-send
libexec/git-core/git-index-pack
libexec/git-core/git-init
@@ -111,7 +111,7 @@ libexec/git-core/git-receive-pack
libexec/git-core/git-reflog
libexec/git-core/git-relink
libexec/git-core/git-remote
-libexec/git-core/git-remote-curl
+%%CURL%%libexec/git-core/git-remote-curl
libexec/git-core/git-repack
libexec/git-core/git-repo-config
libexec/git-core/git-replace
@@ -714,6 +714,7 @@ share/git-core/templates/info/exclude
%%HTMLDOCS%%%%DOCSDIR%%/RelNotes-1.6.4.4.txt
%%HTMLDOCS%%%%DOCSDIR%%/RelNotes-1.6.5.txt
%%HTMLDOCS%%%%DOCSDIR%%/RelNotes-1.6.5.1.txt
+%%HTMLDOCS%%%%DOCSDIR%%/RelNotes-1.6.5.2.txt
%%GITWEB%%%%EXAMPLESDIR%%/gitweb/INSTALL
%%GITWEB%%%%EXAMPLESDIR%%/gitweb/README
%%GITWEB%%%%EXAMPLESDIR%%/gitweb/git-favicon.png
@@ -737,7 +738,7 @@ share/git-core/templates/info/exclude
%%HTMLDOCS%%@dirrm %%DOCSDIR%%/howto
%%HTMLDOCS%%@dirrm %%DOCSDIR%%
@dirrm libexec/git-core
-@dirrm share/git-core/templates/branches
+@dirrmtry share/git-core/templates/branches
@dirrmtry share/git-core/templates/hooks
@dirrm share/git-core/templates/info
@dirrmtry share/git-core/templates