aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-06-03 21:23:09 +0800
committermiwi <miwi@FreeBSD.org>2008-06-03 21:23:09 +0800
commit98f8bd57ba2175558a2653481300ff7fe79d7888 (patch)
treeabc32e80c97ddb51ee1373b4715488f65278ba53
parent2ca000a47a587d8af49913c9129676e834233d80 (diff)
downloadfreebsd-ports-gnome-98f8bd57ba2175558a2653481300ff7fe79d7888.tar.gz
freebsd-ports-gnome-98f8bd57ba2175558a2653481300ff7fe79d7888.tar.zst
freebsd-ports-gnome-98f8bd57ba2175558a2653481300ff7fe79d7888.zip
Goggles Music Manager is a music collection manager and player that
automatically categorizes your music files based on genre, artist, album, and song. It supports gapless playback and features easy tag editing. WWW: http://code.google.com/p/gogglesmm/ PR: ports/124080 Submitted by: Sascha Klauder <sklauder at trimind.de>
-rw-r--r--audio/Makefile1
-rw-r--r--audio/gmm/Makefile60
-rw-r--r--audio/gmm/distinfo3
-rw-r--r--audio/gmm/pkg-descr5
-rw-r--r--audio/gogglesmm/Makefile60
-rw-r--r--audio/gogglesmm/distinfo3
-rw-r--r--audio/gogglesmm/pkg-descr5
7 files changed, 137 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 30c65f1c9e1a..00da5a564b56 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -206,6 +206,7 @@
SUBDIR += glurp
SUBDIR += gmidimonitor
SUBDIR += gmixer
+ SUBDIR += gmm
SUBDIR += gmpc
SUBDIR += gmpc-autoplaylist
SUBDIR += gmpc-extraplaylist
diff --git a/audio/gmm/Makefile b/audio/gmm/Makefile
new file mode 100644
index 000000000000..70b97a1de4f1
--- /dev/null
+++ b/audio/gmm/Makefile
@@ -0,0 +1,60 @@
+# New ports collection makefile for: ggm
+# Date created: 28 May 2008
+# Whom: Sascha Klauder <sklauder@trimind.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gmm
+PORTVERSION= 0.9.10
+CATEGORIES= audio
+MASTER_SITES= http://gogglesmm.googlecode.com/files/
+DISTNAME= musicmanager-${PORTVERSION}
+
+MAINTAINER= sklauder@trimind.de
+COMMENT= Music collection manager and player
+
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
+LIB_DEPENDS= FOX-1.6:${PORTSDIR}/x11-toolkits/fox16 \
+ xine.1:${PORTSDIR}/multimedia/libxine \
+ tag.5:${PORTSDIR}/audio/taglib \
+ sqlite3.8:${PORTSDIR}/databases/sqlite3
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_BZIP2= yes
+
+PORTDOCS= README AUTHORS
+PLIST_FILES= bin/gmm \
+ share/pixmaps/gmm.png \
+ %%PORTDOCS%%%%DOCSDIR%%/AUTHORS \
+ %%PORTDOCS%%%%DOCSDIR%%/README
+
+CONFIGURE_ARGS= --prefix=${PREFIX}
+CONFIGURE_ENV= OPT_CFLAGS=" "
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_NEWREMOTE)
+CONFIGURE_ARGS+=--without-new-remote
+.endif
+
+.if defined(WITH_DBUS)
+CONFIGURE_ARGS+=--with-dbus
+LIB_DEPENDS+= dbus-1:${PORTSDIR}/devel/dbus
+.endif
+
+post-extract:
+ ${REINPLACE_CMD} -i '' -e "s|/bin/bash|${PREFIX}/bin/bash|" \
+ ${WRKSRC}/configure
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+. for FILE in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+. endfor
+.endif
+ ${INSTALL_DATA} ${WRKSRC}/extra/gmm.png ${PREFIX}/share/pixmaps
+
+.include <bsd.port.post.mk>
diff --git a/audio/gmm/distinfo b/audio/gmm/distinfo
new file mode 100644
index 000000000000..20a79a4a33ce
--- /dev/null
+++ b/audio/gmm/distinfo
@@ -0,0 +1,3 @@
+MD5 (musicmanager-0.9.10.tar.bz2) = 8ece5f1f550072d7d16f553b229ff142
+SHA256 (musicmanager-0.9.10.tar.bz2) = df2f80ce7750b37ed024148d8a5c6f41af1f23ea412fa434d4a52cb6aca4b08b
+SIZE (musicmanager-0.9.10.tar.bz2) = 266688
diff --git a/audio/gmm/pkg-descr b/audio/gmm/pkg-descr
new file mode 100644
index 000000000000..ae569373e065
--- /dev/null
+++ b/audio/gmm/pkg-descr
@@ -0,0 +1,5 @@
+Goggles Music Manager is a music collection manager and player that
+automatically categorizes your music files based on genre, artist, album,
+and song. It supports gapless playback and features easy tag editing.
+
+WWW: http://code.google.com/p/gogglesmm/
diff --git a/audio/gogglesmm/Makefile b/audio/gogglesmm/Makefile
new file mode 100644
index 000000000000..70b97a1de4f1
--- /dev/null
+++ b/audio/gogglesmm/Makefile
@@ -0,0 +1,60 @@
+# New ports collection makefile for: ggm
+# Date created: 28 May 2008
+# Whom: Sascha Klauder <sklauder@trimind.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gmm
+PORTVERSION= 0.9.10
+CATEGORIES= audio
+MASTER_SITES= http://gogglesmm.googlecode.com/files/
+DISTNAME= musicmanager-${PORTVERSION}
+
+MAINTAINER= sklauder@trimind.de
+COMMENT= Music collection manager and player
+
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
+LIB_DEPENDS= FOX-1.6:${PORTSDIR}/x11-toolkits/fox16 \
+ xine.1:${PORTSDIR}/multimedia/libxine \
+ tag.5:${PORTSDIR}/audio/taglib \
+ sqlite3.8:${PORTSDIR}/databases/sqlite3
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_BZIP2= yes
+
+PORTDOCS= README AUTHORS
+PLIST_FILES= bin/gmm \
+ share/pixmaps/gmm.png \
+ %%PORTDOCS%%%%DOCSDIR%%/AUTHORS \
+ %%PORTDOCS%%%%DOCSDIR%%/README
+
+CONFIGURE_ARGS= --prefix=${PREFIX}
+CONFIGURE_ENV= OPT_CFLAGS=" "
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_NEWREMOTE)
+CONFIGURE_ARGS+=--without-new-remote
+.endif
+
+.if defined(WITH_DBUS)
+CONFIGURE_ARGS+=--with-dbus
+LIB_DEPENDS+= dbus-1:${PORTSDIR}/devel/dbus
+.endif
+
+post-extract:
+ ${REINPLACE_CMD} -i '' -e "s|/bin/bash|${PREFIX}/bin/bash|" \
+ ${WRKSRC}/configure
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+. for FILE in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+. endfor
+.endif
+ ${INSTALL_DATA} ${WRKSRC}/extra/gmm.png ${PREFIX}/share/pixmaps
+
+.include <bsd.port.post.mk>
diff --git a/audio/gogglesmm/distinfo b/audio/gogglesmm/distinfo
new file mode 100644
index 000000000000..20a79a4a33ce
--- /dev/null
+++ b/audio/gogglesmm/distinfo
@@ -0,0 +1,3 @@
+MD5 (musicmanager-0.9.10.tar.bz2) = 8ece5f1f550072d7d16f553b229ff142
+SHA256 (musicmanager-0.9.10.tar.bz2) = df2f80ce7750b37ed024148d8a5c6f41af1f23ea412fa434d4a52cb6aca4b08b
+SIZE (musicmanager-0.9.10.tar.bz2) = 266688
diff --git a/audio/gogglesmm/pkg-descr b/audio/gogglesmm/pkg-descr
new file mode 100644
index 000000000000..ae569373e065
--- /dev/null
+++ b/audio/gogglesmm/pkg-descr
@@ -0,0 +1,5 @@
+Goggles Music Manager is a music collection manager and player that
+automatically categorizes your music files based on genre, artist, album,
+and song. It supports gapless playback and features easy tag editing.
+
+WWW: http://code.google.com/p/gogglesmm/