aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsbruno <sbruno@FreeBSD.org>2016-11-08 10:00:10 +0800
committersbruno <sbruno@FreeBSD.org>2016-11-08 10:00:10 +0800
commit99286123ae1165f3696821152a303950fc0d3218 (patch)
tree688775704744633741de7e81dc6635be8c67e2ae
parent12a86c45ec7e69c1db3ed6583646735a277097bd (diff)
downloadfreebsd-ports-gnome-99286123ae1165f3696821152a303950fc0d3218.tar.gz
freebsd-ports-gnome-99286123ae1165f3696821152a303950fc0d3218.tar.zst
freebsd-ports-gnome-99286123ae1165f3696821152a303950fc0d3218.zip
Update and track upstream QEMU 2.7.50
No changes to qemu-user are intended here, nor are there and fixes here.
-rw-r--r--emulators/qemu-sbruno/Makefile25
-rw-r--r--emulators/qemu-sbruno/distinfo11
-rw-r--r--emulators/qemu-sbruno/files/patch-Makefile11
-rw-r--r--emulators/qemu-sbruno/pkg-plist2
4 files changed, 34 insertions, 15 deletions
diff --git a/emulators/qemu-sbruno/Makefile b/emulators/qemu-sbruno/Makefile
index 52db19d56711..6eb972dcc2a2 100644
--- a/emulators/qemu-sbruno/Makefile
+++ b/emulators/qemu-sbruno/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= qemu
-PORTVERSION= 2.6.90.g20160728
-PORTREVISION= 1
+PORTVERSION= 2.7.50.g20161024
CATEGORIES= emulators
MASTER_SITES= GH \
LOCAL/nox:dtc \
@@ -18,10 +17,11 @@ COMMENT?= QEMU CPU Emulator - github bsd-user branch
BROKEN_FreeBSD_9= does not build
+LICENSE= GPLv2
USE_GITHUB= yes
GH_ACCOUNT= seanbruno
GH_PROJECT= ${PORTNAME}-bsd-user
-GH_TAGNAME= c47c4e2
+GH_TAGNAME= e0c9a90
HAS_CONFIGURE= yes
USES= gmake pkgconfig bison perl5 python:2,build
USE_PERL5= build
@@ -71,7 +71,7 @@ USE_GNOME+= glib20
CONFIGURE_ARGS+= --localstatedir=/var
CONFIGURE_ARGS+= --extra-ldflags=-L\"${LOCALBASE}/lib\"
CONFIGURE_ARGS+= --disable-libssh2
-PORTDOCS= docs qemu-doc.html qemu-tech.html qmp-commands.txt
+PORTDOCS= docs qemu-doc.html qmp-commands.txt
.if defined(QEMU_USER_STATIC)
.if ${ARCH} != "amd64"
@@ -243,6 +243,13 @@ CONFIGURE_ARGS+= --sparc_cpu=v9
CONFIGURE_ARGS+= --python=${PYTHON_CMD}
+# clang in freebsd 10 is unable to assemble linuxboot_dma.bin
+.if (${OSVERSION} < 1100000)
+PLIST_SUB+= LINUXBOOT_DMA="@comment "
+.else
+PLIST_SUB+= LINUXBOOT_DMA=""
+.endif
+
# -lprocstat actually only _needs_ -lelf after r249666 or r250870 (MFC)
# but it shouldn't matter much
post-patch:
@@ -250,6 +257,16 @@ post-patch:
@${REINPLACE_CMD} -e '/LIBS/s|-lprocstat|-lprocstat -lelf|' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e '/libs_qga=/s|glib_libs|glib_libs -lintl|' ${WRKSRC}/configure
+# clang in freebsd 10 is unable to assemble linuxboot_dma.bin
+.if (${OSVERSION} < 1100000)
+ @${REINPLACE_CMD} -E \
+ -e 's|linuxboot_dma.bin||' \
+ ${WRKSRC}/pc-bios/optionrom/Makefile
+ @${REINPLACE_CMD} -E \
+ -e 's|linuxboot_dma.bin||' \
+ ${WRKSRC}/Makefile
+.endif
+
#.if ${PORT_OPTIONS:MPCAP}
# @cd ${WRKSRC} && ${PATCH} --quiet < ${FILESDIR}/pcap-patch
#.endif
diff --git a/emulators/qemu-sbruno/distinfo b/emulators/qemu-sbruno/distinfo
index d7d2a1666059..5cd2726b7cff 100644
--- a/emulators/qemu-sbruno/distinfo
+++ b/emulators/qemu-sbruno/distinfo
@@ -1,4 +1,7 @@
-SHA256 (qemu/2.6.90.g20160728/seanbruno-qemu-bsd-user-2.6.90.g20160728-c47c4e2_GH0.tar.gz) = e18cf0c11481019a43dc45dc72f720738309c0a5e83c6217cd1cea82ec57173b
-SIZE (qemu/2.6.90.g20160728/seanbruno-qemu-bsd-user-2.6.90.g20160728-c47c4e2_GH0.tar.gz) = 12947898
-SHA256 (qemu/2.6.90.g20160728/dtc-v1.4.0.tar.gz) = 39d0713efd82a27adc065ecb9ef36401c53d5ee87ae1764e2bb243fcd97488e3
-SIZE (qemu/2.6.90.g201605/dtc-v1.4.0.tar.gz) = 131893
+TIMESTAMP = 1478530214
+SHA256 (qemu/2.7.50.g20161024/seanbruno-qemu-bsd-user-2.7.50.g20161024-e0c9a90_GH0.tar.gz) = 92c19071cb5adee091bd7db72021ff4f2181d5380414d748d92926e71839d9a4
+SIZE (qemu/2.7.50.g20161024/seanbruno-qemu-bsd-user-2.7.50.g20161024-e0c9a90_GH0.tar.gz) = 13104701
+SHA256 (qemu/2.7.50.g20161024/dtc-v1.4.0.tar.gz) = 39d0713efd82a27adc065ecb9ef36401c53d5ee87ae1764e2bb243fcd97488e3
+SIZE (qemu/2.7.50.g20161024/dtc-v1.4.0.tar.gz) = 131893
+SHA256 (qemu/2.7.50.g20161024/seanbruno-qemu-bsd-user-2.7.50.g20161024-e0c9a90_GH0.tar.gz) = 92c19071cb5adee091bd7db72021ff4f2181d5380414d748d92926e71839d9a4
+SIZE (qemu/2.7.50.g20161024/seanbruno-qemu-bsd-user-2.7.50.g20161024-e0c9a90_GH0.tar.gz) = 13104701
diff --git a/emulators/qemu-sbruno/files/patch-Makefile b/emulators/qemu-sbruno/files/patch-Makefile
index 9c72b30cfaf9..8d2fe0ca5e83 100644
--- a/emulators/qemu-sbruno/files/patch-Makefile
+++ b/emulators/qemu-sbruno/files/patch-Makefile
@@ -1,14 +1,13 @@
---- Makefile.orig 2016-07-11 15:33:10 UTC
+--- Makefile.orig 2016-10-24 16:28:22 UTC
+++ Makefile
-@@ -91,8 +91,12 @@ LIBS+=-lz $(LIBS_TOOLS)
+@@ -90,7 +90,11 @@ LIBS+=-lz $(LIBS_TOOLS)
HELPERS-$(CONFIG_LINUX) = qemu-bridge-helper$(EXESUF)
ifdef BUILD_DOCS
+ifdef NOPORTDOCS
+DOCS=qemu.1 qemu-img.1 qemu-nbd.8 qemu-ga.8
+else
- DOCS=qemu-doc.html qemu-tech.html qemu.1 qemu-img.1 qemu-nbd.8 qemu-ga.8
- DOCS+=qmp-commands.txt
+ DOCS=qemu-doc.html qemu.1 qemu-img.1 qemu-nbd.8 qemu-ga.8
+endif
ifdef CONFIG_VIRTFS
DOCS+=fsdev/virtfs-proxy-helper.1
@@ -18,8 +17,8 @@
install-doc: $(DOCS)
$(INSTALL_DIR) "$(DESTDIR)$(qemu_docdir)"
+ifndef NOPORTDOCS
- $(INSTALL_DATA) qemu-doc.html qemu-tech.html "$(DESTDIR)$(qemu_docdir)"
- $(INSTALL_DATA) qmp-commands.txt "$(DESTDIR)$(qemu_docdir)"
+ $(INSTALL_DATA) qemu-doc.html "$(DESTDIR)$(qemu_docdir)"
+ $(INSTALL_DATA) $(SRC_PATH)/docs/qmp-commands.txt "$(DESTDIR)$(qemu_docdir)"
+endif
ifdef CONFIG_POSIX
$(INSTALL_DIR) "$(DESTDIR)$(mandir)/man1"
diff --git a/emulators/qemu-sbruno/pkg-plist b/emulators/qemu-sbruno/pkg-plist
index dcd77e41dba6..fa7d21475f29 100644
--- a/emulators/qemu-sbruno/pkg-plist
+++ b/emulators/qemu-sbruno/pkg-plist
@@ -103,7 +103,7 @@
%%SOFTMMU%%%%DATADIR%%/keymaps/tr
%%SOFTMMU%%%%DATADIR%%/kvmvapic.bin
%%SOFTMMU%%%%DATADIR%%/linuxboot.bin
-%%SOFTMMU%%%%DATADIR%%/linuxboot_dma.bin
+%%LINUXBOOT_DMA%%%%SOFTMMU%%%%DATADIR%%/linuxboot_dma.bin
%%SOFTMMU%%%%DATADIR%%/multiboot.bin
%%SOFTMMU%%%%DATADIR%%/openbios-ppc
%%SOFTMMU%%%%DATADIR%%/openbios-sparc32