aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2018-10-06 18:30:45 +0800
committertobik <tobik@FreeBSD.org>2018-10-06 18:30:45 +0800
commit99528bfd3ab01f6d7aff836b79ce342c4b29fb13 (patch)
tree662d4988443eb9d4bb0903331f2e5a29ef6377da
parent11f5d27470f69642208f29d0f8de2a2b7548136d (diff)
downloadfreebsd-ports-gnome-99528bfd3ab01f6d7aff836b79ce342c4b29fb13.tar.gz
freebsd-ports-gnome-99528bfd3ab01f6d7aff836b79ce342c4b29fb13.tar.zst
freebsd-ports-gnome-99528bfd3ab01f6d7aff836b79ce342c4b29fb13.zip
databases/sqlcached: Switch to sqlite3 and respect {C,LD}FLAGS
PR: 231992 Submitted by: tobik Approved by: ivoras (maintainer, via mail)
-rw-r--r--databases/sqlcached/Makefile9
-rw-r--r--databases/sqlcached/files/patch-Makefile21
2 files changed, 23 insertions, 7 deletions
diff --git a/databases/sqlcached/Makefile b/databases/sqlcached/Makefile
index a6fa2740d0d3..ac84ac19e3a1 100644
--- a/databases/sqlcached/Makefile
+++ b/databases/sqlcached/Makefile
@@ -3,18 +3,14 @@
PORTNAME= sqlcached
PORTVERSION= r6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= databases net
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= ivoras@FreeBSD.org
COMMENT= Cache daemon using SQL for data manipulation
-LIB_DEPENDS= libsqlite.so:databases/sqlite2
-
-USES= readline ncurses tar:tgz
-
-LDFLAGS+= -L${LOCALBASE}/lib
+USES= localbase:ldflags ncurses readline sqlite tar:tgz
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -26,7 +22,6 @@ PLIST_FILES= bin/${PORTNAME} etc/rc.d/${PORTNAME} \
OPTIONS_DEFINE= DOCS
post-patch:
- @${REINPLACE_CMD} -e 's|-lcurses|-lncurses|' ${WRKSRC}/Makefile
@${REINPLACE_CMD} 's|/usr/local|${PREFIX}|' \
${WRKSRC}/FreeBSD/${PORTNAME}
diff --git a/databases/sqlcached/files/patch-Makefile b/databases/sqlcached/files/patch-Makefile
new file mode 100644
index 000000000000..95aadbd63f25
--- /dev/null
+++ b/databases/sqlcached/files/patch-Makefile
@@ -0,0 +1,21 @@
+--- Makefile.orig 2013-09-26 13:45:50 UTC
++++ Makefile
+@@ -1,7 +1,5 @@
+-MYCFLAGS=-O3 -Wall -I/usr/local/include #-g -pg
+-MYLDFLAGS=-L/usr/local/lib -lsqlite #-g -pg
+-#MYCFLAGS=-O3 -Wall -I/usr/local/include -DSQLITE3
+-#MYLDFLAGS=-L/usr/local/lib -lsqlite3
++MYCFLAGS= ${CFLAGS} -DSQLITE3
++MYLDFLAGS= ${LDFLAGS} -lsqlite3
+
+ all: sqlcached sc_client sc_client_bench libsqlcached_client.so libsqlcached_client.a
+
+@@ -20,7 +18,7 @@ server_protocol.o: server_protocol.c common.h
+ cc -o server_protocol.o -c server_protocol.c ${MYCFLAGS}
+
+ sc_client: client.o sqlcached_client.o
+- cc -o sc_client client.o sqlcached_client.o ${MYLDFLAGS} -lreadline -lcurses
++ cc -o sc_client client.o sqlcached_client.o ${MYLDFLAGS} -lreadline -lncurses
+
+ client.o: client.c common.h
+ cc -o client.o -c client.c ${MYCFLAGS}