aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2019-05-09 23:43:04 +0800
committerzi <zi@FreeBSD.org>2019-05-09 23:43:04 +0800
commit99a8b60b4984ed050b1e5bf612ff6e83fed51289 (patch)
tree6db981868869b6abb7780b48339cb9e79ba34f16
parent5d7fa3252d66a0f8b703f8bb611135911b1988dd (diff)
downloadfreebsd-ports-gnome-99a8b60b4984ed050b1e5bf612ff6e83fed51289.tar.gz
freebsd-ports-gnome-99a8b60b4984ed050b1e5bf612ff6e83fed51289.tar.zst
freebsd-ports-gnome-99a8b60b4984ed050b1e5bf612ff6e83fed51289.zip
- Fix backwards compatibility for luasocket with lua 5.3
- Bump PORTREVISION Obtained from: Upstream git issue 123
-rw-r--r--net/luasocket/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/net/luasocket/Makefile b/net/luasocket/Makefile
index 186948e60e45..833ebf6f1306 100644
--- a/net/luasocket/Makefile
+++ b/net/luasocket/Makefile
@@ -4,7 +4,7 @@
PORTNAME= luasocket
DISTVERSIONPREFIX= v
DISTVERSION= 3.0-rc1
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= net
PKGNAMEPREFIX= ${LUA_PKGNAMEPREFIX}
@@ -22,7 +22,8 @@ MAKE_ARGS= LUAV=${LUA_VER}
USES?= gmake lua pkgconfig
INSTALL_TARGET= install-unix
-CFLAGS+= `pkgconf --cflags lua-${LUA_VER}`
+CFLAGS+= `pkgconf --cflags lua-${LUA_VER}` \
+ -DLUA_COMPAT_APIINTCASTS
LDFLAGS+= -shared `pkgconf --libs lua-${LUA_VER}`
OPTIONS_DEFINE= DOCS