aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2016-03-29 22:14:54 +0800
committerKoop Mast <kwm@FreeBSD.org>2016-03-29 22:14:54 +0800
commit9a96fef2ceeb6d8eaf4ef01c2b73e514c9a58d36 (patch)
tree0a5219cfc6cc1e500253a062acd954f7baa4ffa9
parent2fd073c5b53185412802cabd38bb47361f3406a0 (diff)
downloadfreebsd-ports-gnome-9a96fef2ceeb6d8eaf4ef01c2b73e514c9a58d36.tar.gz
freebsd-ports-gnome-9a96fef2ceeb6d8eaf4ef01c2b73e514c9a58d36.tar.zst
freebsd-ports-gnome-9a96fef2ceeb6d8eaf4ef01c2b73e514c9a58d36.zip
Exclude libclc (and thus OpenCL) on 10.1 i386.
There is a wierd issue with base clang and llvm37 which stops libclc to build on 10.1 i386. So disable it so we don't block 1500+ ports. Submitted by: pkg-fallout via antoine@
-rw-r--r--graphics/libGL/Makefile.common7
-rw-r--r--lang/clover/Makefile5
2 files changed, 9 insertions, 3 deletions
diff --git a/graphics/libGL/Makefile.common b/graphics/libGL/Makefile.common
index 9b9c76aa5de3..4dd642c7bd5b 100644
--- a/graphics/libGL/Makefile.common
+++ b/graphics/libGL/Makefile.common
@@ -87,8 +87,11 @@ CONFIGURE_ARGS+= --enable-gles2
# Clover (OpenCL).
.if ${OPSYS} == DragonFly || \
- (${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000 && \
- (${ARCH} == i386 || ${ARCH} == amd64))
+ (${OPSYS} == FreeBSD && \
+ (${OSVERSION} >= 1001000 && ${ARCH} == amd64 || \
+ ${OSVERSION} >= 1002000 && ${ARCH} == i386))
+# Disabled on 10.1-R i386 because of compile issues with libclc.
+
BUILD_DEPENDS+= libclc>=0.0.r222830:${PORTSDIR}/devel/libclc
# We need the clang port too even if it is not used to compile because
diff --git a/lang/clover/Makefile b/lang/clover/Makefile
index f3d87d599a9c..c3ac882813f0 100644
--- a/lang/clover/Makefile
+++ b/lang/clover/Makefile
@@ -25,9 +25,12 @@ ONLY_FOR_ARCHS_REASON= Clover needs a graphics driver supported by the Radeon KM
#MESA_BUILD_WRKSRC= src/util src/glsl src/mesa src/gallium
MESA_INSTALL_WRKSRC= src/gallium/targets/opencl src/gallium/targets/pipe-loader
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1001000
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1001000 && ${ARCH} == amd64
IGNORE= Clover is only supported on FreeBSD 10.1 and newer
.endif
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1002000 && ${ARCH} == i386
+IGNORE= Clover is only supported on FreeBSD 10.2 and newer
+.endif
.include "${.CURDIR}/../../graphics/libGL/Makefile.targets"