aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2014-02-06 01:54:49 +0800
committerjohans <johans@FreeBSD.org>2014-02-06 01:54:49 +0800
commit9acd0b5abedd60074d155f3ac36f89bd92461a06 (patch)
treed8c00ff640ff821da071800d6b54a0813837af03
parent0345183395541965731aa62aad83ec57602dc5aa (diff)
downloadfreebsd-ports-gnome-9acd0b5abedd60074d155f3ac36f89bd92461a06.tar.gz
freebsd-ports-gnome-9acd0b5abedd60074d155f3ac36f89bd92461a06.tar.zst
freebsd-ports-gnome-9acd0b5abedd60074d155f3ac36f89bd92461a06.zip
- Enable stage support
- New style options - Strip installed libraries
-rw-r--r--www/xshttpd-devel/Makefile68
-rw-r--r--www/xshttpd-devel/pkg-plist23
-rw-r--r--www/xshttpd/Makefile73
-rw-r--r--www/xshttpd/pkg-plist16
4 files changed, 65 insertions, 115 deletions
diff --git a/www/xshttpd-devel/Makefile b/www/xshttpd-devel/Makefile
index 4bf39d4123d1..93eaf3d5cb90 100644
--- a/www/xshttpd-devel/Makefile
+++ b/www/xshttpd-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xshttpd
DISTVERSION= 3.7b27
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www ipv6
MASTER_SITES= ftp://ftp.stack.nl/pub/xs-httpd/release/ \
ftp://mud.stack.nl/pub/xs-httpd/release/
@@ -13,8 +13,6 @@ DISTNAME= ${PORTNAME}-${DISTVERSION:S/.//}
MAINTAINER= johans@FreeBSD.org
COMMENT= Webserver with CGI as own user and SSL support
-LICENSE= BSD
-
RUN_DEPENDS= run-mailcap:${PORTSDIR}/misc/mime-support \
ppmtogif:${PORTSDIR}/graphics/netpbm
LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
@@ -27,54 +25,20 @@ USE_RC_SUBR= xshttpd
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-hier=bsd
-MAN1= clearxs.1 gfxcount.1 httpd.1 httpdc.1 imagemap.1 \
- readxs.1 xschpass.1 xsindex.1 xspasswd.1
-MAN5= httpd.conf.5 xsauth.5 xsconf.5 xsscripts.5 xsredir.5
-MAN7= httpd_cgi.7 httpd_ssi.7
-
-OPTIONS_DEFINE= LDAP CURL M4_CONFIG PERSISTENT_PERL
-M4_CONFIG_DESC= Enable m4 configuration preprocessor
-PERSISTENT_PERL_DESC= Enable persistent Perl interpreter
+OPTIONS_DEFINE= LDAP CURL M4 PERL
+OPTIONS_SUB= yes
+LDAP_USE= openldap
+LDAP_CONFIGURE_WITH= ldap
+M4_DESC= Enable configuration preprocessor (m4)
+M4_CONFIGURE_WITH= preprocessor
+PERL_DESC= Enable persistent Perl interpreter
+PERL_USES= perl5
+PERL_CONFIGURE_WITH= perl
+CURL_LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
+CURL_CONFIGURE_WITH= curl
PORTDOCS= README ChangeLog
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-# By default XS-HTTPD stores its data in ${PREFIX}/lib/httpd
-WWWDIR?= ${PREFIX}/www/${PORTNAME}
-
-.if ${PORT_OPTIONS:MLDAP}
-USE_OPENLDAP= yes
-CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}
-PLIST_SUB+= LDAP=""
-.else
-CONFIGURE_ARGS+=--without-ldap
-PLIST_SUB+= LDAP="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MM4_CONFIG}
-CONFIGURE_ARGS+=--with-preprocessor
-.else
-CONFIGURE_ARGS+=--without-preprocessor
-.endif
-
-.if ${PORT_OPTIONS:MPERSISTENT_PERL}
-USES+= perl5
-CONFIGURE_ARGS+=--with-perl
-PLIST_SUB+= PERL=""
-.else
-CONFIGURE_ARGS+=--without-perl
-PLIST_SUB+= PERL="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MCURL}
-LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
-CONFIGURE_ARGS+=--with-curl
-.else
-CONFIGURE_ARGS+=--without-curl
-.endif
-
post-patch:
@${REINPLACE_CMD} \
-e 's|\(MIME_TYPES\).*|\1 "${LOCALBASE}/etc/mime.types"|' \
@@ -88,11 +52,11 @@ post-patch:
@${ECHO_CMD} '$$(bin_PROGRAMS) $$(phexec_PROGRAMS)' \
'$$(noinst_PROGRAMS): $$(noinst_LIBRARIES)' \
>> ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e '/libdir/ s|(INSTALL_DATA)|& -s|' \
+ ${WRKSRC}/src/Makefile.in
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR} ${STAGEDIR}${WWWDIR}/htdocs
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/www/xshttpd-devel/pkg-plist b/www/xshttpd-devel/pkg-plist
index 5253e98c4a9f..ab80e63d8cf3 100644
--- a/www/xshttpd-devel/pkg-plist
+++ b/www/xshttpd-devel/pkg-plist
@@ -72,16 +72,31 @@ libexec/xshttpd/mod_gzip.so
libexec/xshttpd/mod_htcpcp.so
libexec/xshttpd/mod_magic.so
libexec/xshttpd/mod_rpaf.so
-@exec mkdir -p %%WWWDIR%%/htdocs
-@exec mkdir -p /var/log/xshttpd
+man/man1/clearxs.1.gz
+man/man1/gfxcount.1.gz
+man/man1/httpd.1.gz
+man/man1/httpdc.1.gz
+man/man1/imagemap.1.gz
+man/man1/readxs.1.gz
+man/man1/xschpass.1.gz
+man/man1/xsindex.1.gz
+man/man1/xspasswd.1.gz
+man/man5/httpd.conf.5.gz
+man/man5/xsauth.5.gz
+man/man5/xsconf.5.gz
+man/man5/xsredir.5.gz
+man/man5/xsscripts.5.gz
+man/man7/httpd_cgi.7.gz
+man/man7/httpd_ssi.7.gz
@dirrm %%DATADIR%%/contrib
@dirrm %%DATADIR%%/gfxcount
@dirrmtry %%DATADIR%%/icons
-@dirrmtry %%DATADIR%%/logs
@dirrmtry %%DATADIR%%
@dirrmtry %%WWWDIR%%/cgi-bin
@dirrmtry %%WWWDIR%%/htdocs
@dirrmtry %%WWWDIR%%
@dirrmtry %%ETCDIR%%
@dirrmtry libexec/xshttpd
-@unexec rmdir /var/log/xshttpd 2>/dev/null || true
+@cwd /
+@unexec rmdir var/log/xshttpd 2>/dev/null || true
+@exec mkdir -p var/log/xshttpd
diff --git a/www/xshttpd/Makefile b/www/xshttpd/Makefile
index 4088ae4b1f20..52190d417d6c 100644
--- a/www/xshttpd/Makefile
+++ b/www/xshttpd/Makefile
@@ -12,8 +12,6 @@ DISTNAME= ${PORTNAME}-${DISTVERSION:S/.//}
MAINTAINER= johans@FreeBSD.org
COMMENT= Webserver with CGI as own user and SSL support
-LICENSE= BSD
-
RUN_DEPENDS= run-mailcap:${PORTSDIR}/misc/mime-support \
ppmtogif:${PORTSDIR}/graphics/netpbm
@@ -23,67 +21,26 @@ USE_BZIP2= yes
USE_RC_SUBR= xshttpd
GNU_CONFIGURE= yes
-MAN1= clearxs.1 gfxcount.1 httpd.1 httpdc.1 imagemap.1 \
- readxs.1 xschpass.1 xsindex.1 xspasswd.1
-MAN5= httpd.conf.5 xsauth.5 xsconf.5 xsscripts.5 xsredir.5
-MAN7= httpd_cgi.7 httpd_ssi.7
+WWWDIR= ${PREFIX}/www/${PORTNAME}
+CONFIGURE_ARGS+=--with-rootdir=${WWWDIR}
OPTIONS_DEFINE= SSL PCRE LDAP CURL M4_CONFIG PERSISTENT_PERL
OPTIONS_DEFAULT=SSL PCRE
+SSL_CONFIGURE_WITH= ssl
+LDAP_USE= openldap
+LDAP_CONFIGURE_WITH= ldap
M4_CONFIG_DESC= Enable m4 configuration preprocessor
+M4_CONFIG_CONFIGURE_WITH=preprocessor
PERSISTENT_PERL_DESC= Enable persistent Perl interpreter
+PERSISTENT_PERL_USES= perl5
+PERSISTENT_PERL_CONFIGURE_WITH= perl
+PCRE_LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
+PCRE_CONFIGURE_WITH= pcre
+CURL_LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
+CURL_CONFIGURE_WITH= curl
PORTDOCS= README ChangeLog
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-# By default XS-HTTPD stores its data in ${PREFIX}/lib/httpd
-WWWDIR?= ${PREFIX}/www/${PORTNAME}
-CONFIGURE_ARGS+=--with-rootdir=${WWWDIR}
-
-.if ${PORT_OPTIONS:MSSL}
-.include <${PORTSDIR}/Mk/bsd.openssl.mk>
-#USE_OPENSSL= yes
-CONFIGURE_ARGS+=--with-ssl
-.else
-CONFIGURE_ARGS+=--without-ssl
-.endif
-
-.if ${PORT_OPTIONS:MLDAP}
-USE_OPENLDAP= yes
-CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}
-.else
-CONFIGURE_ARGS+=--without-ldap
-.endif
-
-.if ${PORT_OPTIONS:MM4_CONFIG}
-CONFIGURE_ARGS+=--with-preprocessor
-.else
-CONFIGURE_ARGS+=--without-preprocessor
-.endif
-
-.if ${PORT_OPTIONS:MPERSISTENT_PERL}
-USES+= perl5
-CONFIGURE_ARGS+=--with-perl
-.else
-CONFIGURE_ARGS+=--without-perl
-.endif
-
-.if ${PORT_OPTIONS:MPCRE}
-LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre
-CONFIGURE_ARGS+=--with-pcre=yes
-.else
-CONFIGURE_ARGS+=--with-pcre=no
-.endif
-
-.if ${PORT_OPTIONS:MCURL}
-LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
-CONFIGURE_ARGS+=--with-curl=yes
-.else
-CONFIGURE_ARGS+=--with-curl=no
-.endif
-
post-patch:
.for i in man/httpd.1.in man/httpd.conf.5 config/httpd.conf.sample \
contrib/SSL-Makefile contrib/logrotate.sh
@@ -101,9 +58,7 @@ post-patch:
${WRKSRC}/config/Makefile.in
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR} ${STAGEDIR}${WWWDIR}/htdocs
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/www/xshttpd/pkg-plist b/www/xshttpd/pkg-plist
index f3a5461818dc..deaf621425c5 100644
--- a/www/xshttpd/pkg-plist
+++ b/www/xshttpd/pkg-plist
@@ -65,6 +65,22 @@ bin/xspasswd
%%WWWDIR%%/icons/xs-video.gif
%%WWWDIR%%/icons/xs-zip.gif
@exec mkdir -p %%WWWDIR%%/htdocs
+man/man1/clearxs.1.gz
+man/man1/gfxcount.1.gz
+man/man1/httpd.1.gz
+man/man1/httpdc.1.gz
+man/man1/imagemap.1.gz
+man/man1/readxs.1.gz
+man/man1/xschpass.1.gz
+man/man1/xsindex.1.gz
+man/man1/xspasswd.1.gz
+man/man5/httpd.conf.5.gz
+man/man5/xsauth.5.gz
+man/man5/xsconf.5.gz
+man/man5/xsredir.5.gz
+man/man5/xsscripts.5.gz
+man/man7/httpd_cgi.7.gz
+man/man7/httpd_ssi.7.gz
@dirrm %%WWWDIR%%/contrib
@dirrm %%WWWDIR%%/gfxcount
@dirrmtry %%WWWDIR%%/cgi-bin