aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2019-12-21 07:24:40 +0800
committerBrooks Davis <brooks@FreeBSD.org>2019-12-21 07:24:40 +0800
commit9b1a5c1c0715bf13d0e25f76a12cb6f129039350 (patch)
tree8c9765b75666794f79202f9dbcf7134c9ea89db6
parent1c8e0602f90eecc124ab267fc8a37276e90f69b0 (diff)
downloadfreebsd-ports-gnome-9b1a5c1c0715bf13d0e25f76a12cb6f129039350.tar.gz
freebsd-ports-gnome-9b1a5c1c0715bf13d0e25f76a12cb6f129039350.tar.zst
freebsd-ports-gnome-9b1a5c1c0715bf13d0e25f76a12cb6f129039350.zip
Additional builds with with src r354909 applied.
The referenced change made NO_INSTALLLIB, NO_MAN, and NO_PROFILE into errors causing these ports that declare them and use the FreeBSD make infrastructure as part of their build to fail. When the offending variables occur in a BSD Makefile, NO_MAN becomes MAN= and NO_INSTALLLIB and NO_PROFILE become MK_INSTALLLIB=no and MK_PROFILE=no respectively. When declared in the environment they become WITHOUT_<FOO>. Also GC NO_MANCOMPRESSED which doesn't do anything. In the case of devel/libpasori, this change accomplished the same thing as the change in r518434, but more directly (fix the Makefiles rather than patching them after they are installed).
-rw-r--r--comms/birda/files/patch-lib-Makefile17
-rw-r--r--comms/hcidump/files/patch-parser-Makefile11
-rw-r--r--databases/oracle8-client/files/patch-freebsd-Makefile18
-rw-r--r--devel/libpasori/files/Makefile.lib.usb202
-rw-r--r--devel/libpasori/files/Makefile.lpdump2
-rw-r--r--devel/libpasori/files/Makefile.lptest2
-rw-r--r--devel/libpasori/files/patch-lib_Makefile11
-rw-r--r--devel/libpasori/files/patch-lpdump_Makefile11
-rw-r--r--devel/libpasori/files/patch-lptest_Makefile11
-rw-r--r--devel/libxalloc/files/Makefile.lib4
-rw-r--r--graphics/squish/files/BSDmakefile2
-rw-r--r--japanese/ming/Makefile1
-rw-r--r--mail/faces/files/Makefile.compface2
-rw-r--r--mail/libdkim/files/Makefile2
-rw-r--r--math/linpack/files/Makefile.lib2
-rw-r--r--security/fbopenssl/files/BSDMakefile3
-rw-r--r--security/ipv6toolkit/files/BSDMakefile.in1
-rw-r--r--security/ipv6toolkit/files/Makefile.in1
-rw-r--r--security/openssh-askpass/files/Makefile.in1
-rw-r--r--sysutils/pefs-kmod/Makefile3
-rw-r--r--x11/gpctool/files/BSDmakefile3
21 files changed, 44 insertions, 66 deletions
diff --git a/comms/birda/files/patch-lib-Makefile b/comms/birda/files/patch-lib-Makefile
index 2d33dd9023fd..f94f9ddfd670 100644
--- a/comms/birda/files/patch-lib-Makefile
+++ b/comms/birda/files/patch-lib-Makefile
@@ -1,9 +1,16 @@
---- lib/Makefile.orig 2005-11-14 12:12:28 UTC
+--- lib/Makefile.orig
+++ lib/Makefile
-@@ -9,4 +9,6 @@ NOPROFILE= yes
- NOPIC= yes
- MKLINKLIB= no
+@@ -5,8 +5,10 @@
+ iasclt.c commsrv.c commclt.c obexsrv.c obexclt.c options.c \
+ actisys.c girbil.c litelink.c jeteye.c sendobex.c redlink.c
-+install:
+-NOPROFILE= yes
+-NOPIC= yes
+-MKLINKLIB= no
++MK_PROFILE= no
++NO_PIC= yes
++MK_LINKLIB= no
+
++install:
+
.include <bsd.lib.mk>
diff --git a/comms/hcidump/files/patch-parser-Makefile b/comms/hcidump/files/patch-parser-Makefile
index 99bf46acbe4c..6b5bfcdac4d4 100644
--- a/comms/hcidump/files/patch-parser-Makefile
+++ b/comms/hcidump/files/patch-parser-Makefile
@@ -1,6 +1,6 @@
---- parser/Makefile.orig Fri Mar 12 23:16:59 2004
-+++ parser/Makefile Fri Dec 10 21:07:28 2004
-@@ -7,8 +7,8 @@
+--- parser/Makefile.orig
++++ parser/Makefile
+@@ -7,10 +7,10 @@
MAN=
SRCS= bnep.c cmtp.c hidp.c l2cap.c rfcomm.c hci.c parser.c sdp.c
WARNS?= 2
@@ -9,5 +9,8 @@
+NO_WERROR= yes
+CFLAGS?= -O2
- NOPROFILE= 1
+-NOPROFILE= 1
++MK_PROFILE= no
+
+ .include <bsd.lib.mk>
diff --git a/databases/oracle8-client/files/patch-freebsd-Makefile b/databases/oracle8-client/files/patch-freebsd-Makefile
index a93a550c53d9..5c5641c8cb1a 100644
--- a/databases/oracle8-client/files/patch-freebsd-Makefile
+++ b/databases/oracle8-client/files/patch-freebsd-Makefile
@@ -1,10 +1,16 @@
---- freebsd/Makefile.orig 2007-11-15 10:50:25.000000000 +0600
-+++ freebsd/Makefile 2007-11-15 10:50:10.000000000 +0600
-@@ -5,6 +5,7 @@
+--- freebsd/Makefile.orig
++++ freebsd/Makefile
+@@ -4,11 +4,8 @@
+
NO_PIC= yes
NO_OBJ= yes
- NO_PROFILE= yes
+-NO_PROFILE= yes
+-
+-NOPIC= yes
+-NOOBJ= yes
+-NOPROFILE= yes
++MK_PROFILE= no
+NO_WERROR= yes
- NOPIC= yes
- NOOBJ= yes
+ LIBDIR= ${ORACLE_HOME}/lib
+
diff --git a/devel/libpasori/files/Makefile.lib.usb20 b/devel/libpasori/files/Makefile.lib.usb20
index a6132a4971a2..719f36e354e9 100644
--- a/devel/libpasori/files/Makefile.lib.usb20
+++ b/devel/libpasori/files/Makefile.lib.usb20
@@ -10,7 +10,7 @@ INCS= libpasori.h libpasori_com.h libpasori_command.h \
LIBDIR= ${LOCALBASE}/lib
INCLUDEDIR= ${LOCALBASE}/include
-NO_PROFILE=
+MK_PROFILE= no
SHLIB_MAJOR= 1
CFLAGS+= -D__LIBPASORI_WITH_LIBUSB
diff --git a/devel/libpasori/files/Makefile.lpdump b/devel/libpasori/files/Makefile.lpdump
index c2a08b99c3e2..8d73c98e7c59 100644
--- a/devel/libpasori/files/Makefile.lpdump
+++ b/devel/libpasori/files/Makefile.lpdump
@@ -7,7 +7,7 @@ DPADD= libpasori.a
LDADD= -L../lib -lpasori
BINDIR= ${LOCALBASE}/bin
-NO_MAN=
+MAN=
CFLAGS+= -Wall -W
diff --git a/devel/libpasori/files/Makefile.lptest b/devel/libpasori/files/Makefile.lptest
index 4b045140f968..9439123465f3 100644
--- a/devel/libpasori/files/Makefile.lptest
+++ b/devel/libpasori/files/Makefile.lptest
@@ -7,7 +7,7 @@ DPADD= libpasori.a
LDADD= -L../lib -lpasori
BINDIR= ${LOCALBASE}/bin
-NO_MAN=
+MAN=
CFLAGS+= -Wall -W
diff --git a/devel/libpasori/files/patch-lib_Makefile b/devel/libpasori/files/patch-lib_Makefile
deleted file mode 100644
index f879e71f8d0d..000000000000
--- a/devel/libpasori/files/patch-lib_Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/Makefile.orig
-+++ lib/Makefile
-@@ -10,7 +10,7 @@
-
- LIBDIR= ${LOCALBASE}/lib
- INCLUDEDIR= ${LOCALBASE}/include
--NO_PROFILE=
-+MK_PROFILE= no
- SHLIB_MAJOR= 1
-
- CFLAGS+= -D__LIBPASORI_WITH_LIBUSB
diff --git a/devel/libpasori/files/patch-lpdump_Makefile b/devel/libpasori/files/patch-lpdump_Makefile
deleted file mode 100644
index f1b2bf00bc5b..000000000000
--- a/devel/libpasori/files/patch-lpdump_Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- lpdump/Makefile.orig
-+++ lpdump/Makefile
-@@ -7,7 +7,7 @@
- LDADD= -L../lib -lpasori
-
- BINDIR= ${LOCALBASE}/bin
--NO_MAN=
-+MAN=
-
- CFLAGS+= -Wall -W
-
diff --git a/devel/libpasori/files/patch-lptest_Makefile b/devel/libpasori/files/patch-lptest_Makefile
deleted file mode 100644
index 817111905507..000000000000
--- a/devel/libpasori/files/patch-lptest_Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- lptest/Makefile.orig
-+++ lptest/Makefile
-@@ -7,7 +7,7 @@
- LDADD= -L../lib -lpasori
-
- BINDIR= ${LOCALBASE}/bin
--NO_MAN=
-+MAN=
-
- CFLAGS+= -Wall -W
-
diff --git a/devel/libxalloc/files/Makefile.lib b/devel/libxalloc/files/Makefile.lib
index cc30ba4d5ffa..80b276aa4f63 100644
--- a/devel/libxalloc/files/Makefile.lib
+++ b/devel/libxalloc/files/Makefile.lib
@@ -5,8 +5,8 @@ LIB= xalloc
LIBDIR= ${PREFIX}/lib
SHLIB_MAJOR= ${SHLIB_VER}
SHLIB_MINOR= 0
-NOPROFILE= yes
-NOOBJ= yes
+MK_PROFILE= no
+NO_OBJ= yes
INCS= xalloc.h
INCSDIR=${PREFIX}/include
diff --git a/graphics/squish/files/BSDmakefile b/graphics/squish/files/BSDmakefile
index cd1235207e66..0f165e1c91b2 100644
--- a/graphics/squish/files/BSDmakefile
+++ b/graphics/squish/files/BSDmakefile
@@ -1,7 +1,7 @@
LIB= squish
SHLIB_MAJOR= 1
SRCS!= echo *.cpp
-NO_PROFILE= yes
+MK_PROFILE= no
CXXFLAGS+= -include limits.h -I${.CURDIR}
diff --git a/japanese/ming/Makefile b/japanese/ming/Makefile
index 558185c5c967..76737b0519e0 100644
--- a/japanese/ming/Makefile
+++ b/japanese/ming/Makefile
@@ -19,7 +19,6 @@ LIB_DEPENDS= libpng.so:graphics/png \
CONFLICTS= ming-*
WRKSRC= ${WRKDIR}/jaming-${PORTVERSION}/src
-MAKE_ARGS= NO_PROFILE=true
USE_LDCONFIG= yes
USES= bison uidfix
MAKE_ENV= WITHOUT_PROFILE=yes __MAKE_CONF=/dev/null SRCCONF=/dev/null
diff --git a/mail/faces/files/Makefile.compface b/mail/faces/files/Makefile.compface
index 8fd2c1c71b62..070f114cf1e8 100644
--- a/mail/faces/files/Makefile.compface
+++ b/mail/faces/files/Makefile.compface
@@ -35,7 +35,7 @@ LIBNAME = lib$(NAME).a
SHLIB_MAJOR = 1
LIB = $(NAME)
SOLIB = lib$(NAME).so.$(SHLIB_MAJOR)
-NOPROFILE = ''
+MK_PROFILE = no
LIBRARY = $(LIBDIR)
MAN1DIR = $(MANDIR)/man1
MAN3DIR = $(MANDIR)/man3
diff --git a/mail/libdkim/files/Makefile b/mail/libdkim/files/Makefile
index 5ffe842d9754..2a647fd00360 100644
--- a/mail/libdkim/files/Makefile
+++ b/mail/libdkim/files/Makefile
@@ -11,6 +11,6 @@ INCLUDEDIR= ${PREFIX}/include
CXXFLAGS+= -DOPENSSL_FIPS -I${OPENSSLINC}
LDFLAGS+= -lcrypto -L${OPENSSLLIB}
-NO_PROFILE=
+MK_PROFILE= no
.include <bsd.lib.mk>
diff --git a/math/linpack/files/Makefile.lib b/math/linpack/files/Makefile.lib
index 073447e883ac..425c80c8dffc 100644
--- a/math/linpack/files/Makefile.lib
+++ b/math/linpack/files/Makefile.lib
@@ -2,7 +2,7 @@
# LINPACK sources
LIBDIR= ${PREFIX}/lib
-NOPROFILE= no
+MK_PROFILE= no
SHLIB_MAJOR= 3
LIB=linpack
diff --git a/security/fbopenssl/files/BSDMakefile b/security/fbopenssl/files/BSDMakefile
index f3964ee82d0c..1d7ead27df0c 100644
--- a/security/fbopenssl/files/BSDMakefile
+++ b/security/fbopenssl/files/BSDMakefile
@@ -9,7 +9,8 @@ LIB= fbopenssl
LIBDIR= ${PREFIX}/lib
SHLIBDIR= ${PREFIX}/lib
SHLIB_MAJOR= 0
-NO_MAN=
+MAN=
+MK_PROFILE= no
CFLAGS+=-ansi -I${OPENSSLINC}
LDADD= -Wl,-R${OPENSSLLIB} -L${OPENSSLLIB} -lcrypto
diff --git a/security/ipv6toolkit/files/BSDMakefile.in b/security/ipv6toolkit/files/BSDMakefile.in
index 083812e06c42..d161db9e4def 100644
--- a/security/ipv6toolkit/files/BSDMakefile.in
+++ b/security/ipv6toolkit/files/BSDMakefile.in
@@ -19,7 +19,6 @@ PREFIX?= /usr/local
BINDIR?= ${PREFIX}/bin
MANDIR?= ${PREFIX}/man/man
MAN= blackhole6.1 script6.1 ipv6toolkit.conf.5 ipv6toolkit.7
-NO_MANCOMPRESS=
data/ipv6toolkit.conf:
echo "# SI6 Networks' IPv6 Toolkit Configuration File" > ${.TARGET}
diff --git a/security/ipv6toolkit/files/Makefile.in b/security/ipv6toolkit/files/Makefile.in
index f4dcaafc4ab6..fde72c7cc5d4 100644
--- a/security/ipv6toolkit/files/Makefile.in
+++ b/security/ipv6toolkit/files/Makefile.in
@@ -8,7 +8,6 @@ BINDIR?= ${PREFIX}/bin
BINDIR?= ${PREFIX}/sbin
.endif
MANDIR?= ${PREFIX}/man/man
-NO_MANCOMPRESS=
.PATH: ${.CURDIR}/../tools ${.CURDIR}/../manuals
diff --git a/security/openssh-askpass/files/Makefile.in b/security/openssh-askpass/files/Makefile.in
index ffe5b585947b..5734117c23a1 100644
--- a/security/openssh-askpass/files/Makefile.in
+++ b/security/openssh-askpass/files/Makefile.in
@@ -4,7 +4,6 @@ PREFIX?= /usr/local
LOCALBASE?= /usr/local
BINDIR?= ${PREFIX}/bin
MANDIR?= ${PREFIX}/man/man
-NO_MANCOMPRESS=
CLASS= SshAskpass
FILES= ${CLASS}
diff --git a/sysutils/pefs-kmod/Makefile b/sysutils/pefs-kmod/Makefile
index c4c93885c97c..46ea61152a16 100644
--- a/sysutils/pefs-kmod/Makefile
+++ b/sysutils/pefs-kmod/Makefile
@@ -20,8 +20,7 @@ ONLY_FOR_ARCHS_REASON= untested on any other arch
USES= kmod uidfix
MAKE_JOBS_UNSAFE=yes
-MAKE_ENV= BINDIR="${PREFIX}/sbin" MANDIR="${MANPREFIX}/man/man" \
- NO_MANCOMPRESS=
+MAKE_ENV= BINDIR="${PREFIX}/sbin" MANDIR="${MANPREFIX}/man/man"
OPTIONS_DEFINE= AESNI
OPTIONS_DEFAULT=
diff --git a/x11/gpctool/files/BSDmakefile b/x11/gpctool/files/BSDmakefile
index ada4d8011e49..40a9e529bba0 100644
--- a/x11/gpctool/files/BSDmakefile
+++ b/x11/gpctool/files/BSDmakefile
@@ -1,6 +1,5 @@
PROG= gpctool
-NO_MAN= Ha-ha!
-NOMAN= ${NO_MAN}
+MAN=
SRCS= gpctool.c main.c callbacks.c graphics.c psdump.c