aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2015-09-20 09:13:47 +0800
committerjbeich <jbeich@FreeBSD.org>2015-09-20 09:13:47 +0800
commit9b732ad740635e0caf083b37a6c587f7fc6657f5 (patch)
tree55de2489e46adf7e8df2eb49a07dd5510150b7ce
parent863dde86c6223e196b52927c530c953db8fb7a0e (diff)
downloadfreebsd-ports-gnome-9b732ad740635e0caf083b37a6c587f7fc6657f5.tar.gz
freebsd-ports-gnome-9b732ad740635e0caf083b37a6c587f7fc6657f5.tar.zst
freebsd-ports-gnome-9b732ad740635e0caf083b37a6c587f7fc6657f5.zip
Convert the rest to USE_GL
Tested by: make describe (only touched ports) Approved by: portmgr blanket
-rw-r--r--devel/renpy/Makefile2
-rw-r--r--devel/rlvm/Makefile5
-rw-r--r--devel/sfml/Makefile5
-rw-r--r--editors/libreoffice/Makefile3
-rw-r--r--editors/libreoffice4/Makefile3
-rw-r--r--games/openspades/Makefile5
-rw-r--r--games/phlipple/Makefile5
-rw-r--r--games/scorched3d/Makefile5
-rw-r--r--games/warzone2100/Makefile3
-rw-r--r--graphics/gource/Makefile2
-rw-r--r--graphics/libEGL/Makefile4
-rw-r--r--graphics/libgltf/Makefile2
-rw-r--r--graphics/libprojectm/Makefile2
13 files changed, 19 insertions, 27 deletions
diff --git a/devel/renpy/Makefile b/devel/renpy/Makefile
index 89cd9ea7a818..7e6ad85c3f95 100644
--- a/devel/renpy/Makefile
+++ b/devel/renpy/Makefile
@@ -18,7 +18,6 @@ LICENSE_PERMS_DejaVu= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}game_sdl2>0:${PORTSDIR}/devel/py-game_sdl2 \
cython:${PORTSDIR}/lang/cython
LIB_DEPENDS= libfribidi.so:${PORTSDIR}/converters/fribidi \
- libGLEW.so:${PORTSDIR}/graphics/glew \
libpng.so:${PORTSDIR}/graphics/png \
libavcodec.so:${PORTSDIR}/multimedia/ffmpeg \
libfreetype.so:${PORTSDIR}/print/freetype2
@@ -28,6 +27,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}game_sdl2>=6.99.6:${PORTSDIR}/devel/py-game_
PORTSCOUT= site:http://www.renpy.org/dl/release/
USES= python:2.7 shebangfix tar:bz2
+USE_GL= glew
USE_PYTHON= autoplist distutils
USE_SDL= sdl2
EXCLUDE= gen 'module/*.py[co]' 'renpy/*.py[co]'
diff --git a/devel/rlvm/Makefile b/devel/rlvm/Makefile
index 8947dde9f4eb..63baf1689506 100644
--- a/devel/rlvm/Makefile
+++ b/devel/rlvm/Makefile
@@ -13,8 +13,7 @@ LICENSE_COMB= multi
BUILD_DEPENDS= ${LOCALBASE}/include/utf8.h:${PORTSDIR}/devel/utf8cpp
LIB_DEPENDS= libvorbisfile.so:${PORTSDIR}/audio/libvorbis \
libboost_serialization.so:${PORTSDIR}/devel/boost-libs \
- libguichan.so:${PORTSDIR}/devel/guichan \
- libGLEW.so:${PORTSDIR}/graphics/glew
+ libguichan.so:${PORTSDIR}/devel/guichan
RUN_DEPENDS= ${LOCALBASE}/share/fonts/dejavu/DejaVuSans.ttf:${PORTSDIR}/x11-fonts/dejavu
USE_GITHUB= yes
@@ -22,7 +21,7 @@ GH_ACCOUNT= eglaysher
GH_TAGNAME= 373a3db # release-${PORTVERSION}
USES= compiler:c++11-lib pkgconfig scons
-USE_GL= yes
+USE_GL= glew glu
USE_GNOME= gtk20
USE_SDL= image mixer ttf
EXCLUDE= GLEW SDL_image SDL_mixer SDL_ttf gmock gtest guichan \
diff --git a/devel/sfml/Makefile b/devel/sfml/Makefile
index 8d63ea5a66bd..9228cb1f39f6 100644
--- a/devel/sfml/Makefile
+++ b/devel/sfml/Makefile
@@ -12,13 +12,12 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Simple and Fast Multimedia Library
LIB_DEPENDS= libsndfile.so:${PORTSDIR}/audio/libsndfile \
- libfreetype.so:${PORTSDIR}/print/freetype2 \
- libGLEW.so:${PORTSDIR}/graphics/glew
+ libfreetype.so:${PORTSDIR}/print/freetype2
USES= cmake dos2unix jpeg openal:al zip:infozip
DOS2UNIX_FILES= CMakeLists.txt
USE_XORG= x11 xrandr
-USE_GL= gl
+USE_GL= gl glew
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/SFML-${PORTVERSION}
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index 2c44a26fe7ef..ce171a98b3ac 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -25,7 +25,6 @@ LIB_DEPENDS= libapr-1.so:${PORTSDIR}/devel/apr1 \
liborcus-0.10.so:${PORTSDIR}/devel/liborcus \
libcurl.so:${PORTSDIR}/ftp/curl \
libcairo.so:${PORTSDIR}/graphics/cairo \
- libGLEW.so:${PORTSDIR}/graphics/glew \
libgraphite2.so:${PORTSDIR}/graphics/graphite2 \
liblcms2.so:${PORTSDIR}/graphics/lcms2 \
libcdr-0.1.so:${PORTSDIR}/graphics/libcdr01 \
@@ -83,7 +82,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${LOVERSION}
GNU_CONFIGURE= yes
USE_AUTOTOOLS= autoconf aclocal
-USE_GL= gl glu
+USE_GL= gl glew glu
USE_OPENLDAP= yes
USE_PERL5= build
USE_QT4= # empty but required
diff --git a/editors/libreoffice4/Makefile b/editors/libreoffice4/Makefile
index b2dd46284144..3db7bc8c7388 100644
--- a/editors/libreoffice4/Makefile
+++ b/editors/libreoffice4/Makefile
@@ -37,7 +37,6 @@ LIB_DEPENDS= libapr-1.so:${PORTSDIR}/devel/apr1 \
liborcus-0.8.so:${PORTSDIR}/devel/liborcus07 \
libcurl.so:${PORTSDIR}/ftp/curl \
libcairo.so:${PORTSDIR}/graphics/cairo \
- libGLEW.so:${PORTSDIR}/graphics/glew \
libgraphite2.so:${PORTSDIR}/graphics/graphite2 \
liblcms2.so:${PORTSDIR}/graphics/lcms2 \
libcdr-0.1.so:${PORTSDIR}/graphics/libcdr01 \
@@ -85,7 +84,7 @@ _MAKE_JOBS= #
GNU_CONFIGURE= yes
USE_AUTOTOOLS= autoconf aclocal
-USE_GL= gl glu
+USE_GL= gl glew glu
USE_OPENLDAP= yes
USE_PERL5= build
USE_QT4= # empty but required
diff --git a/games/openspades/Makefile b/games/openspades/Makefile
index aeb1eff0d118..6baef7a858cb 100644
--- a/games/openspades/Makefile
+++ b/games/openspades/Makefile
@@ -16,8 +16,7 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick # for building icons
-LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
- libGLEW.so:${PORTSDIR}/graphics/glew
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
BROKEN_FreeBSD_9= does not build on FreeBSD 9.x
@@ -30,7 +29,7 @@ CMAKE_ARGS= -DOPENSPADES_RESOURCES=OFF \
-DOPENSPADES_INSTALL_BINARY="bin" \
-DOPENSPADES_INSTALL_RESOURCES="${DATADIR_REL}"
USE_SDL= sdl2 image2
-USE_GL= gl
+USE_GL= gl glew
INSTALLS_ICONS= yes
PORTDOCS= *
diff --git a/games/phlipple/Makefile b/games/phlipple/Makefile
index 60af5baa7022..074c5d59b842 100644
--- a/games/phlipple/Makefile
+++ b/games/phlipple/Makefile
@@ -11,12 +11,11 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Flipping squares will never be the same
LIB_DEPENDS= libogg.so:${PORTSDIR}/audio/libogg \
- libvorbis.so:${PORTSDIR}/audio/libvorbis \
- libGLEW.so:${PORTSDIR}/graphics/glew
+ libvorbis.so:${PORTSDIR}/audio/libvorbis
USES= desktop-file-utils pkgconfig
USE_SDL= sdl mixer image
-USE_GL= gl glu
+USE_GL= gl glew glu
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/games/scorched3d/Makefile b/games/scorched3d/Makefile
index cb5041ae01f3..070f1b84555f 100644
--- a/games/scorched3d/Makefile
+++ b/games/scorched3d/Makefile
@@ -13,8 +13,7 @@ COMMENT= 3D version of the classic DOS game Scorched Earth
LICENSE= GPLv2
-LIB_DEPENDS= libGLEW.so:${PORTSDIR}/graphics/glew \
- libvorbis.so:${PORTSDIR}/audio/libvorbis \
+LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis \
libpng.so:${PORTSDIR}/graphics/png \
libfftw3.so:${PORTSDIR}/math/fftw3 \
libfftw3f.so:${PORTSDIR}/math/fftw3-float \
@@ -24,7 +23,7 @@ OPTIONS_DEFINE= MYSQL
WRKSRC= ${WRKDIR}/scorched
-USE_GL= glu
+USE_GL= glew glu
USE_SDL= mixer net sdl
USE_WX= 2.8
WX_CONF_ARGS= absolute
diff --git a/games/warzone2100/Makefile b/games/warzone2100/Makefile
index d77eb4947e9c..ae08cf59ded6 100644
--- a/games/warzone2100/Makefile
+++ b/games/warzone2100/Makefile
@@ -17,7 +17,6 @@ LIB_DEPENDS= libphysfs.so:${PORTSDIR}/devel/physfs \
libpng.so:${PORTSDIR}/graphics/png \
libvorbis.so:${PORTSDIR}/audio/libvorbis \
libtheora.so:${PORTSDIR}/multimedia/libtheora \
- libGLEW.so:${PORTSDIR}/graphics/glew \
libfribidi.so:${PORTSDIR}/converters/fribidi \
libfreetype.so:${PORTSDIR}/print/freetype2 \
libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
@@ -25,7 +24,7 @@ RUN_DEPENDS= ${LOCALBASE}/share/fonts/dejavu/DejaVuSans.ttf:${PORTSDIR}/x11-font
USES= tar:xz bison gmake openal:al pkgconfig compiler:c++11-lang # actually, old gcc fails on unknown -W flag
GNU_CONFIGURE= yes
-USE_GL= yes
+USE_GL= glew glu
USE_SDL= sdl
USE_QT4= corelib network script gui moc_build
QT_NONSTANDARD= yes
diff --git a/graphics/gource/Makefile b/graphics/gource/Makefile
index 3a5901c7ee88..54c9dbb6bd40 100644
--- a/graphics/gource/Makefile
+++ b/graphics/gource/Makefile
@@ -15,12 +15,12 @@ BUILD_DEPENDS= ${LOCALBASE}/include/glm/glm.hpp:${PORTSDIR}/math/glm
LIB_DEPENDS= libSDL_image.so:${PORTSDIR}/graphics/sdl_image \
libfreetype.so:${PORTSDIR}/print/freetype2 \
libpcre.so:${PORTSDIR}/devel/pcre \
- libGLEW.so:${PORTSDIR}/graphics/glew \
libboost_filesystem.so:${PORTSDIR}/devel/boost-libs
RUN_DEPENDS= ${LOCALBASE}/include/glm/glm.hpp:${PORTSDIR}/math/glm
GNU_CONFIGURE= yes
USES= gmake pkgconfig compiler:c++0x
+USE_GL= glew
CONFIGURE_ARGS+=--with-boost-system=boost_system \
--with-boost-filesystem=boost_filesystem
diff --git a/graphics/libEGL/Makefile b/graphics/libEGL/Makefile
index 1ef8fe5471b5..3ea2c3072f08 100644
--- a/graphics/libEGL/Makefile
+++ b/graphics/libEGL/Makefile
@@ -11,9 +11,9 @@ COMMENT= OpenEGL library
LIB_DEPENDS+= libpthread-stubs.so:${PORTSDIR}/devel/libpthread-stubs \
libexpat.so:${PORTSDIR}/textproc/expat2 \
libdevq.so:${PORTSDIR}/devel/libdevq \
- libdrm.so:${PORTSDIR}/graphics/libdrm \
- libgbm.so:${PORTSDIR}/graphics/gbm
+ libdrm.so:${PORTSDIR}/graphics/libdrm
+USE_GL= gbm
USE_XORG= x11 xau xcb xdmcp
# stuff not needed by libEGL but configure wants it
diff --git a/graphics/libgltf/Makefile b/graphics/libgltf/Makefile
index 1e502ad30ed4..14fb9f8e52bd 100644
--- a/graphics/libgltf/Makefile
+++ b/graphics/libgltf/Makefile
@@ -13,9 +13,9 @@ LICENSE_COMB= dual
BUILD_DEPENDS= ${LOCALBASE}/include/boost/ptr_container/ptr_map.hpp:${PORTSDIR}/devel/boost-libs \
${LOCALBASE}/include/glm/glm.hpp:${PORTSDIR}/math/glm
-LIB_DEPENDS= libGLEW.so:${PORTSDIR}/graphics/glew
USES= compiler:c++0x libtool pathfix pkgconfig tar:bzip2
+USE_GL= glew
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-werror
diff --git a/graphics/libprojectm/Makefile b/graphics/libprojectm/Makefile
index f022b545a743..f9d0c6325df0 100644
--- a/graphics/libprojectm/Makefile
+++ b/graphics/libprojectm/Makefile
@@ -13,10 +13,10 @@ COMMENT= Awesome music visualiser
LICENSE= LGPL21
LIB_DEPENDS= libftgl.so:${PORTSDIR}/graphics/ftgl \
- libGLEW.so:${PORTSDIR}/graphics/glew \
libfreetype.so:${PORTSDIR}/print/freetype2
USES= cmake
+USE_GL= glew
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
USE_LDCONFIG= yes