aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2018-04-20 20:01:06 +0800
committergarga <garga@FreeBSD.org>2018-04-20 20:01:06 +0800
commit9c3e6d2dc7dce37944307a0eba4f6218e7740ee8 (patch)
treeff42a6b5141684ffa415aef66c784c2fb8749bb1
parente74793f9008583a1751e0064254d8940608d860e (diff)
downloadfreebsd-ports-gnome-9c3e6d2dc7dce37944307a0eba4f6218e7740ee8.tar.gz
freebsd-ports-gnome-9c3e6d2dc7dce37944307a0eba4f6218e7740ee8.tar.zst
freebsd-ports-gnome-9c3e6d2dc7dce37944307a0eba4f6218e7740ee8.zip
Install a gitweb.conf initial file and update pkg-message to make it easier
to configure it PR: 218229 Submitted by: Zsolt Udvari <uzsolt@uzsolt.hu> Sponsored by: Rubicon Communications, LLC (Netgate)
-rw-r--r--devel/git/Makefile9
-rw-r--r--devel/git/files/gitweb.conf.in1
-rw-r--r--devel/git/files/pkg-message.in11
-rw-r--r--devel/git/pkg-plist2
4 files changed, 15 insertions, 8 deletions
diff --git a/devel/git/Makefile b/devel/git/Makefile
index 201abed64022..896d9fa58f18 100644
--- a/devel/git/Makefile
+++ b/devel/git/Makefile
@@ -3,7 +3,7 @@
PORTNAME= git
DISTVERSION= 2.17.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= KERNEL_ORG/software/scm/git
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
@@ -23,7 +23,7 @@ CONFLICTS_INSTALL?= git-gui-[0-9]* git-subversion-[0-9]* git-lite-[0-9]*
USERS= git_daemon
GROUPS= git_daemon
-SUB_FILES= pkg-message
+SUB_FILES= pkg-message gitweb.conf
GNU_CONFIGURE= yes
USES= autoreconf gmake iconv shebangfix ssl tar:xz
@@ -234,4 +234,9 @@ post-install-CONTRIB-off:
post-install-P4-on:
${INSTALL_SCRIPT} ${WRKSRC}/git-p4.py ${STAGEDIR}${PREFIX}/bin/
+post-install-GITWEB-on:
+ ${MKDIR} ${STAGEDIR}${ETCDIR}
+ ${INSTALL_DATA} ${WRKDIR}/gitweb.conf \
+ ${STAGEDIR}${ETCDIR}/gitweb.conf.sample
+
.include <bsd.port.mk>
diff --git a/devel/git/files/gitweb.conf.in b/devel/git/files/gitweb.conf.in
new file mode 100644
index 000000000000..8f5a4f58582d
--- /dev/null
+++ b/devel/git/files/gitweb.conf.in
@@ -0,0 +1 @@
+our $projectroot="%%PREFIX%%/git/pub";
diff --git a/devel/git/files/pkg-message.in b/devel/git/files/pkg-message.in
index 7109ce1a6142..58161b5fb898 100644
--- a/devel/git/files/pkg-message.in
+++ b/devel/git/files/pkg-message.in
@@ -7,12 +7,11 @@ In the directory %%EXAMPLESDIR%%/gitweb you can find all files to
make gitweb work as a public repository on the web.
All you have to do to make gitweb work is:
-1) Copy the files %%EXAMPLESDIR%%/gitweb/* to a directory on
- your web server (e.g. Apache2) in which you are able to execute
- CGI-scripts.
-2) In gitweb.cgi, adjust the variable $projectroot to point to
- your git repository (that is where you have your *.git project
- directories).
+1) Please be sure you're able to execute CGI scripts in
+ %%EXAMPLESDIR%%/gitweb.
+2) Set the GITWEB_CONFIG variable in your webserver's config to
+ %%ETCDIR%%/gitweb.conf. This variable is passed to gitweb.cgi.
+3) Restart server.
*************************** GITWEB *************************************
*************************** CONTRIB ************************************
diff --git a/devel/git/pkg-plist b/devel/git/pkg-plist
index 8add1badeafb..69d4121c5e27 100644
--- a/devel/git/pkg-plist
+++ b/devel/git/pkg-plist
@@ -1228,6 +1228,7 @@ man/man7/gitworkflows.7.gz
%%HTMLDOCS%%%%DOCSDIR%%/user-manual.txt
share/emacs/site-lisp/git/git-blame.el
share/emacs/site-lisp/git/git.el
+%%GITWEB%%@sample %%ETCDIR%%/gitweb.conf.sample
%%GITWEB%%%%EXAMPLESDIR%%/gitweb/gitweb.cgi
%%GITWEB%%%%EXAMPLESDIR%%/gitweb/static/git-favicon.png
%%GITWEB%%%%EXAMPLESDIR%%/gitweb/static/git-logo.png
@@ -1496,3 +1497,4 @@ share/git-core/templates/info/exclude
%%NLS%%share/locale/vi/LC_MESSAGES/git.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/git.mo
@dir share/git-core/templates/branches
+@dir %%ETCDIR%%