aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-09-30 11:56:31 +0800
committerclsung <clsung@FreeBSD.org>2006-09-30 11:56:31 +0800
commit9c8b41698f8ef75bf71fa5a0773ed1316abdc4db (patch)
treeafba48c461a8d932c1e5cd4c628fa2cc1542b0e0
parentb826758dfb01db7d405319358f68f6c24f36e425 (diff)
downloadfreebsd-ports-gnome-9c8b41698f8ef75bf71fa5a0773ed1316abdc4db.tar.gz
freebsd-ports-gnome-9c8b41698f8ef75bf71fa5a0773ed1316abdc4db.tar.zst
freebsd-ports-gnome-9c8b41698f8ef75bf71fa5a0773ed1316abdc4db.zip
Add p5-Object-Array 0.060, array references with accessors.
PR: ports/102681 Submitted by: Gea-Suan Lin <gslin at gslin.org>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Object-Array/Makefile35
-rw-r--r--devel/p5-Object-Array/distinfo3
-rw-r--r--devel/p5-Object-Array/pkg-descr9
-rw-r--r--devel/p5-Object-Array/pkg-plist10
5 files changed, 58 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ec308f75aaae..850c990608cc 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1226,6 +1226,7 @@
SUBDIR += p5-OOTools
SUBDIR += p5-ORBit
SUBDIR += p5-Object-Accessor
+ SUBDIR += p5-Object-Array
SUBDIR += p5-Object-Declare
SUBDIR += p5-Object-Enum
SUBDIR += p5-Object-InsideOut
diff --git a/devel/p5-Object-Array/Makefile b/devel/p5-Object-Array/Makefile
new file mode 100644
index 000000000000..df1a498edb8f
--- /dev/null
+++ b/devel/p5-Object-Array/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-Object-Array
+# Date created: 2006-08-30
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Object-Array
+PORTVERSION= 0.060
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Object
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Array references with accessors
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/List/MoreUtils.pm:${PORTSDIR}/lang/p5-List-MoreUtils \
+ ${SITE_PERL}/Sub/Exporter.pm:${PORTSDIR}/devel/p5-Sub-Exporter \
+ ${SITE_PERL}/Sub/Install.pm:${PORTSDIR}/devel/p5-Sub-Install \
+ ${SITE_PERL}/Module/Pluggable.pm:${PORTSDIR}/devel/p5-Module-Pluggable
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Object::Array.3 Object::Array::Plugin::Builtins.3 \
+ Object::Array::Plugin::ListMoreUtils.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Object-Array/distinfo b/devel/p5-Object-Array/distinfo
new file mode 100644
index 000000000000..03e72e6e0433
--- /dev/null
+++ b/devel/p5-Object-Array/distinfo
@@ -0,0 +1,3 @@
+MD5 (Object-Array-0.060.tar.gz) = 14ff94ff5d3f9af8a72758465d0d48b6
+SHA256 (Object-Array-0.060.tar.gz) = 11bb79d63f1c432496c2475e01c8e372cda93a0979672ffe3131a7ce8e0abb9a
+SIZE (Object-Array-0.060.tar.gz) = 22868
diff --git a/devel/p5-Object-Array/pkg-descr b/devel/p5-Object-Array/pkg-descr
new file mode 100644
index 000000000000..750f8016e631
--- /dev/null
+++ b/devel/p5-Object-Array/pkg-descr
@@ -0,0 +1,9 @@
+Several of these methods do not behave exactly like their builtin
+counterparts.
+
+Specifically, any method that you would expect to return a list does
+so, but only in list context. In scalar context, these methods will
+return an Object::Array object constructed from a copy of the list
+that would have been returned.
+
+WWW: http://search.cpan.org/dist/Object-Array/
diff --git a/devel/p5-Object-Array/pkg-plist b/devel/p5-Object-Array/pkg-plist
new file mode 100644
index 000000000000..71ebe46bc48e
--- /dev/null
+++ b/devel/p5-Object-Array/pkg-plist
@@ -0,0 +1,10 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Object/Array/.packlist
+%%SITE_PERL%%/Object/Array.pm
+%%SITE_PERL%%/Object/Array/Plugin/Builtins.pm
+%%SITE_PERL%%/Object/Array/Plugin/ListMoreUtils.pm
+@dirrmtry %%SITE_PERL%%/Object/Array/Plugin
+@dirrmtry %%SITE_PERL%%/Object/Array
+@dirrmtry %%SITE_PERL%%/Object
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Object/Array
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Object