aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-04-24 01:15:38 +0800
committermiwi <miwi@FreeBSD.org>2009-04-24 01:15:38 +0800
commit9ca69a083101931380c79594a2f3c5f938226955 (patch)
treeba7a28a0ab05e94e415bfeaba0cfbf824937e4e6
parent8e7bf9ef28e7dfd1b79581071f6cb9d5e3d11696 (diff)
downloadfreebsd-ports-gnome-9ca69a083101931380c79594a2f3c5f938226955.tar.gz
freebsd-ports-gnome-9ca69a083101931380c79594a2f3c5f938226955.tar.zst
freebsd-ports-gnome-9ca69a083101931380c79594a2f3c5f938226955.zip
py-pylibacl -- Manipulate the POSIX.1e Access Control Lists with python
WWW: http://pylibacl.sourceforge.net/ PR: ports/133846 Submitted by: joris
-rw-r--r--security/Makefile1
-rw-r--r--security/py-pylibacl/Makefile20
-rw-r--r--security/py-pylibacl/distinfo3
-rw-r--r--security/py-pylibacl/pkg-descr5
-rw-r--r--security/py-pylibacl/pkg-plist1
5 files changed, 30 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 3c1b254605f0..eb20da03be3a 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -662,6 +662,7 @@
SUBDIR += py-pyclamd
SUBDIR += py-pycrypto
SUBDIR += py-pycryptopp
+ SUBDIR += py-pylibacl
SUBDIR += py-pyme
SUBDIR += py-rijndael
SUBDIR += py-tlslite
diff --git a/security/py-pylibacl/Makefile b/security/py-pylibacl/Makefile
new file mode 100644
index 000000000000..7957ecd13917
--- /dev/null
+++ b/security/py-pylibacl/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: py-pylibacl
+# Date created: 18 april 2009
+# Whom: joris
+#
+# $FreeBSD$
+#
+
+PORTNAME= pylibacl
+PORTVERSION= 0.4.0
+CATEGORIES= security python
+MASTER_SITES= SF
+
+MAINTAINER= joris.dedieu@gmail.com
+COMMENT= Manipulate ACL with Python
+
+USE_PYTHON= 2.4+
+USE_PYDISTUTILS= easy_install
+PYEASYINSTALL_ARCHDEP= yes
+
+.include <bsd.port.mk>
diff --git a/security/py-pylibacl/distinfo b/security/py-pylibacl/distinfo
new file mode 100644
index 000000000000..e3e145664c60
--- /dev/null
+++ b/security/py-pylibacl/distinfo
@@ -0,0 +1,3 @@
+MD5 (pylibacl-0.4.0.tar.gz) = 0c8c7fd673527fd63d970a6bac15779a
+SHA256 (pylibacl-0.4.0.tar.gz) = 77fdb67239f44d1e41315e36be7094a2fdf55a0021e9613540936abab3de3480
+SIZE (pylibacl-0.4.0.tar.gz) = 25469
diff --git a/security/py-pylibacl/pkg-descr b/security/py-pylibacl/pkg-descr
new file mode 100644
index 000000000000..2a32efae40fc
--- /dev/null
+++ b/security/py-pylibacl/pkg-descr
@@ -0,0 +1,5 @@
+py-pylibacl -- Manipulate the POSIX.1e Access Control Lists with python
+
+
+Author: Iustin Pop, <iusty@k1024.org>
+WWW: http://pylibacl.sourceforge.net/
diff --git a/security/py-pylibacl/pkg-plist b/security/py-pylibacl/pkg-plist
new file mode 100644
index 000000000000..ddf68a1c022f
--- /dev/null
+++ b/security/py-pylibacl/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%