aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-02-10 08:10:04 +0800
committerYuri Victorovich <yuri@FreeBSD.org>2019-02-10 08:10:04 +0800
commit9f5ff5d3f9dd485c54624af2dbbf539d3e9ff562 (patch)
tree9e73cfb2e2251d261efe65ef8032b97827c13507
parent756c12bcdebc71e4af3cd8cfadb927fb1ebcf230 (diff)
downloadfreebsd-ports-gnome-9f5ff5d3f9dd485c54624af2dbbf539d3e9ff562.tar.gz
freebsd-ports-gnome-9f5ff5d3f9dd485c54624af2dbbf539d3e9ff562.tar.zst
freebsd-ports-gnome-9f5ff5d3f9dd485c54624af2dbbf539d3e9ff562.zip
math/xtensor: Update 0.19.1 -> 0.19.3
Reported by: portscout
-rw-r--r--math/xtensor/Makefile2
-rw-r--r--math/xtensor/distinfo6
-rw-r--r--math/xtensor/files/patch-test_CMakeLists.txt16
-rw-r--r--math/xtensor/pkg-plist1
4 files changed, 12 insertions, 13 deletions
diff --git a/math/xtensor/Makefile b/math/xtensor/Makefile
index c779f953cec2..f7fae7735c3b 100644
--- a/math/xtensor/Makefile
+++ b/math/xtensor/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= xtensor
-DISTVERSION= 0.19.1
+DISTVERSION= 0.19.3
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
diff --git a/math/xtensor/distinfo b/math/xtensor/distinfo
index dac37d80e807..c2cf0854067e 100644
--- a/math/xtensor/distinfo
+++ b/math/xtensor/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1545516526
-SHA256 (QuantStack-xtensor-0.19.1_GH0.tar.gz) = 52ac9081138d413485b9bf70376722f109ab32e5ed2ed3311257f5d7e9a88bc7
-SIZE (QuantStack-xtensor-0.19.1_GH0.tar.gz) = 904812
+TIMESTAMP = 1549754028
+SHA256 (QuantStack-xtensor-0.19.3_GH0.tar.gz) = 51510735809ee7ab5312197b303f117167667aacb9254605f272b08efa8880f2
+SIZE (QuantStack-xtensor-0.19.3_GH0.tar.gz) = 903954
diff --git a/math/xtensor/files/patch-test_CMakeLists.txt b/math/xtensor/files/patch-test_CMakeLists.txt
index f42160a2eb85..89e9a7b39078 100644
--- a/math/xtensor/files/patch-test_CMakeLists.txt
+++ b/math/xtensor/files/patch-test_CMakeLists.txt
@@ -1,4 +1,4 @@
---- test/CMakeLists.txt.orig 2018-06-22 15:12:37 UTC
+--- test/CMakeLists.txt.orig 2019-02-04 09:16:01 UTC
+++ test/CMakeLists.txt
@@ -8,12 +8,13 @@
@@ -19,20 +19,20 @@
message(STATUS "Forcing tests build type to Release")
set(CMAKE_BUILD_TYPE Release CACHE STRING "Choose the type of build." FORCE)
-@@ -174,7 +175,7 @@ add_custom_target(
- foreach(filename IN LISTS XTENSOR_TESTS)
+@@ -192,7 +193,7 @@ foreach(filename IN LISTS XTENSOR_TESTS)
string(REPLACE ".cpp" "" targetname ${filename})
add_executable(${targetname} ${COMMON_BASE} ${filename} ${XTENSOR_HEADERS})
+ target_include_directories(${targetname} PRIVATE ${XTENSOR_INCLUDE_DIR})
- target_link_libraries(${targetname} xtensor ${GTEST_BOTH_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
+ target_link_libraries(${targetname} ${GTEST_BOTH_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
if(DOWNLOAD_GTEST OR GTEST_SRC_DIR)
add_dependencies(${targetname} gtest_main)
endif()
-@@ -188,6 +189,6 @@ add_executable(${XTENSOR_TARGET} ${COMMO
+@@ -207,6 +208,6 @@ target_include_directories(test_xtensor_
if(DOWNLOAD_GTEST OR GTEST_SRC_DIR)
- add_dependencies(${XTENSOR_TARGET} gtest_main)
+ add_dependencies(test_xtensor_lib gtest_main)
endif()
--target_link_libraries(${XTENSOR_TARGET} xtensor ${GTEST_BOTH_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
-+target_link_libraries(${XTENSOR_TARGET} ${GTEST_BOTH_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
+-target_link_libraries(test_xtensor_lib xtensor ${GTEST_BOTH_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
++target_link_libraries(test_xtensor_lib ${GTEST_BOTH_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
- add_custom_target(xtest COMMAND ${XTENSOR_TARGET} DEPENDS ${XTENSOR_TARGET})
+ add_custom_target(xtest COMMAND test_xtensor_lib DEPENDS test_xtensor_lib)
diff --git a/math/xtensor/pkg-plist b/math/xtensor/pkg-plist
index 0e1215b794a3..b19002fdd74f 100644
--- a/math/xtensor/pkg-plist
+++ b/math/xtensor/pkg-plist
@@ -7,7 +7,6 @@ include/xtensor/xbroadcast.hpp
include/xtensor/xbuffer_adaptor.hpp
include/xtensor/xbuilder.hpp
include/xtensor/xcomplex.hpp
-include/xtensor/xconcepts.hpp
include/xtensor/xcontainer.hpp
include/xtensor/xcsv.hpp
include/xtensor/xdynamic_view.hpp