aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2011-05-15 00:50:43 +0800
committerpgj <pgj@FreeBSD.org>2011-05-15 00:50:43 +0800
commit9febadef7ce6f494f14a6ab60f7336de57fd48fd (patch)
tree443a29d418900a7480b0b6a3c69a3b560880b0e9
parente978e19877dfa92f1b134ba9ee1c4fb4bf7badf6 (diff)
downloadfreebsd-ports-gnome-9febadef7ce6f494f14a6ab60f7336de57fd48fd.tar.gz
freebsd-ports-gnome-9febadef7ce6f494f14a6ab60f7336de57fd48fd.tar.zst
freebsd-ports-gnome-9febadef7ce6f494f14a6ab60f7336de57fd48fd.zip
The Haskell Platform (HP) is the blessed set of libraries and tools on which
to build further Haskell libraries and applications. It is intended to provide a comprehensive, stable, and quality-tested base for Haskell projects to work from. This version specifies the following additional developer tools be installed, for a system to be in full compliance: * cabal-install * alex * happy * haddock WWW: http://haskell.org/platform/ Obtained from: FreeBSD Haskell
-rw-r--r--devel/Makefile1
-rw-r--r--devel/hs-haskell-platform/Makefile46
-rw-r--r--devel/hs-haskell-platform/pkg-descr15
3 files changed, 62 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6e4d52ec84c2..6140bac9bd60 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -602,6 +602,7 @@
SUBDIR += hs-happy
SUBDIR += hs-hashed-storage
SUBDIR += hs-haskeline
+ SUBDIR += hs-haskell-platform
SUBDIR += hs-haskell-src
SUBDIR += hs-haskell-src-exts
SUBDIR += hs-hat
diff --git a/devel/hs-haskell-platform/Makefile b/devel/hs-haskell-platform/Makefile
new file mode 100644
index 000000000000..a185f263ee9b
--- /dev/null
+++ b/devel/hs-haskell-platform/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: haskell-platform
+# Date created: April 23, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= haskell-platform
+PORTVERSION= 2011.2.0.1
+CATEGORIES= devel haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= The Haskell Platform
+
+LICENSE= BSD
+
+METAPORT= yes
+USE_CABAL= cgi==3001.1.7.4,1 \
+ fgl==5.4.2.3_1 \
+ GLUT==2.1.2.1,1 \
+ haskell-src==1.0.1.4 \
+ html==1.0.1.2 \
+ HUnit==1.2.2.3 \
+ mtl==2.0.1.0 \
+ network==2.3.0.2 \
+ OpenGL==2.2.3.0,1 \
+ parallel==3.1.0.1 \
+ parsec==3.1.1 \
+ QuickCheck==2.4.0.1 \
+ regex-base==0.93.2 \
+ regex-compat==0.93.1 \
+ regex-posix==0.94.4 \
+ stm==2.2.0.1 \
+ syb==0.3 \
+ xhtml==3000.2.0.1 \
+ zlib==0.5.3.1 \
+ HTTP==4000.1.1 \
+ deepseq==1.1.0.2 \
+ text=0.11.0.6 \
+ transformers==0.2.2.0 \
+ cabal-install==0.10.2 \
+ alex==2.3.5 \
+ happy==1.18.6
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/devel/hs-haskell-platform/pkg-descr b/devel/hs-haskell-platform/pkg-descr
new file mode 100644
index 000000000000..678f2c09926a
--- /dev/null
+++ b/devel/hs-haskell-platform/pkg-descr
@@ -0,0 +1,15 @@
+The Haskell Platform (HP) is the blessed set of libraries and tools on which
+to build further Haskell libraries and applications. It is intended to
+provide a comprehensive, stable, and quality-tested base for Haskell projects
+to work from.
+
+This version specifies the following additional developer tools be installed,
+for a system to be in full compliance:
+
+ * cabal-install
+ * alex
+ * happy
+ * haddock
+
+
+WWW: http://haskell.org/platform/