aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2012-12-21 01:13:51 +0800
committerpawel <pawel@FreeBSD.org>2012-12-21 01:13:51 +0800
commita01597efdf63263290f15ee61ff4af7a270f0c08 (patch)
tree0f084cdcd0ef48d6aad8a5785172281aa78ad7ed
parent81c35f125afe7ea8af6b76faeff7b61d918a583c (diff)
downloadfreebsd-ports-gnome-a01597efdf63263290f15ee61ff4af7a270f0c08.tar.gz
freebsd-ports-gnome-a01597efdf63263290f15ee61ff4af7a270f0c08.tar.zst
freebsd-ports-gnome-a01597efdf63263290f15ee61ff4af7a270f0c08.zip
rifiuti2 is a rewrite of rifiuti, a great tool from Foundstone folks
for analyzing Windows Recycle Bin INFO2 file. But since rifiuti (last updated 2004) is restricted to English version of Windows (fail to analyze any non-latin character), thus this rewrite. WWW: http://code.google.com/p/rifiuti2/ PR: ports/174031 Submitted by: antoine@FreeBSD.org
-rw-r--r--security/Makefile1
-rw-r--r--security/rifiuti2/Makefile42
-rw-r--r--security/rifiuti2/distinfo2
-rw-r--r--security/rifiuti2/pkg-descr6
4 files changed, 51 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 8a6d626ec650..018dd87c3f7b 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -815,6 +815,7 @@
SUBDIR += regripperplugins
SUBDIR += retranslator
SUBDIR += revelation
+ SUBDIR += rifiuti2
SUBDIR += rkhunter
SUBDIR += ruby-acl
SUBDIR += ruby-camellia
diff --git a/security/rifiuti2/Makefile b/security/rifiuti2/Makefile
new file mode 100644
index 000000000000..c4d9341b147b
--- /dev/null
+++ b/security/rifiuti2/Makefile
@@ -0,0 +1,42 @@
+# Created by: antoine@FreeBSD.org
+# $FreeBSD$
+
+PORTNAME= rifiuti2
+DISTVERSION= 0.5.1
+CATEGORIES= security
+MASTER_SITES= GOOGLE_CODE
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Tool for analyzing Windows recycle bin
+
+LICENSE= BSD
+
+LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
+
+GNU_CONFIGURE= yes
+USE_PKGCONFIG= build
+USE_GETTEXT= yes
+USE_ICONV= yes
+USE_GNOME= glib20
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+PLIST_FILES= bin/rifiuti bin/rifiuti-vista
+
+MAN1= rifiuti.1
+MLINKS= rifiuti.1 rifiuti-vista.1
+
+OPTIONS_DEFINE= DOCS
+
+PORTDOCS= AUTHORS COPYING ChangeLog NEWS README THANKS TODO
+
+.include <bsd.port.options.mk>
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/rifiuti2/distinfo b/security/rifiuti2/distinfo
new file mode 100644
index 000000000000..b147817ac28e
--- /dev/null
+++ b/security/rifiuti2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rifiuti2-0.5.1.tar.gz) = b8db7d9ff442d71794256a97103134200b286c19134f2fe30506f58035a380b2
+SIZE (rifiuti2-0.5.1.tar.gz) = 109598
diff --git a/security/rifiuti2/pkg-descr b/security/rifiuti2/pkg-descr
new file mode 100644
index 000000000000..ce29539e9e58
--- /dev/null
+++ b/security/rifiuti2/pkg-descr
@@ -0,0 +1,6 @@
+rifiuti2 is a rewrite of rifiuti, a great tool from Foundstone folks
+for analyzing Windows Recycle Bin INFO2 file. But since rifiuti
+(last updated 2004) is restricted to English version of Windows
+(fail to analyze any non-latin character), thus this rewrite.
+
+WWW: http://code.google.com/p/rifiuti2/