aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-05-02 22:11:03 +0800
committerbapt <bapt@FreeBSD.org>2013-05-02 22:11:03 +0800
commita03024f3f5e3c9362b5f357b1f2a1782ff6be469 (patch)
treee61a997db96cf00e80c0e9befaaa02d633c7e998
parente001b601fb2a38f6d01c9726de51a1a681e75d45 (diff)
downloadfreebsd-ports-gnome-a03024f3f5e3c9362b5f357b1f2a1782ff6be469.tar.gz
freebsd-ports-gnome-a03024f3f5e3c9362b5f357b1f2a1782ff6be469.tar.zst
freebsd-ports-gnome-a03024f3f5e3c9362b5f357b1f2a1782ff6be469.zip
Only try to retrieve python's version is the python command is installed to please bmake
Obtained from: dports
-rw-r--r--Mk/bsd.python.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index f065310bde21..d94abd1c5093 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -359,8 +359,10 @@ DEPENDS_ARGS+= PYTHON_VERSION=${PYTHON_VERSION}
# should point to some other version we have installed, according to the port USE_PYTHON
# specification
.if !defined(PYTHON_DEFAULT_PORTVERSION) || (${PYTHON_VERSION} != ${PYTHON_DEFAULT_VERSION})
+.if exists(${PYTHON_CMD})
_PYTHON_PORTVERSION!= (${PYTHON_CMD} -c 'import sys; \
print(sys.version.split()[0].replace("b",".b"))' 2> /dev/null) | ${TAIL} -1
+.endif
.if !defined(PYTHON_NO_DEPENDS) && !empty(_PYTHON_PORTVERSION)
PYTHON_PORTVERSION= ${_PYTHON_PORTVERSION}
.endif