aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbeat <beat@FreeBSD.org>2012-06-09 16:28:38 +0800
committerbeat <beat@FreeBSD.org>2012-06-09 16:28:38 +0800
commita0d969aa9b8c359b053aa981e4c8c06a58771c45 (patch)
tree47647fe866be4a3b5577245c98ad8e80fd61935f
parent2565692d300da92f0aba191a73780893b2d1750d (diff)
downloadfreebsd-ports-gnome-a0d969aa9b8c359b053aa981e4c8c06a58771c45.tar.gz
freebsd-ports-gnome-a0d969aa9b8c359b053aa981e4c8c06a58771c45.tar.zst
freebsd-ports-gnome-a0d969aa9b8c359b053aa981e4c8c06a58771c45.zip
- Update Thunderbird to 13.0
- Use GCC 4.6 to fix build on newer FreeBSD versions - Update required nspr version [1] PR: ports/167431 [1] Submitted by: Toomas Aas <toomas.aas AT raad.tartu.ee> [1] Security: http://www.vuxml.org/freebsd/bfecf7c1-af47-11e1-9580-4061862b8c22.html
-rw-r--r--Mk/bsd.gecko.mk10
-rw-r--r--mail/thunderbird/Makefile9
-rw-r--r--mail/thunderbird/distinfo4
-rw-r--r--mail/thunderbird/files/patch-bugzilla-736961111
-rw-r--r--mail/thunderbird/files/patch-mail-app-Makefile.in254
-rw-r--r--mail/thunderbird/files/patch-mozilla-configure.in41
6 files changed, 385 insertions, 44 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 88afdbc22e3e..0c6d6eb39ba6 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -203,7 +203,7 @@ Gecko_Pre_Include= bsd.gecko.mk
# version is given by the maintainer via the port
# or by the user via defined variable try to find
# the highest stable installed version.
-# Available values: yes 10+ 12+ 10 12
+# Available values: yes 10+ 13+ 10 13
# NOTE:
# default value 10 is used in case of USE_THUNDERBIRD=yes
#
@@ -373,11 +373,11 @@ _THUNDERBIRD_BUILD_DEPENDS= yes
.endif
_THUNDERBIRD_DEFAULT_VERSION= 10
-_THUNDERBIRD_VERSIONS= 10 12
-_THUNDERBIRD_RANGE_VERSIONS= 10+ 12+
+_THUNDERBIRD_VERSIONS= 10 13
+_THUNDERBIRD_RANGE_VERSIONS= 10+ 13+
# For specifying [10, ..]+
-_THUNDERBIRD_12P= 12 ${_THUNDERBIRD_10P}
+_THUNDERBIRD_13P= 13 ${_THUNDERBIRD_10P}
_THUNDERBIRD_10P= 10
# Set the default Thunderbird version and check if USE_THUNDERBIRD=yes was given
@@ -424,7 +424,7 @@ IGNORE= cannot install: unknown Thunderbird version: thunderbird-${USE_THUNDER
# Dependence lines for different Thunderbird versions
10_DEPENDS= ${LOCALBASE}/lib/thunderbird/thunderbird:${PORTSDIR}/mail/thunderbird-esr
-12_DEPENDS= ${LOCALBASE}/lib/thunderbird/thunderbird:${PORTSDIR}/mail/thunderbird
+13_DEPENDS= ${LOCALBASE}/lib/thunderbird/thunderbird:${PORTSDIR}/mail/thunderbird
# Add dependencies
.if defined(USE_THUNDERBIRD)
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index caad57924315..351bc61d1f48 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= thunderbird
-DISTVERSION= 12.0.1
-PORTREVISION= 1
+DISTVERSION= 13.0
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${DISTVERSION}/source
@@ -16,7 +15,7 @@ DISTNAME= ${PORTNAME}-${DISTVERSION}.source
MAINTAINER= gecko@FreeBSD.org
COMMENT= Mozilla Thunderbird is standalone mail and news that stands above
-BUILD_DEPENDS= nspr>=4.8.7:${PORTSDIR}/devel/nspr \
+BUILD_DEPENDS= nspr>=4.9:${PORTSDIR}/devel/nspr \
cairo>=1.10.2_1,1:${PORTSDIR}/graphics/cairo \
unzip:${PORTSDIR}/archivers/unzip
LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo \
@@ -62,6 +61,10 @@ OPTIONS= LIGHTNING "Enable calendar extension" off
.include <bsd.port.pre.mk>
+.if empty(CXX:M*clang++*) && ${OSVERSION} > 900000
+USE_GCC= 4.6+
+.endif
+
WRKSRC= ${WRKDIR}/comm-release
MOZSRC:= ${WRKSRC}/mozilla
diff --git a/mail/thunderbird/distinfo b/mail/thunderbird/distinfo
index e6eb13d76484..a19e6cc1ab04 100644
--- a/mail/thunderbird/distinfo
+++ b/mail/thunderbird/distinfo
@@ -1,2 +1,2 @@
-SHA256 (thunderbird-12.0.1.source.tar.bz2) = d8914f27b0ec71d940475a8942c951b106ecda69fd3a2954047584663a6ab183
-SIZE (thunderbird-12.0.1.source.tar.bz2) = 101253776
+SHA256 (thunderbird-13.0.source.tar.bz2) = 50fbb2e50d9294067974d3270899f32fbeb61e7951becb5deaf09ac5cf874dfb
+SIZE (thunderbird-13.0.source.tar.bz2) = 102799262
diff --git a/mail/thunderbird/files/patch-bugzilla-736961 b/mail/thunderbird/files/patch-bugzilla-736961
new file mode 100644
index 000000000000..2b5a8cc9ae29
--- /dev/null
+++ b/mail/thunderbird/files/patch-bugzilla-736961
@@ -0,0 +1,111 @@
+--- mozilla/config/rules.mk.orig Wed May 2 05:16:35 2012
++++ mozilla/config/rules.mk Fri May 11 08:42:50 2012
+@@ -1479,7 +1487,7 @@ $(XPIDL_GEN_DIR)/%.h: %.idl $(XPIDL_DEPS) $(XPIDL_GEN_
+ $(PYTHON_PATH) \
+ -I$(topsrcdir)/other-licenses/ply \
+ -I$(topsrcdir)/xpcom/idl-parser \
+- $(topsrcdir)/xpcom/idl-parser/header.py --cachedir=$(DEPTH)/xpcom/idl-parser $(XPIDL_FLAGS) $(_VPATH_SRCS) -d $(MDDEPDIR)/$(@F).pp -o $@
++ $(topsrcdir)/xpcom/idl-parser/header.py --cachedir=$(DEPTH)/xpcom/idl-parser/cache $(XPIDL_FLAGS) $(_VPATH_SRCS) -d $(MDDEPDIR)/$(@F).pp -o $@
+ @if test -n "$(findstring $*.h, $(EXPORTS))"; \
+ then echo "*** WARNING: file $*.h generated from $*.idl overrides $(srcdir)/$*.h"; else true; fi
+
+@@ -1492,7 +1500,7 @@ $(XPIDL_GEN_DIR)/%.xpt: %.idl $(XPIDL_DEPS) $(XPIDL_GE
+ -I$(topsrcdir)/other-licenses/ply \
+ -I$(topsrcdir)/xpcom/idl-parser \
+ -I$(topsrcdir)/xpcom/typelib/xpt/tools \
+- $(topsrcdir)/xpcom/idl-parser/typelib.py --cachedir=$(DEPTH)/xpcom/idl-parser $(XPIDL_FLAGS) $(_VPATH_SRCS) -d $(MDDEPDIR)/$(@F).pp -o $@
++ $(topsrcdir)/xpcom/idl-parser/typelib.py --cachedir=$(DEPTH)/xpcom/idl-parser/cache $(XPIDL_FLAGS) $(_VPATH_SRCS) -d $(MDDEPDIR)/$(@F).pp -o $@
+
+ # no need to link together if XPIDLSRCS contains only XPIDL_MODULE
+ ifneq ($(XPIDL_MODULE).idl,$(strip $(XPIDLSRCS)))
+--- mozilla/js/src/config/rules.mk.orig Fri May 11 08:42:57 2012
++++ mozilla/js/src/config/rules.mk Fri May 11 08:43:15 2012
+@@ -1479,7 +1479,7 @@ $(XPIDL_GEN_DIR)/%.h: %.idl $(XPIDL_DEPS) $(XPIDL_GEN_
+ $(PYTHON_PATH) \
+ -I$(topsrcdir)/other-licenses/ply \
+ -I$(topsrcdir)/xpcom/idl-parser \
+- $(topsrcdir)/xpcom/idl-parser/header.py --cachedir=$(DEPTH)/xpcom/idl-parser $(XPIDL_FLAGS) $(_VPATH_SRCS) -d $(MDDEPDIR)/$(@F).pp -o $@
++ $(topsrcdir)/xpcom/idl-parser/header.py --cachedir=$(DEPTH)/xpcom/idl-parser/cache $(XPIDL_FLAGS) $(_VPATH_SRCS) -d $(MDDEPDIR)/$(@F).pp -o $@
+ @if test -n "$(findstring $*.h, $(EXPORTS))"; \
+ then echo "*** WARNING: file $*.h generated from $*.idl overrides $(srcdir)/$*.h"; else true; fi
+
+@@ -1492,7 +1492,7 @@ $(XPIDL_GEN_DIR)/%.xpt: %.idl $(XPIDL_DEPS) $(XPIDL_GE
+ -I$(topsrcdir)/other-licenses/ply \
+ -I$(topsrcdir)/xpcom/idl-parser \
+ -I$(topsrcdir)/xpcom/typelib/xpt/tools \
+- $(topsrcdir)/xpcom/idl-parser/typelib.py --cachedir=$(DEPTH)/xpcom/idl-parser $(XPIDL_FLAGS) $(_VPATH_SRCS) -d $(MDDEPDIR)/$(@F).pp -o $@
++ $(topsrcdir)/xpcom/idl-parser/typelib.py --cachedir=$(DEPTH)/xpcom/idl-parser/cache $(XPIDL_FLAGS) $(_VPATH_SRCS) -d $(MDDEPDIR)/$(@F).pp -o $@
+
+ # no need to link together if XPIDLSRCS contains only XPIDL_MODULE
+ ifneq ($(XPIDL_MODULE).idl,$(strip $(XPIDLSRCS)))
+--- mozilla/js/xpconnect/src/Makefile.in.orig Fri May 11 08:43:27 2012
++++ mozilla/js/xpconnect/src/Makefile.in Fri May 11 08:44:03 2012
+@@ -151,7 +151,7 @@ dom_quickstubs.cpp: $(srcdir)/dom_quickstubs.qsconf \
+ -I$(topsrcdir)/xpcom/idl-parser \
+ $(srcdir)/qsgen.py \
+ --idlpath=$(DEPTH)/dist/idl \
+- --cachedir=$(DEPTH)/xpcom/idl-parser \
++ --cachedir=$(DEPTH)/xpcom/idl-parser/cache \
+ --header-output dom_quickstubs.h \
+ --stub-output dom_quickstubs.cpp \
+ --makedepend-output $(MDDEPDIR)/dom_qsgen.pp \
+@@ -172,7 +172,7 @@ dombindings_gen.h: $(srcdir)/dombindings.conf \
+ -I$(topsrcdir)/xpcom/idl-parser \
+ $(srcdir)/dombindingsgen.py \
+ --idlpath=$(DEPTH)/dist/idl \
+- --cachedir=$(DEPTH)/xpcom/idl-parser \
++ --cachedir=$(DEPTH)/xpcom/idl-parser/cache \
+ --header-output dombindings_gen.h \
+ $(srcdir)/dombindings.conf
+
+@@ -189,7 +189,7 @@ dombindings_gen.cpp: $(srcdir)/dombindings.conf \
+ -I$(topsrcdir)/xpcom/idl-parser \
+ $(srcdir)/dombindingsgen.py \
+ --idlpath=$(DEPTH)/dist/idl \
+- --cachedir=$(DEPTH)/xpcom/idl-parser \
++ --cachedir=$(DEPTH)/xpcom/idl-parser/cache \
+ --stub-output dombindings_gen.cpp \
+ --makedepend-output $(MDDEPDIR)/dombindingsgen.pp \
+ $(srcdir)/dombindings.conf
+@@ -208,7 +208,7 @@ DictionaryHelpers.h: $(srcdir)/dictionary_helper_gen.c
+ -I$(topsrcdir)/xpcom/idl-parser \
+ $(srcdir)/dictionary_helper_gen.py \
+ -I $(DEPTH)/dist/idl \
+- --cachedir=$(DEPTH)/xpcom/idl-parser \
++ --cachedir=$(DEPTH)/xpcom/idl-parser/cache \
+ --header-output DictionaryHelpers.h \
+ $(srcdir)/dictionary_helper_gen.conf
+
+@@ -223,7 +223,7 @@ DictionaryHelpers.cpp: $(srcdir)/dictionary_helper_gen
+ -I$(topsrcdir)/xpcom/idl-parser \
+ $(srcdir)/dictionary_helper_gen.py \
+ -I $(DEPTH)/dist/idl \
+- --cachedir=$(DEPTH)/xpcom/idl-parser \
++ --cachedir=$(DEPTH)/xpcom/idl-parser/cache \
+ --header-output DictionaryHelpers.h \
+ --stub-output DictionaryHelpers.cpp \
+ --makedepend-output $(MDDEPDIR)/dictionary_helper_gen.pp \
+--- mozilla/xpcom/idl-parser/Makefile.in.orig Fri May 11 08:44:10 2012
++++ mozilla/xpcom/idl-parser/Makefile.in Fri May 11 08:44:29 2012
+@@ -61,7 +61,7 @@ export:: $(PARSER_SRCS) $(PLY_PROGS)
+ $(PYTHON_PATH) \
+ -I$(topsrcdir)/other-licenses/ply \
+ -I$(topsrcdir)/xpcom/idl-parser \
+- $(topsrcdir)/xpcom/idl-parser/header.py --cachedir=. --regen
++ $(topsrcdir)/xpcom/idl-parser/header.py --cachedir=$(DEPTH)/xpcom/idl-parser/cache --regen
+
+ check::
+ $(PYTHON_PATH) \
+--- mozilla/xpcom/typelib/xpidl/Makefile.in.orig Fri May 11 08:44:51 2012
++++ mozilla/xpcom/typelib/xpidl/Makefile.in Fri May 11 08:45:09 2012
+@@ -48,8 +48,8 @@ SDK_BINARY = \
+ $(topsrcdir)/xpcom/idl-parser/xpidl.py \
+ $(topsrcdir)/xpcom/idl-parser/header.py \
+ $(topsrcdir)/xpcom/idl-parser/typelib.py \
+- $(DEPTH)/xpcom/idl-parser/xpidllex.py \
+- $(DEPTH)/xpcom/idl-parser/xpidlyacc.py \
++ $(DEPTH)/xpcom/idl-parser/cache/xpidllex.py \
++ $(DEPTH)/xpcom/idl-parser/cache/xpidlyacc.py \
+ $(NULL)
+
+ ifndef MOZ_SYSTEM_PLY
diff --git a/mail/thunderbird/files/patch-mail-app-Makefile.in b/mail/thunderbird/files/patch-mail-app-Makefile.in
new file mode 100644
index 000000000000..237c8147bd27
--- /dev/null
+++ b/mail/thunderbird/files/patch-mail-app-Makefile.in
@@ -0,0 +1,254 @@
+--- mail/app/Makefile.in 2012-06-01 19:11:49.000000000 +0200
++++ /usr/ports/mail/thunderbird/work/comm-release/mail/app/Makefile.in 2012-04-28 21:31:30.000000000 +0200
+@@ -47,6 +47,13 @@
+ GRE_MILESTONE = $(shell $(PYTHON) $(MOZILLA_SRCDIR)/config/printconfigsetting.py $(LIBXUL_DIST)/bin/platform.ini Build Milestone)
+ GRE_BUILDID = $(shell $(PYTHON) $(MOZILLA_SRCDIR)/config/printconfigsetting.py $(LIBXUL_DIST)/bin/platform.ini Build BuildID)
+
++DEFINES += \
++ -DTHUNDERBIRD_ICO=\"$(DIST)/branding/thunderbird.ico\" \
++ -DAB_CD=$(AB_CD) \
++ -DGRE_MILESTONE=$(GRE_MILESTONE) \
++ -DGRE_BUILDID=$(GRE_BUILDID) \
++ $(NULL)
++
+ MOZ_SOURCE_STAMP = $(firstword $(shell hg -R $(topsrcdir) parent --template="{node|short}\n" 2>/dev/null))
+ ifdef MOZ_SOURCE_STAMP
+ DEFINES += -DMOZ_SOURCE_STAMP="$(MOZ_SOURCE_STAMP)"
+@@ -58,30 +65,26 @@
+ endif
+
+ ifdef MOZILLA_OFFICIAL
+-DEFINES += -DMOZILLA_OFFICIAL
++DEFINES += -DOFFICIAL_BUILD=1
+ endif
+
+ DIRS = profile
+
++GARBAGE += \
++ $(FINAL_TARGET)/license.html \
++ $(NULL)
++
+ PREF_JS_EXPORTS = \
+ $(srcdir)/profile/all-thunderbird.js \
+ $(srcdir)/profile/channel-prefs.js \
+ $(NULL)
+
+-DEFINES += \
+- -DAB_CD=$(AB_CD) \
+- -DAPP_VERSION="$(MOZ_APP_VERSION)" \
+- -DTHUNDERBIRD_ICO=\"$(DIST)/branding/thunderbird.ico\" \
+- -DGRE_MILESTONE=$(GRE_MILESTONE) \
+- -DGRE_BUILDID=$(GRE_BUILDID) \
+- $(NULL)
+-
+-ifdef LIBXUL_SDK
+-include $(topsrcdir)/config/rules.mk
++ifneq (,$(filter OS2 Darwin WINNT,$(OS_ARCH)))
++PROGRAM = $(MOZ_APP_NAME)$(BIN_SUFFIX)
+ else
+-# Build a binary bootstrapping with XRE_main
++PROGRAM = $(MOZ_APP_NAME)-bin$(BIN_SUFFIX)
++endif
+
+-PROGRAM = $(MOZ_APP_NAME)$(BIN_SUFFIX)
+
+ CPPSRCS = nsMailApp.cpp
+
+@@ -96,13 +99,21 @@
+ DEFINES += -DXPCOM_GLUE
+ STL_FLAGS=
+
++ifeq (cocoa,$(MOZ_WIDGET_TOOLKIT))
++TK_LIBS := -framework Cocoa $(TK_LIBS)
++endif
++
+ LIBS += \
+ $(EXTRA_DSO_LIBS) \
+ $(XPCOM_STANDALONE_GLUE_LDOPTS) \
+ $(NULL)
+
+-ifdef MOZ_LINKER
+-LIBS += $(ZLIB_LIBS)
++ifdef MOZ_JPROF
++LIBS += -ljprof
++endif
++
++ifdef MOZ_ENABLE_DBUS
++LIBS += $(MOZ_DBUS_GLIB_LIBS)
+ endif
+
+ ifndef MOZ_WINCONSOLE
+@@ -136,6 +147,8 @@
+
+ GARBAGE += write-message.ico address-book.ico
+
++OS_LIBS += $(call EXPAND_LIBNAME,comctl32 comdlg32 uuid shell32 ole32 oleaut32 version winspool)
++OS_LIBS += $(call EXPAND_LIBNAME,usp10 msimg32)
+ RCINCLUDE = splash.rc
+ ifndef GNU_CC
+ RCFLAGS += -DMOZ_THUNDERBIRD -I$(srcdir)
+@@ -147,11 +160,25 @@
+ ifeq ($(OS_ARCH),OS2)
+ RESFILE=splashos2.res
+ RCFLAGS += -DMOZ_THUNDERBIRD
++ifdef DEBUG
++RCFLAGS += -DDEBUG
++endif
+ RCFLAGS += -DTHUNDERBIRD_ICO=\"$(DIST)/branding/thunderbird.ico\"
+ endif
+
+ include $(topsrcdir)/config/rules.mk
+
++ifdef MOZILLA_OFFICIAL
++DEFINES += -DMOZILLA_OFFICIAL
++endif
++
++APP_UA_NAME = $(shell echo $(MOZ_APP_DISPLAYNAME) | sed -e's/[^A-Za-z]//g')
++DEFINES += -DAPP_VERSION="$(MOZ_APP_VERSION)" -DAPP_UA_NAME="$(APP_UA_NAME)"
++
++ifeq (cocoa,$(MOZ_WIDGET_TOOLKIT))
++LIBS += -framework CoreAudio -framework AudioToolbox -framework AudioUnit -framework Carbon
++endif
++
+ ifeq ($(OS_ARCH),WINNT)
+ #
+ # Control the default heap size.
+@@ -165,22 +192,9 @@
+ #
+ ifndef GNU_CC
+ LDFLAGS += /HEAP:0x40000
+-ifeq ($(OS_TEST),x86_64)
+-# set stack to 2MB on x64 build. See bug 582910
+-LDFLAGS += -STACK:2097152
+-endif
+ endif
+ endif
+
+-ifneq (,$(filter-out OS2 WINNT,$(OS_ARCH)))
+-libs::
+- cp -p $(MOZ_APP_NAME)$(BIN_SUFFIX) $(DIST)/bin/$(MOZ_APP_NAME)-bin$(BIN_SUFFIX)
+-
+-GARBAGE += $(addprefix $(DIST)/bin/defaults/pref/, all.js all-thunderbird.js channel-prefs.js mailnews.js)
+-endif # ! OS 2 or WinNT
+-
+-endif # LIBXUL_SDK
+-
+ ifneq (,$(filter windows os2,$(MOZ_WIDGET_TOOLKIT)))
+ ICON_SUFFIX=.ico
+
+@@ -219,10 +233,36 @@
+ $(SYSINSTALL) $(IFLAGS1) $(DIST)/branding/default* $(DESTDIR)$(mozappdir)/chrome/icons/default
+ endif
+
++ifneq (,$(filter-out OS2 WINNT,$(OS_ARCH)))
++ifneq (,$(filter-out Darwin,$(OS_ARCH)))
++$(MOZ_APP_NAME):: $(MOZILLA_DIR)/build/unix/mozilla.in $(GLOBAL_DEPS) $(DEPTH)/config/autoconf.mk
++ cat $< | sed -e "s|%MOZAPPDIR%|$(installdir)|" \
++ -e "s|%MOZ_APP_DISPLAYNAME%|$(MOZ_APP_DISPLAYNAME)|" > $@
++ chmod +x $@
++
++libs:: $(MOZ_APP_NAME)
++ $(INSTALL) $< $(DIST)/bin
++
++install:: $(MOZ_APP_NAME)
++ $(SYSINSTALL) $< $(DESTDIR)$(bindir)
++
++GARBAGE += $(MOZ_APP_NAME)
++else
++libs::
++ cp -p $(MOZ_APP_NAME)$(BIN_SUFFIX) $(DIST)/bin/$(MOZ_APP_NAME)-bin$(BIN_SUFFIX)
++
++endif # ! Mac
++GARBAGE += $(addprefix $(DIST)/bin/defaults/pref/, all.js all-thunderbird.js channel-prefs.js mailnews.js)
++endif # ! OS 2 or WinNT
++
++ifeq ($(MOZ_WIDGET_TOOLKIT),photon)
++LIBS += -lphexlib
++endif
++
+ libs:: $(srcdir)/profile/prefs.js
+ $(INSTALL) $(IFLAGS1) $^ $(DIST)/bin/defaults/profile
+
+-libs:: $(srcdir)/blocklist.xml
++libs:: blocklist.xml
+ $(INSTALL) $(IFLAGS1) $^ $(DIST)/bin
+
+ ifdef ENABLE_TESTS
+@@ -239,6 +279,8 @@
+
+ ifeq (cocoa,$(MOZ_WIDGET_TOOLKIT))
+
++AB := $(firstword $(subst -, ,$(AB_CD)))
++
+ MAC_APP_NAME = $(MOZ_APP_DISPLAYNAME)
+
+ ifdef MOZ_DEBUG
+@@ -247,55 +289,26 @@
+
+ LOWER_MAC_APP_NAME = $(shell echo $(MAC_APP_NAME) | tr '[A-Z]' '[a-z]')
+
+-AB_CD = $(MOZ_UI_LOCALE)
+-
+-AB := $(firstword $(subst -, ,$(AB_CD)))
+-
+-clean clobber repackage::
+- $(RM) -r $(DIST)/$(MOZ_MACBUNDLE_NAME)
+-
+-ifdef LIBXUL_SDK
+-APPFILES = Resources
+-else
+-APPFILES = MacOS
+-endif
+-
+-libs repackage:: $(PROGRAM)
+- $(MKDIR) -p $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/MacOS
+- rsync -a --exclude "*.in" $(srcdir)/macbuild/Contents $(DIST)/$(MOZ_MACBUNDLE_NAME) --exclude English.lproj
+- $(MKDIR) -p $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/Resources/$(AB).lproj
+- rsync -a --exclude "*.in" $(srcdir)/macbuild/Contents/Resources/English.lproj/ $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/Resources/$(AB).lproj
++libs:: $(PROGRAM)
++ mkdir -p $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/MacOS
++ rsync -a --exclude CVS --exclude "*.in" $(srcdir)/macbuild/Contents $(DIST)/$(MOZ_MACBUNDLE_NAME) --exclude English.lproj
++ mkdir -p $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/Resources/$(AB).lproj
++ rsync -a --exclude CVS --exclude "*.in" $(srcdir)/macbuild/Contents/Resources/English.lproj/ $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/Resources/$(AB).lproj
+ sed -e "s/%APP_VERSION%/$(MOZ_APP_VERSION)/" -e "s/%MAC_APP_NAME%/$(MAC_APP_NAME)/" -e "s/%LOWER_MAC_APP_NAME%/$(LOWER_MAC_APP_NAME)/" $(srcdir)/macbuild/Contents/Info.plist.in > $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/Info.plist
+ sed -e "s/%MAC_APP_NAME%/$(MAC_APP_NAME)/" $(srcdir)/macbuild/Contents/Resources/English.lproj/InfoPlist.strings.in | iconv -f UTF-8 -t UTF-16 > $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/Resources/$(AB).lproj/InfoPlist.strings
+- rsync -a $(DIST)/bin/ $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/$(APPFILES)
+-ifdef LIBXUL_SDK
+- cp $(LIBXUL_DIST)/bin/$(XR_STUB_NAME) $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/MacOS/thunderbird
+-else
+- $(RM) $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/MacOS/$(PROGRAM)
++ rsync -a $(DIST)/bin/ $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/MacOS
++ rm -f $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/MacOS/$(PROGRAM)
+ rsync -aL $(PROGRAM) $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/MacOS
+-endif
+- $(MKDIR) -p $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/Library/Spotlight
++ mkdir -p $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/Library/Spotlight
+ rsync -a --copy-unsafe-links $(DIST)/package/Thunderbird.mdimporter $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/Library/Spotlight
+ cp -RL $(DIST)/branding/thunderbird.icns $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/Resources/thunderbird.icns
+ printf APPLMOZM > $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/PkgInfo
+-else
+-ifdef LIBXUL_SDK
+-libs::
+- cp $(LIBXUL_DIST)/bin/$(XULRUNNER_STUB_NAME)$(BIN_SUFFIX) $(DIST)/bin/thunderbird$(BIN_SUFFIX)
+-endif
+-endif
++# remove CVS dirs from packaged app
++ find $(DIST)/$(MOZ_MACBUNDLE_NAME) -type d -name "CVS" -prune -exec rm -rf {} \;
+
+-ifdef LIBXUL_SDK
+-ifndef SKIP_COPY_XULRUNNER
+-libs::
+-ifeq (cocoa,$(MOZ_WIDGET_TOOLKIT))
+- rsync -a --copy-unsafe-links $(LIBXUL_DIST)/XUL.framework $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/Frameworks
+-else
+- $(NSINSTALL) -D $(DIST)/bin/xulrunner
+- (cd $(LIBXUL_SDK)/bin && tar $(TAR_CREATE_FLAGS) - .) | (cd $(DIST)/bin/xulrunner && tar -xf -)
+-endif # cocoa
+-endif # SKIP_COPY_XULRUNNER
+-endif # LIBXUL_SDK
++clean clobber::
++ rm -rf $(DIST)/$(MOZ_MACBUNDLE_NAME)
++endif
+
+ # Note that anything you do to dist/ down here isn't going to make it into the
+ # Mac build, since it's already been copied over to the .app, above.
diff --git a/mail/thunderbird/files/patch-mozilla-configure.in b/mail/thunderbird/files/patch-mozilla-configure.in
index 4ccc7bfe5017..7e61ff7867c7 100644
--- a/mail/thunderbird/files/patch-mozilla-configure.in
+++ b/mail/thunderbird/files/patch-mozilla-configure.in
@@ -1,6 +1,6 @@
---- mozilla/configure.in.orig 2010-11-04 21:05:18.000000000 +0100
-+++ mozilla/configure.in 2010-11-09 12:59:28.000000000 +0100
-@@ -1549,7 +1549,7 @@
+--- mozilla/configure.in.orig 2012-05-23 20:56:34.000000000 +0200
++++ mozilla/configure.in 2012-05-27 18:18:25.000000000 +0200
+@@ -1517,7 +1517,7 @@
CPU_ARCH=sparc
;;
@@ -9,7 +9,7 @@
CPU_ARCH="$OS_TEST"
;;
-@@ -1567,7 +1567,7 @@ dnl Set INTEL_ARCHITECTURE if we're comp
+@@ -1539,7 +1539,7 @@
dnl ===============================================================
INTEL_ARCHITECTURE=
case "$OS_TEST" in
@@ -18,34 +18,7 @@
INTEL_ARCHITECTURE=1
esac
-@@ -3803,19 +3803,21 @@
- AC_CHECK_FUNCS(localtime_r strtok_r)
-
- dnl check for clock_gettime(), the CLOCK_MONOTONIC clock, and -lrt
--_SAVE_LDFLAGS=$LDFLAGS
--LDFLAGS="$LDFLAGS -lrt"
--AC_CACHE_CHECK(for clock_gettime(CLOCK_MONOTONIC) and -lrt,
-+_SAVE_LIBS=$LIBS
-+AC_SEARCH_LIBS(clock_gettime, rt)
-+AC_CACHE_CHECK(for clock_gettime(CLOCK_MONOTONIC),
- ac_cv_have_clock_monotonic,
- [AC_TRY_LINK([#include <time.h>],
- [ struct timespec ts;
- clock_gettime(CLOCK_MONOTONIC, &ts); ],
- ac_cv_have_clock_monotonic=yes,
- ac_cv_have_clock_monotonic=no)])
--LDFLAGS=$_SAVE_LDFLAGS
-+LIBS=$_SAVE_LIBS
- if test "$ac_cv_have_clock_monotonic" = "yes"; then
- HAVE_CLOCK_MONOTONIC=1
-- REALTIME_LIBS=-lrt
-+ if test "$ac_cv_search_clock_gettime" != "none required"; then
-+ REALTIME_LIBS=$ac_cv_search_clock_gettime
-+ fi
- AC_DEFINE(HAVE_CLOCK_MONOTONIC)
- AC_SUBST(HAVE_CLOCK_MONOTONIC)
- AC_SUBST(REALTIME_LIBS)
-@@ -4808,7 +4810,7 @@ CFLAGS=$_SAVE_CFLAGS
+@@ -4580,7 +4580,7 @@
LDFLAGS=$_SAVE_LDFLAGS
LIBS=$_SAVE_LIBS
@@ -54,7 +27,7 @@
ZLIB_CFLAGS="-I${ZLIB_DIR}/include"
ZLIB_LIBS="-L${ZLIB_DIR}/lib ${ZLIB_LIBS}"
fi
-@@ -6022,6 +6024,14 @@
+@@ -5903,6 +5903,14 @@
VPX_ASFLAGS="-f elf64 -rnasm -pnasm -DPIC"
VPX_X86_ASM=1
;;
@@ -69,7 +42,7 @@
SunOS:x86)
VPX_ASFLAGS="-f elf32 -rnasm -pnasm"
VPX_X86_ASM=1
-@@ -6392,6 +6402,14 @@ if test -n "$MOZ_LIBJPEG_TURBO"; then
+@@ -6297,6 +6305,14 @@
LIBJPEG_TURBO_ASFLAGS="-f elf64 -rnasm -pnasm -D__x86_64__ -DPIC -DELF"
LIBJPEG_TURBO_X64_ASM=1
;;