aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2014-04-18 17:38:03 +0800
committermakc <makc@FreeBSD.org>2014-04-18 17:38:03 +0800
commita20b5c626763abcbde90c3e27404f1d614da4a3d (patch)
treedd2725f5a2afe0720084ddf7fa48aa83e8124df4
parentca14e1ab5cd404fb21239477302880d1fec554f8 (diff)
downloadfreebsd-ports-gnome-a20b5c626763abcbde90c3e27404f1d614da4a3d.tar.gz
freebsd-ports-gnome-a20b5c626763abcbde90c3e27404f1d614da4a3d.tar.zst
freebsd-ports-gnome-a20b5c626763abcbde90c3e27404f1d614da4a3d.zip
Add new port games/dustrac:
Dust Racing 2D (Dustrac) is a tile-based, cross-platform 2D racing game written in Qt. WWW: http://dustrac.sourceforge.net/
-rw-r--r--games/Makefile1
-rw-r--r--games/dustrac/Makefile46
-rw-r--r--games/dustrac/distinfo2
-rw-r--r--games/dustrac/files/patch-CMakeLists.txt18
-rw-r--r--games/dustrac/files/patch-src__common__route.cpp10
-rw-r--r--games/dustrac/files/patch-src__editor__CMakeLists.txt11
-rw-r--r--games/dustrac/files/patch-src__editor__editorview.cpp11
-rw-r--r--games/dustrac/files/patch-src__game__CMakeLists.txt11
-rw-r--r--games/dustrac/files/patch-src__game__fadeanimation.cpp20
-rw-r--r--games/dustrac/pkg-descr9
-rw-r--r--games/dustrac/pkg-plist142
11 files changed, 281 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index b585c559841b..04fc4b73e3b7 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -215,6 +215,7 @@
SUBDIR += duke3d-data
SUBDIR += dungeon
SUBDIR += dungeoncrawl
+ SUBDIR += dustrac
SUBDIR += eboard
SUBDIR += edge
SUBDIR += editss
diff --git a/games/dustrac/Makefile b/games/dustrac/Makefile
new file mode 100644
index 000000000000..e5648c1c0fc7
--- /dev/null
+++ b/games/dustrac/Makefile
@@ -0,0 +1,46 @@
+# $FreeBSD$
+
+PORTNAME= dustrac
+PORTVERSION= 1.7.2
+CATEGORIES= games
+MASTER_SITES= SF/${PORTNAME}/src
+
+MAINTAINER= makc@FreeBSD.org
+COMMENT= 2D top-view racing game
+
+LIB_DEPENDS= libvorbisfile.so:${PORTSDIR}/audio/libvorbis
+
+USES= compiler:c++11-lib cmake openal pkgconfig zip
+USE_GL= glu
+_USE_QT4= corelib opengl xml linguist_build \
+ moc_build qmake_build rcc_build uic_build
+_USE_QT5= core opengl xml widgets \
+ buildtools_build linguisttools_build qmake_build
+CMAKE_ARGS= -DReleaseBuild=on \
+ -DDATA_PATH=${DATADIR} \
+ -DDOC_PATH=${DOCSDIR}
+LDFLAGS= -L${LOCALBASE}/lib
+
+OPTIONS_DEFINE= DOCS DEBUG
+OPTIONS_SINGLE= TOOLKIT
+OPTIONS_SINGLE_TOOLKIT= QT4 QT5
+OPTIONS_DEFAULT= QT5
+
+TOOLKIT_DESC= Qt toolkit
+DEBUG_CMAKE_ON= -DDebugBuild=on
+QT4_USE= ${_USE_QT4:S/^/QT4=/}
+QT5_USE= ${_USE_QT5:S/^/QT5=/}
+QT5_CMAKE_ON= -DUseQt5=on
+QT5_CMAKE_OFF= -DUseQt5=off
+
+STRIP_FILES= bin/dustrac-game \
+ bin/dustrac-editor
+
+post-patch:
+ ${REINPLACE_CMD} -e '/add_subdirectory(UnitTests)/d' \
+ ${WRKSRC}/src/game/MiniCore/CMakeLists.txt
+
+post-install:
+ ${STRIP_CMD} ${STRIP_FILES:S,^,${STAGEDIR}${PREFIX}/,}
+
+.include <bsd.port.mk>
diff --git a/games/dustrac/distinfo b/games/dustrac/distinfo
new file mode 100644
index 000000000000..9a55256b5830
--- /dev/null
+++ b/games/dustrac/distinfo
@@ -0,0 +1,2 @@
+SHA256 (dustrac-1.7.2.zip) = 2eaa4b98c77936cbbc0c34120b3e1a32a48612886254f8ea85ed042034e4268b
+SIZE (dustrac-1.7.2.zip) = 26450932
diff --git a/games/dustrac/files/patch-CMakeLists.txt b/games/dustrac/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..3bca9025dc11
--- /dev/null
+++ b/games/dustrac/files/patch-CMakeLists.txt
@@ -0,0 +1,18 @@
+--- ./CMakeLists.txt.orig 2014-03-09 12:40:35.000000000 +0000
++++ ./CMakeLists.txt 2014-04-05 13:27:16.455482525 +0000
+@@ -40,13 +40,12 @@
+ cmake_policy(VERSION 2.8.7)
+ endif()
+
+-if(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
++if(UNIX)
+ include("InstallLinux.cmake")
+-elseif(${CMAKE_SYSTEM_NAME} MATCHES "Windows")
++elseif(WIN32)
+ include("InstallWindows.cmake")
+ endif()
+
+-set(CMAKE_VERBOSE_MAKEFILE OFF)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x -W -Wall -O3 -pedantic")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fomit-frame-pointer -finline-functions -ffast-math")
+
diff --git a/games/dustrac/files/patch-src__common__route.cpp b/games/dustrac/files/patch-src__common__route.cpp
new file mode 100644
index 000000000000..5940ce786e94
--- /dev/null
+++ b/games/dustrac/files/patch-src__common__route.cpp
@@ -0,0 +1,10 @@
+--- ./src/common/route.cpp.orig 2014-03-29 12:42:23.000000000 +0000
++++ ./src/common/route.cpp 2014-04-14 11:24:16.431660171 +0000
+@@ -18,6 +18,7 @@
+
+ #include <algorithm>
+ #include <cassert>
++#include <cmath>
+
+ static const int CLOSING_TH = 32;
+
diff --git a/games/dustrac/files/patch-src__editor__CMakeLists.txt b/games/dustrac/files/patch-src__editor__CMakeLists.txt
new file mode 100644
index 000000000000..9b326d81a137
--- /dev/null
+++ b/games/dustrac/files/patch-src__editor__CMakeLists.txt
@@ -0,0 +1,11 @@
+--- ./src/editor/CMakeLists.txt.orig 2014-04-05 14:09:43.520483380 +0000
++++ ./src/editor/CMakeLists.txt 2014-04-05 14:10:03.847483124 +0000
+@@ -75,7 +75,7 @@
+ endif()
+
+ # Copy desktop file
+-if(ReleaseBuild AND ${CMAKE_SYSTEM_NAME} MATCHES "Linux")
++if(ReleaseBuild AND UNIX)
+ set(DesktopFileSourcePath)
+ if(USC)
+ set(DesktopFileSourcePath ${CMAKE_SOURCE_DIR}/src/dustrac-editor.desktop.opt.in)
diff --git a/games/dustrac/files/patch-src__editor__editorview.cpp b/games/dustrac/files/patch-src__editor__editorview.cpp
new file mode 100644
index 000000000000..0f9a5bafd957
--- /dev/null
+++ b/games/dustrac/files/patch-src__editor__editorview.cpp
@@ -0,0 +1,11 @@
+--- ./src/editor/editorview.cpp.orig 2014-03-29 12:42:23.000000000 +0000
++++ ./src/editor/editorview.cpp 2014-04-06 15:45:53.624369553 +0000
+@@ -240,7 +240,7 @@
+
+ if (MainWindow::instance()->randomlyRotateObjects())
+ {
+- object.setRotation(std::rand() % 360);
++ object.setRotation(rand() % 360);
+ }
+
+ scene()->addItem(&object);
diff --git a/games/dustrac/files/patch-src__game__CMakeLists.txt b/games/dustrac/files/patch-src__game__CMakeLists.txt
new file mode 100644
index 000000000000..983e53b5d644
--- /dev/null
+++ b/games/dustrac/files/patch-src__game__CMakeLists.txt
@@ -0,0 +1,11 @@
+--- ./src/game/CMakeLists.txt.orig 2014-04-05 14:09:28.680493168 +0000
++++ ./src/game/CMakeLists.txt 2014-04-05 14:09:35.694483369 +0000
+@@ -129,7 +129,7 @@
+ endif()
+
+ # Copy desktop file
+-if(ReleaseBuild AND ${CMAKE_SYSTEM_NAME} MATCHES "Linux")
++if(ReleaseBuild AND UNIX)
+ set(DesktopFileSourcePath)
+ if(USC)
+ set(DesktopFileSourcePath ${CMAKE_SOURCE_DIR}/src/dustrac-game.desktop.opt.in)
diff --git a/games/dustrac/files/patch-src__game__fadeanimation.cpp b/games/dustrac/files/patch-src__game__fadeanimation.cpp
new file mode 100644
index 000000000000..d7e62e16cde1
--- /dev/null
+++ b/games/dustrac/files/patch-src__game__fadeanimation.cpp
@@ -0,0 +1,20 @@
+--- ./src/game/fadeanimation.cpp.orig 2014-03-09 12:40:35.000000000 +0000
++++ ./src/game/fadeanimation.cpp 2014-04-05 13:27:41.052483713 +0000
+@@ -81,7 +81,7 @@
+ #ifdef Q_OS_ANDROID
+ emit fadeValueChanged(fmin(m_fadeValue, 1.0));
+ #else
+- emit fadeValueChanged(std::fmin(m_fadeValue, 1.0));
++ emit fadeValueChanged(fmin(m_fadeValue, 1.0));
+ #endif
+ }
+ else if (!m_fadeIn && m_fadeValue > 0.0)
+@@ -90,7 +90,7 @@
+ #ifdef Q_OS_ANDROID
+ emit fadeValueChanged(fmax(m_fadeValue, 0.0));
+ #else
+- emit fadeValueChanged(std::fmax(m_fadeValue, 0.0));
++ emit fadeValueChanged(fmax(m_fadeValue, 0.0));
+ #endif
+ }
+ else if (m_postDelayMSec)
diff --git a/games/dustrac/pkg-descr b/games/dustrac/pkg-descr
new file mode 100644
index 000000000000..529945dd950d
--- /dev/null
+++ b/games/dustrac/pkg-descr
@@ -0,0 +1,9 @@
+Dust Racing 2D (Dustrac) is a tile-based, cross-platform 2D racing
+game written in Qt.
+
+Play against challenging computer cars or use the split-screen mode
+to play against your friend. A level editor for easy level creation
+is included. Dust Racing 2D is inspired by Super Cars and Slicks’n
+Slide.
+
+WWW: http://dustrac.sourceforge.net/
diff --git a/games/dustrac/pkg-plist b/games/dustrac/pkg-plist
new file mode 100644
index 000000000000..acf94b3034ff
--- /dev/null
+++ b/games/dustrac/pkg-plist
@@ -0,0 +1,142 @@
+bin/dustrac-editor
+bin/dustrac-game
+share/applications/dustrac-editor.desktop
+share/applications/dustrac-game.desktop
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%DATADIR%%/editorModels.conf
+%%DATADIR%%/fonts.conf
+%%DATADIR%%/fonts/UbuntuMono-B.ttf
+%%DATADIR%%/fonts/UbuntuMono-R.ttf
+%%DATADIR%%/images/about.png
+%%DATADIR%%/images/asphalt.jpg
+%%DATADIR%%/images/brake.png
+%%DATADIR%%/images/bridge.png
+%%DATADIR%%/images/bridgeEditor.png
+%%DATADIR%%/images/bridgeObject.png
+%%DATADIR%%/images/bridgePreview.png
+%%DATADIR%%/images/bushArea.png
+%%DATADIR%%/images/carBlack.png
+%%DATADIR%%/images/carBlue.png
+%%DATADIR%%/images/carBrown.png
+%%DATADIR%%/images/carCyan.png
+%%DATADIR%%/images/carDarkGreen.png
+%%DATADIR%%/images/carDarkRed.png
+%%DATADIR%%/images/carGreen.png
+%%DATADIR%%/images/carGrey.png
+%%DATADIR%%/images/carNormalMap.png
+%%DATADIR%%/images/carOrange.png
+%%DATADIR%%/images/carPink.png
+%%DATADIR%%/images/carRed.png
+%%DATADIR%%/images/carViolet.png
+%%DATADIR%%/images/carYellow.png
+%%DATADIR%%/images/checkeredFlag.png
+%%DATADIR%%/images/clear.png
+%%DATADIR%%/images/corner.png
+%%DATADIR%%/images/corner45Left.png
+%%DATADIR%%/images/corner45LeftPreview.png
+%%DATADIR%%/images/corner45Right.png
+%%DATADIR%%/images/corner45RightPreview.png
+%%DATADIR%%/images/cornerPreview.png
+%%DATADIR%%/images/creditsHelpBack.png
+%%DATADIR%%/images/cross.png
+%%DATADIR%%/images/cursor.png
+%%DATADIR%%/images/cursor2.png
+%%DATADIR%%/images/dustRacing2DBanner.png
+%%DATADIR%%/images/finish.png
+%%DATADIR%%/images/finishPreview.png
+%%DATADIR%%/images/frontTire.png
+%%DATADIR%%/images/grandstand.png
+%%DATADIR%%/images/grandstandEditor.png
+%%DATADIR%%/images/grass.png
+%%DATADIR%%/images/grassEditor.png
+%%DATADIR%%/images/grid.png
+%%DATADIR%%/images/intro.png
+%%DATADIR%%/images/leaf.png
+%%DATADIR%%/images/left.png
+%%DATADIR%%/images/lock.png
+%%DATADIR%%/images/logo.png
+%%DATADIR%%/images/mainMenuBack.png
+%%DATADIR%%/images/monospace.png
+%%DATADIR%%/images/mud.png
+%%DATADIR%%/images/pit.png
+%%DATADIR%%/images/plant.png
+%%DATADIR%%/images/right.png
+%%DATADIR%%/images/rock.png
+%%DATADIR%%/images/sand.png
+%%DATADIR%%/images/sandAreaBig.png
+%%DATADIR%%/images/sandAreaCurve.png
+%%DATADIR%%/images/sandGrassCorner.png
+%%DATADIR%%/images/sandGrassCorner2.png
+%%DATADIR%%/images/sandGrassStraight.png
+%%DATADIR%%/images/settingsBack.png
+%%DATADIR%%/images/skid.png
+%%DATADIR%%/images/sky.png
+%%DATADIR%%/images/smoke.png
+%%DATADIR%%/images/sparkle.png
+%%DATADIR%%/images/star.png
+%%DATADIR%%/images/starGlow.png
+%%DATADIR%%/images/startLightGlow.png
+%%DATADIR%%/images/startLightOff.png
+%%DATADIR%%/images/startLightOffCorner.png
+%%DATADIR%%/images/startLightOn.png
+%%DATADIR%%/images/startLightOnCorner.png
+%%DATADIR%%/images/steel.jpg
+%%DATADIR%%/images/straight.png
+%%DATADIR%%/images/straight45Female.png
+%%DATADIR%%/images/straight45FemalePreview.png
+%%DATADIR%%/images/straight45Male.png
+%%DATADIR%%/images/straight45MalePreview.png
+%%DATADIR%%/images/straightPreview.png
+%%DATADIR%%/images/tire.png
+%%DATADIR%%/images/tireStatusIndicatorBody.png
+%%DATADIR%%/images/tireStatusIndicatorTires.png
+%%DATADIR%%/images/trackSelectionBack.png
+%%DATADIR%%/images/tree.png
+%%DATADIR%%/images/wood.png
+%%DATADIR%%/levels/curvastone.trk
+%%DATADIR%%/levels/infinity.trk
+%%DATADIR%%/levels/monza.trk
+%%DATADIR%%/levels/ring.trk
+%%DATADIR%%/levels/straight.trk
+%%DATADIR%%/levels/triangle.trk
+%%DATADIR%%/levels/twister.trk
+%%DATADIR%%/meshes.conf
+%%DATADIR%%/models/cube.obj
+%%DATADIR%%/sounds/bell.ogg
+%%DATADIR%%/sounds/carEngine.ogg
+%%DATADIR%%/sounds/carHit.ogg
+%%DATADIR%%/sounds/carHit2.ogg
+%%DATADIR%%/sounds/carHit3.ogg
+%%DATADIR%%/sounds/cheering.ogg
+%%DATADIR%%/sounds/menuBoom.ogg
+%%DATADIR%%/sounds/menuClick.ogg
+%%DATADIR%%/sounds/pit.ogg
+%%DATADIR%%/sounds/skid.ogg
+%%DATADIR%%/textures.conf
+%%DATADIR%%/translations/dustrac-editor_cs.qm
+%%DATADIR%%/translations/dustrac-editor_fi.qm
+%%DATADIR%%/translations/dustrac-editor_fr.qm
+%%DATADIR%%/translations/dustrac-editor_it.qm
+%%DATADIR%%/translations/dustrac-game_cs.qm
+%%DATADIR%%/translations/dustrac-game_fi.qm
+%%DATADIR%%/translations/dustrac-game_fr.qm
+%%DATADIR%%/translations/dustrac-game_it.qm
+share/icons/hicolor/64x64/apps/dustrac-editor.png
+share/icons/hicolor/64x64/apps/dustrac-game.png
+share/pixmaps/dustrac-editor.png
+share/pixmaps/dustrac-game.png
+@dirrmtry share/icons/hicolor/64x64/apps
+@dirrmtry share/icons/hicolor/64x64
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+@dirrm %%DATADIR%%/translations
+@dirrm %%DATADIR%%/sounds
+@dirrm %%DATADIR%%/models
+@dirrm %%DATADIR%%/levels
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%/fonts
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%