aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2012-07-03 06:24:21 +0800
committerRenato Botelho <garga@FreeBSD.org>2012-07-03 06:24:21 +0800
commita2e035369724c8e855c81f5d85701252382c41e7 (patch)
tree5f273b0392509d9125b0b8254ef9beb306da8171
parentf3941b6e07e9756ac66aaeb7bd455d79015ade5e (diff)
downloadfreebsd-ports-gnome-a2e035369724c8e855c81f5d85701252382c41e7.tar.gz
freebsd-ports-gnome-a2e035369724c8e855c81f5d85701252382c41e7.tar.zst
freebsd-ports-gnome-a2e035369724c8e855c81f5d85701252382c41e7.zip
Remove lib version from LIB_DEPENDS to silence portlint
-rw-r--r--mail/maildrop/Makefile4
-rw-r--r--mail/wmbiff/Makefile4
-rw-r--r--www/dansguardian-devel/Makefile2
-rw-r--r--www/dansguardian/Makefile2
-rw-r--r--x11/gmrun/Makefile2
-rw-r--r--x11/xcb-util-image/Makefile4
-rw-r--r--x11/xcb-util-keysyms/Makefile4
-rw-r--r--x11/xcb-util-renderutil/Makefile4
-rw-r--r--x11/xcb-util-wm/Makefile4
-rw-r--r--x11/xcb-util/Makefile2
10 files changed, 16 insertions, 16 deletions
diff --git a/mail/maildrop/Makefile b/mail/maildrop/Makefile
index 04a0b10ba750..95a2e893d4fb 100644
--- a/mail/maildrop/Makefile
+++ b/mail/maildrop/Makefile
@@ -42,7 +42,7 @@ CONFIGURE_ARGS= --enable-syslog=1 \
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-LIB_DEPENDS+= pcre.1:${PORTSDIR}/devel/pcre
+LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre
MAILDROP_LOG_COLUMNS?= 72 # lenght of 'File:' line in log
@@ -55,7 +55,7 @@ MAILDROP_LOG_COLUMNS?= 72 # lenght of 'File:' line in log
.include <bsd.port.pre.mk>
.if defined(WITH_GDBM)
-LIB_DEPENDS+= gdbm.4:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS+= gdbm:${PORTSDIR}/databases/gdbm
CONFIGURE_ARGS+= --with-db=gdbm
.else
CONFIGURE_ARGS+= --with-db=db
diff --git a/mail/wmbiff/Makefile b/mail/wmbiff/Makefile
index c84904c9ec59..0aae41c95d26 100644
--- a/mail/wmbiff/Makefile
+++ b/mail/wmbiff/Makefile
@@ -34,8 +34,8 @@ PLIST_DIRS= %%DATADIR%%/skins \
.include <bsd.port.pre.mk>
.if defined(WITH_GNUTLS)
-LIB_DEPENDS+= gcrypt.18:${PORTSDIR}/security/libgcrypt \
- gnutls.47:${PORTSDIR}/security/gnutls
+LIB_DEPENDS+= gcrypt:${PORTSDIR}/security/libgcrypt \
+ gnutls:${PORTSDIR}/security/gnutls
CONFIGURE_ARGS+= --with-libgnutls-prefix=${LOCALBASE} \
--with-libgcrypt-prefix=${LOCALBASE}
.else
diff --git a/www/dansguardian-devel/Makefile b/www/dansguardian-devel/Makefile
index 2b8d70697737..d3f069496613 100644
--- a/www/dansguardian-devel/Makefile
+++ b/www/dansguardian-devel/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= garga@FreeBSD.org
COMMENT= A fast, feature-rich web content filter for Squid proxy servers
RUN_DEPENDS= ${LOCALBASE}/sbin/squid:${PORTSDIR}/www/squid
-LIB_DEPENDS+= pcre.1:${PORTSDIR}/devel/pcre
+LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre
USE_RC_SUBR= dansguardian
USE_GNOME= pkgconfig
diff --git a/www/dansguardian/Makefile b/www/dansguardian/Makefile
index e2caaff1781d..370d5db7b65c 100644
--- a/www/dansguardian/Makefile
+++ b/www/dansguardian/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= garga@FreeBSD.org
COMMENT= A fast, feature-rich web content filter for Squid proxy servers
RUN_DEPENDS= ${LOCALBASE}/sbin/squid:${PORTSDIR}/www/squid
-LIB_DEPENDS+= pcre.1:${PORTSDIR}/devel/pcre
+LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre
USE_RC_SUBR= dansguardian
USE_GNOME= pkgconfig
diff --git a/x11/gmrun/Makefile b/x11/gmrun/Makefile
index db13d305d78d..554b8626208a 100644
--- a/x11/gmrun/Makefile
+++ b/x11/gmrun/Makefile
@@ -14,7 +14,7 @@ MASTER_SITES= SF
MAINTAINER= garga@FreeBSD.org
COMMENT= A customizable program to run programs, with tab-completion
-LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
+LIB_DEPENDS= popt:${PORTSDIR}/devel/popt
USE_GNOME= gtk20
USE_GMAKE= yes
diff --git a/x11/xcb-util-image/Makefile b/x11/xcb-util-image/Makefile
index 3ee602b7179a..48fb2bb38ede 100644
--- a/x11/xcb-util-image/Makefile
+++ b/x11/xcb-util-image/Makefile
@@ -13,8 +13,8 @@ MASTER_SITES= http://xcb.freedesktop.org/dist/
MAINTAINER= garga@FreeBSD.org
COMMENT= A port of Xlib's XImage and XShmImage functions
-LIB_DEPENDS= xcb.2:${PORTSDIR}/x11/libxcb \
- xcb-util.0:${PORTSDIR}/x11/xcb-util
+LIB_DEPENDS= xcb:${PORTSDIR}/x11/libxcb \
+ xcb-util:${PORTSDIR}/x11/xcb-util
#BUILD_DEPENDS= ${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf
USE_BZIP2= yes
diff --git a/x11/xcb-util-keysyms/Makefile b/x11/xcb-util-keysyms/Makefile
index 570871dbc322..bb045e9010bd 100644
--- a/x11/xcb-util-keysyms/Makefile
+++ b/x11/xcb-util-keysyms/Makefile
@@ -13,8 +13,8 @@ MASTER_SITES= http://xcb.freedesktop.org/dist/
MAINTAINER= garga@FreeBSD.org
COMMENT= Standard X key constants and conversion to/from keycodes
-LIB_DEPENDS= xcb.2:${PORTSDIR}/x11/libxcb \
- xcb-util.0:${PORTSDIR}/x11/xcb-util
+LIB_DEPENDS= xcb:${PORTSDIR}/x11/libxcb \
+ xcb-util:${PORTSDIR}/x11/xcb-util
#BUILD_DEPENDS= ${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf
USE_BZIP2= yes
diff --git a/x11/xcb-util-renderutil/Makefile b/x11/xcb-util-renderutil/Makefile
index 8acdd8e97696..14980e31fdd2 100644
--- a/x11/xcb-util-renderutil/Makefile
+++ b/x11/xcb-util-renderutil/Makefile
@@ -13,8 +13,8 @@ MASTER_SITES= http://xcb.freedesktop.org/dist/
MAINTAINER= garga@FreeBSD.org
COMMENT= Convenience functions for the Render extension
-LIB_DEPENDS= xcb.2:${PORTSDIR}/x11/libxcb \
- xcb-util.0:${PORTSDIR}/x11/xcb-util
+LIB_DEPENDS= xcb:${PORTSDIR}/x11/libxcb \
+ xcb-util:${PORTSDIR}/x11/xcb-util
#BUILD_DEPENDS= ${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf
USE_BZIP2= yes
diff --git a/x11/xcb-util-wm/Makefile b/x11/xcb-util-wm/Makefile
index ba13757e8785..786688dabe27 100644
--- a/x11/xcb-util-wm/Makefile
+++ b/x11/xcb-util-wm/Makefile
@@ -13,8 +13,8 @@ MASTER_SITES= http://xcb.freedesktop.org/dist/
MAINTAINER= garga@FreeBSD.org
COMMENT= Framework for window manager implementation
-LIB_DEPENDS= xcb.2:${PORTSDIR}/x11/libxcb \
- xcb-util.0:${PORTSDIR}/x11/xcb-util
+LIB_DEPENDS= xcb:${PORTSDIR}/x11/libxcb \
+ xcb-util:${PORTSDIR}/x11/xcb-util
#BUILD_DEPENDS= ${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf
USE_BZIP2= yes
diff --git a/x11/xcb-util/Makefile b/x11/xcb-util/Makefile
index 1f2f60e5cbc6..13bafafcfe11 100644
--- a/x11/xcb-util/Makefile
+++ b/x11/xcb-util/Makefile
@@ -14,7 +14,7 @@ MASTER_SITES= http://xcb.freedesktop.org/dist/
MAINTAINER= garga@FreeBSD.org
COMMENT= A module with libxcb/libX11 extension/replacement libraries
-LIB_DEPENDS= xcb.2:${PORTSDIR}/x11/libxcb
+LIB_DEPENDS= xcb:${PORTSDIR}/x11/libxcb
BUILD_DEPENDS= ${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf
USE_BZIP2= yes