aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlippe <lippe@FreeBSD.org>2008-09-02 09:19:17 +0800
committerlippe <lippe@FreeBSD.org>2008-09-02 09:19:17 +0800
commita2fcb3e001c311c57b49a32fa9070d395e08f851 (patch)
tree5e617f47cc6f76004e7bf8d739345c1672dced41
parent2d803da43da47289d468484f1ba075b76eef5eae (diff)
downloadfreebsd-ports-gnome-a2fcb3e001c311c57b49a32fa9070d395e08f851.tar.gz
freebsd-ports-gnome-a2fcb3e001c311c57b49a32fa9070d395e08f851.tar.zst
freebsd-ports-gnome-a2fcb3e001c311c57b49a32fa9070d395e08f851.zip
SQL Buddy - Web based MySQL administration
PR: ports/126646 Submitted by: ChenGuang LI <horus.li@gmail.com>
-rw-r--r--databases/Makefile1
-rw-r--r--databases/sqlbuddy/Makefile44
-rw-r--r--databases/sqlbuddy/distinfo3
-rw-r--r--databases/sqlbuddy/files/pkg-message.in13
-rw-r--r--databases/sqlbuddy/pkg-descr23
-rw-r--r--databases/sqlbuddy/pkg-plist103
6 files changed, 187 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index cd50844d18d3..c080a69631f8 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -568,6 +568,7 @@
SUBDIR += skytools
SUBDIR += slony1
SUBDIR += spatialite
+ SUBDIR += sqlbuddy
SUBDIR += sqlcached
SUBDIR += sqlclient
SUBDIR += sqldeveloper
diff --git a/databases/sqlbuddy/Makefile b/databases/sqlbuddy/Makefile
new file mode 100644
index 000000000000..dda1297fd9cd
--- /dev/null
+++ b/databases/sqlbuddy/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: SQL Buddy
+# Date created: 17 August 2008
+# Whom: Chenguang LI
+#
+# $FreeBSD$
+#
+
+PORTNAME= sqlbuddy
+PORTVERSION= 1.2.9
+CATEGORIES= databases www
+MASTER_SITES= http://www.sqlbuddy.com/download/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= horus.li@gmail.com
+COMMENT= Web based MySQL administration with a set of PHP scripts
+
+USE_ZIP= yes
+NO_BUILD= yes
+
+USE_PHP= ctype mysql pcre session
+WANT_PHP_WEB= yes
+
+SUB_FILES= pkg-message
+
+.include <bsd.port.pre.mk>
+
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "NOTE:"
+ @${ECHO_MSG} "This port suppose you have already installed MySQL, "
+ @${ECHO_MSG} "and you want to use SQL Buddy to manage the server."
+ @${ECHO_MSG} "If you are planning to install MySQL on this machine later, "
+ @${ECHO_MSG} "you can find it at ${PORTSDIR}/databases."
+ @${ECHO_MSG} ""
+
+do-install:
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "Installing SQL Buddy under ${WWWDIR}/"
+ @${MKDIR} ${WWWDIR}
+ @cd ${WRKSRC} && ${CP} -R * ${WWWDIR}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/databases/sqlbuddy/distinfo b/databases/sqlbuddy/distinfo
new file mode 100644
index 000000000000..27ab7682b6d1
--- /dev/null
+++ b/databases/sqlbuddy/distinfo
@@ -0,0 +1,3 @@
+MD5 (sqlbuddy.zip) = 17f42033a1855ed710ef23ed045d45e1
+SHA256 (sqlbuddy.zip) = c94f59092a7fbc78a5a1ba838b0fadc02c0220f71ed823fd0a5fc80dae65023d
+SIZE (sqlbuddy.zip) = 171454
diff --git a/databases/sqlbuddy/files/pkg-message.in b/databases/sqlbuddy/files/pkg-message.in
new file mode 100644
index 000000000000..ab9896c595b4
--- /dev/null
+++ b/databases/sqlbuddy/files/pkg-message.in
@@ -0,0 +1,13 @@
+Congratulations!
+Now you have SQL Buddy installed.
+The configuration file is placed at:
+
+%%WWWDIR%%/config.php
+
+Edit it to suit your needs. Add the following
+line to your httpd.conf for apache:
+
+ Alias /${PORTNAME} "%%WWWDIR%%"
+
+Open the login page and start using SQL Buddy.
+
diff --git a/databases/sqlbuddy/pkg-descr b/databases/sqlbuddy/pkg-descr
new file mode 100644
index 000000000000..5535a64f461e
--- /dev/null
+++ b/databases/sqlbuddy/pkg-descr
@@ -0,0 +1,23 @@
+Let's be honest - managing a database isn't terribly exciting.
+But you still want to use a product that looks half-decent and is
+intuitive to use. SQL Buddy was designed to meet the demands of
+modern web developers. Oh, and did I mention that its completely
+open source and free for everyone to use?
+
+Some applications look great in a screenshot, but deliver disappointing
+results when they are actually used. The driving force behind the
+development of SQL Buddy was not to produce a great-looking screenshot
+but rather to create a product that would enable developers to enjoy their
+work and get more done in less time.
+
+Features:
+
+* No setup
+* Complete control of users
+* Easy to browse
+* Reduced load times
+* Bookmark to your hearts content
+* Import and export
+* Multilanguage
+
+WWW: http://www.sqlbuddy.com/
diff --git a/databases/sqlbuddy/pkg-plist b/databases/sqlbuddy/pkg-plist
new file mode 100644
index 000000000000..6170319a319c
--- /dev/null
+++ b/databases/sqlbuddy/pkg-plist
@@ -0,0 +1,103 @@
+%%WWWDIR%%/LICENSE
+%%WWWDIR%%/README
+%%WWWDIR%%/ajaxcreatetable.php
+%%WWWDIR%%/ajaxfulltext.php
+%%WWWDIR%%/ajaximportfile.php
+%%WWWDIR%%/ajaxquery.php
+%%WWWDIR%%/ajaxsavecolumnedit.php
+%%WWWDIR%%/ajaxsaveedit.php
+%%WWWDIR%%/ajaxsaveuseredit.php
+%%WWWDIR%%/browse.php
+%%WWWDIR%%/config.php
+%%WWWDIR%%/css/common.css
+%%WWWDIR%%/css/navigation.css
+%%WWWDIR%%/dboverview.php
+%%WWWDIR%%/edit.php
+%%WWWDIR%%/editcolumn.php
+%%WWWDIR%%/edituser.php
+%%WWWDIR%%/export.php
+%%WWWDIR%%/functions.php
+%%WWWDIR%%/home.php
+%%WWWDIR%%/images/button.png
+%%WWWDIR%%/images/close.png
+%%WWWDIR%%/images/closeHover.png
+%%WWWDIR%%/images/closedArrow.png
+%%WWWDIR%%/images/goto.png
+%%WWWDIR%%/images/info.png
+%%WWWDIR%%/images/infoHover.png
+%%WWWDIR%%/images/initLoad.png
+%%WWWDIR%%/images/loading.gif
+%%WWWDIR%%/images/logo.png
+%%WWWDIR%%/images/openArrow.png
+%%WWWDIR%%/images/schemaHeader.png
+%%WWWDIR%%/images/sortasc.gif
+%%WWWDIR%%/images/sortdesc.gif
+%%WWWDIR%%/images/transparent.png
+%%WWWDIR%%/images/window-button.png
+%%WWWDIR%%/images/window-center.png
+%%WWWDIR%%/images/window-close.png
+%%WWWDIR%%/images/window-header-center.png
+%%WWWDIR%%/images/window-header-left.png
+%%WWWDIR%%/images/window-header-right.png
+%%WWWDIR%%/images/window-resize.png
+%%WWWDIR%%/images/window-shadow-bottom-left.png
+%%WWWDIR%%/images/window-shadow-bottom-right.png
+%%WWWDIR%%/images/window-shadow-bottom.png
+%%WWWDIR%%/images/window-shadow-left.png
+%%WWWDIR%%/images/window-shadow-right.png
+%%WWWDIR%%/import.php
+%%WWWDIR%%/includes/browse.php
+%%WWWDIR%%/includes/gettextreader.php
+%%WWWDIR%%/includes/types.php
+%%WWWDIR%%/index.php
+%%WWWDIR%%/insert.php
+%%WWWDIR%%/js/animation.js
+%%WWWDIR%%/js/columnsize.js
+%%WWWDIR%%/js/core.js
+%%WWWDIR%%/js/drag.js
+%%WWWDIR%%/js/helpers.js
+%%WWWDIR%%/js/mootools-1.2-core.js
+%%WWWDIR%%/js/resize.js
+%%WWWDIR%%/locale/de_DE.pot
+%%WWWDIR%%/locale/en_US.pot
+%%WWWDIR%%/locale/es_ES.pot
+%%WWWDIR%%/locale/it_IT.pot
+%%WWWDIR%%/locale/nl_NL.pot
+%%WWWDIR%%/locale/pl_PL.pot
+%%WWWDIR%%/locale/pt_BR.pot
+%%WWWDIR%%/locale/ru_RU.pot
+%%WWWDIR%%/locale/sv_SE.pot
+%%WWWDIR%%/locale/tl_PH.pot
+%%WWWDIR%%/locale/zh_CN.pot
+%%WWWDIR%%/locale/zh_TW.pot
+%%WWWDIR%%/login.php
+%%WWWDIR%%/logout.php
+%%WWWDIR%%/query.php
+%%WWWDIR%%/structure.php
+%%WWWDIR%%/themes/bittersweet/css/ie.css
+%%WWWDIR%%/themes/bittersweet/css/main.css
+%%WWWDIR%%/themes/bittersweet/images/header.png
+%%WWWDIR%%/themes/bittersweet/images/initLoad-dark.png
+%%WWWDIR%%/themes/classic/css/ie.css
+%%WWWDIR%%/themes/classic/css/main.css
+%%WWWDIR%%/themes/classic/images/corner-bl.png
+%%WWWDIR%%/themes/classic/images/corner-br.png
+%%WWWDIR%%/themes/classic/images/corner-tl.png
+%%WWWDIR%%/themes/classic/images/corner-tr.png
+%%WWWDIR%%/themes/classic/images/header.png
+%%WWWDIR%%/themes/classic/images/shading.png
+%%WWWDIR%%/users.php
+@dirrm %%WWWDIR%%/themes/classic/images
+@dirrm %%WWWDIR%%/themes/classic/css
+@dirrm %%WWWDIR%%/themes/classic
+@dirrm %%WWWDIR%%/themes/bittersweet/images
+@dirrm %%WWWDIR%%/themes/bittersweet/css
+@dirrm %%WWWDIR%%/themes/bittersweet
+@dirrm %%WWWDIR%%/themes
+@dirrm %%WWWDIR%%/locale
+@dirrm %%WWWDIR%%/js
+@dirrm %%WWWDIR%%/includes
+@dirrm %%WWWDIR%%/images
+@dirrm %%WWWDIR%%/exports
+@dirrm %%WWWDIR%%/css
+@dirrmtry %%WWWDIR%%