aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2011-07-11 01:19:35 +0800
committerbapt <bapt@FreeBSD.org>2011-07-11 01:19:35 +0800
commita3428a3abec3ab01fc20f3afc76fdfe4de89555c (patch)
tree6b63c00c1f8c137af4a79b85d85f402bf3a12134
parent28da67eaabd66e6265299c7bb2bd55f81e44af48 (diff)
downloadfreebsd-ports-gnome-a3428a3abec3ab01fc20f3afc76fdfe4de89555c.tar.gz
freebsd-ports-gnome-a3428a3abec3ab01fc20f3afc76fdfe4de89555c.tar.zst
freebsd-ports-gnome-a3428a3abec3ab01fc20f3afc76fdfe4de89555c.zip
Add missing depenendcy
Make portlint happy PR: ports/158767 Submitted by: milki <milki@rescomp.berkeley.edu>
-rw-r--r--devel/p5-Mixin-Linewise/Makefile17
1 files changed, 13 insertions, 4 deletions
diff --git a/devel/p5-Mixin-Linewise/Makefile b/devel/p5-Mixin-Linewise/Makefile
index 4f9195cc19d1..5554d851840c 100644
--- a/devel/p5-Mixin-Linewise/Makefile
+++ b/devel/p5-Mixin-Linewise/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Mixin-Linewise
PORTVERSION= 0.003
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:RJBS
@@ -15,11 +16,19 @@ PKGNAMEPREFIX= p5-
MAINTAINER= bapt@FreeBSD.org
COMMENT= Write your linewise code for handles; this does the rest
-LICENSE_COMB= dual
LICENSE= ART20 GPLv1
+LICENSE_COMB= dual
+
+.include <bsd.port.pre.mk>
+
+BUILD_DEPENDS+= p5-Sub-Exporter>=0.900:${PORTSDIR}/devel/p5-Sub-Exporter \
+ p5-IO-String>=0:${PORTSDIR}/devel/p5-IO-String
+RUN_DEPENDS+= p5-Sub-Exporter>=0.900:${PORTSDIR}/devel/p5-Sub-Exporter \
+ p5-IO-String>=0:${PORTSDIR}/devel/p5-IO-String
-BUILD_DEPENDS+= p5-Sub-Exporter>=0.900:${PORTSDIR}/devel/p5-Sub-Exporter
-RUN_DEPENDS+= p5-Sub-Exporter>=0.900:${PORTSDIR}/devel/p5-Sub-Exporter
+.if ${PERL_LEVEL} < 501001
+TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
+.endif
PERL_CONFIGURE= yes
@@ -35,4 +44,4 @@ PLIST_DIRS+= %%SITE_PERL%%/Mixin/Linewise \
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Mixin/Linewise \
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Mixin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>