aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-01-28 08:02:29 +0800
committerbapt <bapt@FreeBSD.org>2014-01-28 08:02:29 +0800
commita39fa1def73748ce17a2af0f49e44ee8ea70fec2 (patch)
treeeedbf256521d013554f129815bb5a19ff525df82
parenteed00b6f9e77fa2d286b21ca8ad2b9589fc178cf (diff)
downloadfreebsd-ports-gnome-a39fa1def73748ce17a2af0f49e44ee8ea70fec2.tar.gz
freebsd-ports-gnome-a39fa1def73748ce17a2af0f49e44ee8ea70fec2.tar.zst
freebsd-ports-gnome-a39fa1def73748ce17a2af0f49e44ee8ea70fec2.zip
Support stage
Use shebangfix Remove support for the nonexisting cvsnt Add dependency on cvs
-rw-r--r--devel/cvs-syncmail/Makefile24
1 files changed, 5 insertions, 19 deletions
diff --git a/devel/cvs-syncmail/Makefile b/devel/cvs-syncmail/Makefile
index 162562a35130..bf09a6e6e278 100644
--- a/devel/cvs-syncmail/Makefile
+++ b/devel/cvs-syncmail/Makefile
@@ -11,35 +11,21 @@ EXTRACT_SUFX=
MAINTAINER= ports@FreeBSD.org
COMMENT= CVS notification tool
-.if defined(WITH_CVSNT)
-# Use the CVSNT binary when generating diffs instead of the system CVS
-RUN_DEPENDS= ${LOCALBASE}/bin/cvsnt:${PORTSDIR}/devel/cvsnt
-.endif
+RUN_DEPENDS= cvs:${PORTSDIR}/devel/cvs
+USES= shebangfix
+SHEBANG_FILES= ${DISTNAME}
NO_BUILD= yes
NO_WRKSUBDIR= yes
USE_PYTHON= yes
PLIST_FILES= bin/${DISTNAME}
-NO_STAGE= yes
do-extract:
@${MKDIR} ${WRKSRC}
- @${CP} ${DISTDIR}/${DISTNAME} ${WRKSRC}
-
-do-patch:
- @${REINPLACE_CMD} -e "s| /usr/bin/python|${PYTHON_CMD}|" \
- ${WRKSRC}/${DISTNAME}
-
- @${REINPLACE_CMD} -e "s|cvs -fn update|/usr/bin/cvs -fn update|" \
- ${WRKSRC}/${DISTNAME}
-
-.if defined(WITH_CVSNT)
- @${REINPLACE_CMD} -e "s|/usr/bin/cvs|${LOCALBASE}/bin/cvsnt|" \
- ${WRKSRC}/${DISTNAME}
-.endif
+ ${CP} ${DISTDIR}/${DISTNAME} ${WRKSRC}
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME} ${PREFIX}/bin/${DISTNAME}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME} ${STAGEDIR}${PREFIX}/bin/${DISTNAME}
.include <bsd.port.mk>