aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2019-08-13 03:15:04 +0800
committerjbeich <jbeich@FreeBSD.org>2019-08-13 03:15:04 +0800
commita5850abf53650c7c8f6bfe5421746049dbeaed0f (patch)
treef4637c20c2af855eb06c31c62a854525012c42de
parent50263073cb5251b72e5a1a31a73e53780f1349c2 (diff)
downloadfreebsd-ports-gnome-a5850abf53650c7c8f6bfe5421746049dbeaed0f.tar.gz
freebsd-ports-gnome-a5850abf53650c7c8f6bfe5421746049dbeaed0f.tar.zst
freebsd-ports-gnome-a5850abf53650c7c8f6bfe5421746049dbeaed0f.zip
x11/virtboard: add new port
Virtboard is an on screen keyboard based on wayland-keyboard, and serving as a test bed for new input method protocols. https://source.puri.sm/Librem5/virtboard
-rw-r--r--x11/Makefile1
-rw-r--r--x11/virtboard/Makefile37
-rw-r--r--x11/virtboard/distinfo7
-rw-r--r--x11/virtboard/pkg-descr4
4 files changed, 49 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index eef9ef367b4b..cbe49044d0db 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -330,6 +330,7 @@
SUBDIR += urxvt-perls
SUBDIR += vdesk
SUBDIR += viewres
+ SUBDIR += virtboard
SUBDIR += virtualgl
SUBDIR += waybar
SUBDIR += wbar
diff --git a/x11/virtboard/Makefile b/x11/virtboard/Makefile
new file mode 100644
index 000000000000..c17ea1e64901
--- /dev/null
+++ b/x11/virtboard/Makefile
@@ -0,0 +1,37 @@
+# $FreeBSD$
+
+PORTNAME= virtboard
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.0.5-26
+CATEGORIES= x11
+
+PATCH_SITES= ${GL_SITE}/jbeich/${GL_PROJECT}/commit/
+PATCHFILES+= 42e698964e42.patch:-p1
+PATCHFILES+= 86e6915d4920.patch:-p1
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Basic keyboard, blazing the path of modern Wayland keyboards
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= evdev-proto>0:devel/evdev-proto \
+ wayland-protocols>=1.14:graphics/wayland-protocols
+LIB_DEPENDS= libepoll-shim.so:devel/libepoll-shim \
+ libpng.so:graphics/png \
+ libwayland-client.so:graphics/wayland \
+ libxkbcommon.so:x11/libxkbcommon
+RUN_DEPENDS= gsettings-desktop-schemas>0:devel/gsettings-desktop-schemas
+
+USES= compiler:c11 gettext-tools gnome meson pkgconfig
+USE_GITLAB= yes
+USE_GNOME= cairo glib20
+USE_XORG= pixman
+GL_SITE= https://source.puri.sm
+GL_ACCOUNT= Librem5
+GL_COMMIT= 576fffc61bcfa8e24f9dcf10d8bf3b32240cc36d
+PLIST_FILES= bin/${PORTNAME} \
+ share/applications/sm.puri.Virtboard.desktop \
+ share/dbus-1/interfaces/sm.puri.OSK0.xml
+
+.include <bsd.port.mk>
diff --git a/x11/virtboard/distinfo b/x11/virtboard/distinfo
new file mode 100644
index 000000000000..80aabaec84d3
--- /dev/null
+++ b/x11/virtboard/distinfo
@@ -0,0 +1,7 @@
+TIMESTAMP = 1543864393
+SHA256 (Librem5-virtboard-576fffc61bcfa8e24f9dcf10d8bf3b32240cc36d_GL0.tar.gz) = 34d15918ea9e788f4b311dc34a9c5aecafad7ef466b2158ca9fa603bb936da9c
+SIZE (Librem5-virtboard-576fffc61bcfa8e24f9dcf10d8bf3b32240cc36d_GL0.tar.gz) = 128500
+SHA256 (42e698964e42.patch) = 20eda9ca7c6359bff8b8202e29f958735839fa9258da944b7d2a7459dd5c4ab7
+SIZE (42e698964e42.patch) = 832
+SHA256 (86e6915d4920.patch) = f97bf3f30f84d973056ba1f6d59bc6519310637cbbc65d3677fca0da881c5b39
+SIZE (86e6915d4920.patch) = 1696
diff --git a/x11/virtboard/pkg-descr b/x11/virtboard/pkg-descr
new file mode 100644
index 000000000000..89499085cdf5
--- /dev/null
+++ b/x11/virtboard/pkg-descr
@@ -0,0 +1,4 @@
+Virtboard is an on screen keyboard based on wayland-keyboard, and
+serving as a test bed for new input method protocols.
+
+WWW: https://source.puri.sm/Librem5/virtboard