aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-07-07 01:45:15 +0800
committerkwm <kwm@FreeBSD.org>2013-07-07 01:45:15 +0800
commita5cdfcf1f380218fc9f736a5ae1eb9565415b875 (patch)
treec6d7aeb1c9cfd0f1e451c230c2cbad36e3842bb6
parentc18012cf493cace493fb7dbf127658836dc8ec3d (diff)
downloadfreebsd-ports-gnome-a5cdfcf1f380218fc9f736a5ae1eb9565415b875.tar.gz
freebsd-ports-gnome-a5cdfcf1f380218fc9f736a5ae1eb9565415b875.tar.zst
freebsd-ports-gnome-a5cdfcf1f380218fc9f736a5ae1eb9565415b875.zip
Remove extra blank line to please portlint.
Don't let the port chmod 777 ${WRKSRC}/src to prevent possible security issue. Submitted by: tijl@ (priv mail)
-rw-r--r--converters/libiconv/Makefile1
-rw-r--r--converters/libiconv/files/patch-src::Makefile.in14
2 files changed, 11 insertions, 4 deletions
diff --git a/converters/libiconv/Makefile b/converters/libiconv/Makefile
index d811edb66504..a640159bba61 100644
--- a/converters/libiconv/Makefile
+++ b/converters/libiconv/Makefile
@@ -49,5 +49,4 @@ post-patch:
${WRKSRC}/libcharset/configure \
${WRKSRC}/preload/configure
-
.include <bsd.port.mk>
diff --git a/converters/libiconv/files/patch-src::Makefile.in b/converters/libiconv/files/patch-src::Makefile.in
index ba1da2b0eedf..fc5bbd58b95d 100644
--- a/converters/libiconv/files/patch-src::Makefile.in
+++ b/converters/libiconv/files/patch-src::Makefile.in
@@ -1,6 +1,14 @@
---- src/Makefile.in.orig 2009-06-21 07:17:33.000000000 -0400
-+++ src/Makefile.in 2009-07-04 19:46:15.000000000 -0400
-@@ -113,6 +113,7 @@ install : all force
+--- src/Makefile.in.orig 2011-06-04 19:05:58.000000000 +0200
++++ src/Makefile.in 2013-07-06 18:49:54.000000000 +0200
+@@ -71,7 +71,6 @@
+ # without internationalization and not linked with libintl.
+
+ all : iconv_no_i18n$(EXEEXT) iconv.@OBJEXT@ $(OBJECTS_RES_@WOE32@)
+- test `ls -ld . | sed -e 's/^d\(.........\).*/\1/'` = rwxrwxrwx || chmod 777 .
+
+ # This is the temporary iconv executable, without internationalization.
+ iconv_no_i18n$(EXEEXT) : iconv_no_i18n.@OBJEXT@ ../lib/libiconv.la $(OBJECTS_RES_@WOE32@)
+@@ -113,6 +112,7 @@
if [ ! -d $(DESTDIR)$(bindir) ] ; then $(mkinstalldirs) $(DESTDIR)$(bindir) ; fi
case "@host_os@" in \
hpux*) $(CC) $(LDFLAGS) $(CFLAGS) $(iconv_LDFLAGS) iconv.@OBJEXT@ ../srclib/libicrt.a -L$(DESTDIR)$(libdir) -liconv @LIBINTL@ $(OBJECTS_RES_@WOE32@) `if test -n '$(DESTDIR)'; then echo " -Wl,+b -Wl,$(libdir)"; fi` -o iconv$(EXEEXT);; \