aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorstephen <stephen@FreeBSD.org>2012-06-20 10:38:16 +0800
committerstephen <stephen@FreeBSD.org>2012-06-20 10:38:16 +0800
commita627ef6dacb19d7ce502fe691dbb49c2ee4832b2 (patch)
treed9aea61f92bd26421faf8503714854e915e41e6b
parent3ddf14160c82774fb7a503153b077820d782bfdc (diff)
downloadfreebsd-ports-gnome-a627ef6dacb19d7ce502fe691dbb49c2ee4832b2.tar.gz
freebsd-ports-gnome-a627ef6dacb19d7ce502fe691dbb49c2ee4832b2.tar.zst
freebsd-ports-gnome-a627ef6dacb19d7ce502fe691dbb49c2ee4832b2.zip
- New port math/octave-forge-java.
The octave-forge package is the result of The GNU Octave Repositry project, which is intended to be a central location for custom scripts, functions and extensions for GNU Octave. contains the source for all the functions plus build and install scripts. This is java, and provides a Java interface with OO-like Java objects manipulation.
-rw-r--r--math/Makefile1
-rw-r--r--math/octave-forge-java/Makefile37
-rw-r--r--math/octave-forge-java/distinfo2
-rw-r--r--math/octave-forge-java/pkg-descr10
-rw-r--r--math/octave-forge-java/pkg-plist1
5 files changed, 51 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 3430b71b25e3..a9b19d6817bf 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -291,6 +291,7 @@
SUBDIR += octave-forge-integration
SUBDIR += octave-forge-io
SUBDIR += octave-forge-irsa
+ SUBDIR += octave-forge-java
SUBDIR += octave-forge-linear-algebra
SUBDIR += octave-forge-mapping
SUBDIR += octave-forge-mechanics
diff --git a/math/octave-forge-java/Makefile b/math/octave-forge-java/Makefile
new file mode 100644
index 000000000000..1549bd27a8a8
--- /dev/null
+++ b/math/octave-forge-java/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: octave-forge-java
+# Date created: 19 June 2012
+# Whom: Stephen Montgomery-Smith <stephen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= octave-forge-java
+PORTVERSION= 1.2.8
+CATEGORIES= math java
+
+MAINTAINER= stephen@FreeBSD.org
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${OCTAVE_PKGNAME}
+
+GNU_CONFIGURE= yes
+USE_JAVA= 1.5+
+CONFIGURE_ENV+= JAVA_HOME=${JAVA_HOME}
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
+MAKE_ENV+= MKOCTFILE=mkoctfile
+
+RUN_DEPENDS+= ${TARBALLS_DIR}/signal.tar.gz:${PORTSDIR}/math/octave-forge-signal
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.octave.mk"
+post-patch:
+ ${REINPLACE_CMD} 's+/client/libjvm.so+/server/libjvm.so+' ${WRKSRC}/__java__.cc
+
+post-build:
+ ${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
+
+.include <bsd.port.post.mk>
diff --git a/math/octave-forge-java/distinfo b/math/octave-forge-java/distinfo
new file mode 100644
index 000000000000..32054ed46062
--- /dev/null
+++ b/math/octave-forge-java/distinfo
@@ -0,0 +1,2 @@
+SHA256 (octave-forge/java-1.2.8.tar.gz) = 5785ddd72179148004652bbd98484000b7c69fe97b2c68d7a5febdd37f215953
+SIZE (octave-forge/java-1.2.8.tar.gz) = 603999
diff --git a/math/octave-forge-java/pkg-descr b/math/octave-forge-java/pkg-descr
new file mode 100644
index 000000000000..20009fe4125e
--- /dev/null
+++ b/math/octave-forge-java/pkg-descr
@@ -0,0 +1,10 @@
+The octave-forge package is the result of The GNU Octave Repositry project,
+which is intended to be a central location for custom scripts, functions and
+extensions for GNU Octave. contains the source for all the functions plus
+build and install scripts.
+
+This is java.
+
+ Provides Java interface with OO-like Java objects manipulation.
+
+WWW: http://octave.sourceforge.net/
diff --git a/math/octave-forge-java/pkg-plist b/math/octave-forge-java/pkg-plist
new file mode 100644
index 000000000000..a999ec86c07e
--- /dev/null
+++ b/math/octave-forge-java/pkg-plist
@@ -0,0 +1 @@
+@comment This file intentionally left empty