aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2007-08-25 06:31:16 +0800
committerthierry <thierry@FreeBSD.org>2007-08-25 06:31:16 +0800
commita64e6b4d79e09d06dd2a00e0e9726de788ffde37 (patch)
tree69d349d44808105df46750fccfd8cd35567b79b6
parent3bab2993eacd9b02b0654eecbf82413038443a69 (diff)
downloadfreebsd-ports-gnome-a64e6b4d79e09d06dd2a00e0e9726de788ffde37.tar.gz
freebsd-ports-gnome-a64e6b4d79e09d06dd2a00e0e9726de788ffde37.tar.zst
freebsd-ports-gnome-a64e6b4d79e09d06dd2a00e0e9726de788ffde37.zip
The board library allows simple drawings in:
* Encapsulated Postcript files (EPS); * XFig files (FIG); * Scalable Vector Graphics files (SVG). WWW: http://www.greyc.ensicaen.fr/~seb/board/
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/libboard/Makefile43
-rw-r--r--graphics/libboard/distinfo3
-rw-r--r--graphics/libboard/pkg-descr7
-rw-r--r--graphics/libboard/pkg-plist11
5 files changed, 65 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index db517c56bc4a..a9baea8f70a7 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -338,6 +338,7 @@
SUBDIR += libart
SUBDIR += libart_lgpl
SUBDIR += libaux
+ SUBDIR += libboard
SUBDIR += libcaca
SUBDIR += libdrm
SUBDIR += libemf
diff --git a/graphics/libboard/Makefile b/graphics/libboard/Makefile
new file mode 100644
index 000000000000..83807026a377
--- /dev/null
+++ b/graphics/libboard/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: libboard
+# Date created: Fri 24 aug 2007
+# Whom: thierry@pompo.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= libboard
+PORTVERSION= 0.8.0
+CATEGORIES= graphics
+MASTER_SITES= http://www.greyc.ensicaen.fr/~seb/board/download/
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= A vector graphics C++ library
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX}
+CONFIGURE_ENV= CXX=${CXX}
+
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+
+PORTDOCS= *
+
+pre-configure:
+ ${REINPLACE_CMD} -e 's|-O3|${CXXFLAGS}|' ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+post-install:
+ ${MV} ${PREFIX}/lib/libboard.so ${PREFIX}/lib/libboard.so.0
+ ${LN} -sf ${PREFIX}/lib/libboard.so.0 ${PREFIX}/lib/libboard.so
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC}/doc/html/ && ${COPYTREE_SHARE} . ${DOCSDIR}/
+.endif
+
+regression-test:
+ (cd ${WRKDIR} && ${WRKSRC}/bin/arithmetic bec)
+.for ex in 1 2 3
+ (cd ${WRKDIR} && ${WRKSRC}/bin/example${ex})
+.endfor
+ ${LS} -l ${WRKDIR}/arithm* ${WRKDIR}/draw*
+
+.include <bsd.port.mk>
diff --git a/graphics/libboard/distinfo b/graphics/libboard/distinfo
new file mode 100644
index 000000000000..48dec43967c2
--- /dev/null
+++ b/graphics/libboard/distinfo
@@ -0,0 +1,3 @@
+MD5 (libboard-0.8.0.tar.gz) = 6e60f5915dd5e3bc989103f82ee1f6d3
+SHA256 (libboard-0.8.0.tar.gz) = c8b4d5036a08c1ec835c910e25c41051aadd6fd596d8e5be34dfaa938f3beeeb
+SIZE (libboard-0.8.0.tar.gz) = 130724
diff --git a/graphics/libboard/pkg-descr b/graphics/libboard/pkg-descr
new file mode 100644
index 000000000000..20f092dac259
--- /dev/null
+++ b/graphics/libboard/pkg-descr
@@ -0,0 +1,7 @@
+The board library allows simple drawings in:
+
+ * Encapsulated Postcript files (EPS);
+ * XFig files (FIG);
+ * Scalable Vector Graphics files (SVG).
+
+WWW: http://www.greyc.ensicaen.fr/~seb/board/
diff --git a/graphics/libboard/pkg-plist b/graphics/libboard/pkg-plist
new file mode 100644
index 000000000000..5b477b45260a
--- /dev/null
+++ b/graphics/libboard/pkg-plist
@@ -0,0 +1,11 @@
+include/Board.h
+include/board/Board.h
+include/board/Color.h
+include/board/Point.h
+include/board/Rect.h
+include/board/Shapes.h
+include/board/Transforms.h
+lib/libboard.a
+lib/libboard.so
+lib/libboard.so.0
+@dirrm include/board