aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjoerg <joerg@FreeBSD.org>2006-09-29 06:13:24 +0800
committerjoerg <joerg@FreeBSD.org>2006-09-29 06:13:24 +0800
commita67dd1a6edcf2b606515e8c7e4242ab4793810e8 (patch)
treea6d5b2ab2e716575e064e7b3577f82bcfcc3cf16
parent2bdeed6ce67ebaa6e916f8b6a5a7555b28d54534 (diff)
downloadfreebsd-ports-gnome-a67dd1a6edcf2b606515e8c7e4242ab4793810e8.tar.gz
freebsd-ports-gnome-a67dd1a6edcf2b606515e8c7e4242ab4793810e8.tar.zst
freebsd-ports-gnome-a67dd1a6edcf2b606515e8c7e4242ab4793810e8.zip
Add a workaround for binutils-2.17's pickyness about copying an empty
section in [avr-]objcopy, until a new version of avr-libc is going to be released.
-rw-r--r--devel/avr-libc/Makefile1
-rw-r--r--devel/avr-libc/files/patch-binutils2.1728
2 files changed, 29 insertions, 0 deletions
diff --git a/devel/avr-libc/Makefile b/devel/avr-libc/Makefile
index d87db810463c..347904c918a1 100644
--- a/devel/avr-libc/Makefile
+++ b/devel/avr-libc/Makefile
@@ -8,6 +8,7 @@
PORTNAME= avr-libc
PORTVERSION= 1.4.4
PORTEPOCH= 1
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/devel/avr-libc/files/patch-binutils2.17 b/devel/avr-libc/files/patch-binutils2.17
new file mode 100644
index 000000000000..52f20cb47148
--- /dev/null
+++ b/devel/avr-libc/files/patch-binutils2.17
@@ -0,0 +1,28 @@
+Index: doc/examples/demo/Makefile
+===================================================================
+RCS file: /home/cvs/avr-libc/avr-libc/doc/examples/demo/Makefile,v
+retrieving revision 1.10
+retrieving revision 1.11
+diff -u -u -r1.10 -r1.11
+--- doc/examples/demo/Makefile 19 Apr 2006 20:09:20 -0000 1.10
++++ doc/examples/demo/Makefile 28 Aug 2006 05:23:27 -0000 1.11
+@@ -108,13 +108,16 @@
+ esrec: $(PRG)_eeprom.srec
+
+ %_eeprom.hex: %.elf
+- $(OBJCOPY) -j .eeprom --change-section-lma .eeprom=0 -O ihex $< $@
++ $(OBJCOPY) -j .eeprom --change-section-lma .eeprom=0 -O ihex $< $@ \
++ || { echo empty $@ not generated; exit 0; }
+
+ %_eeprom.srec: %.elf
+- $(OBJCOPY) -j .eeprom --change-section-lma .eeprom=0 -O srec $< $@
++ $(OBJCOPY) -j .eeprom --change-section-lma .eeprom=0 -O srec $< $@ \
++ || { echo empty $@ not generated; exit 0; }
+
+ %_eeprom.bin: %.elf
+- $(OBJCOPY) -j .eeprom --change-section-lma .eeprom=0 -O binary $< $@
++ $(OBJCOPY) -j .eeprom --change-section-lma .eeprom=0 -O binary $< $@ \
++ || { echo empty $@ not generated; exit 0; }
+
+ # Every thing below here is used by avr-libc's build system and can be ignored
+ # by the casual user.