aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjpaetzel <jpaetzel@FreeBSD.org>2009-06-05 17:48:26 +0800
committerjpaetzel <jpaetzel@FreeBSD.org>2009-06-05 17:48:26 +0800
commita6ac8133f8d86609f9376b454de25efcb8b40d0d (patch)
tree9295488b13863a7ab694dde6be5730c5da307f70
parent07191d0e09b1203e028d317a9c868dc73b84e3fb (diff)
downloadfreebsd-ports-gnome-a6ac8133f8d86609f9376b454de25efcb8b40d0d.tar.gz
freebsd-ports-gnome-a6ac8133f8d86609f9376b454de25efcb8b40d0d.tar.zst
freebsd-ports-gnome-a6ac8133f8d86609f9376b454de25efcb8b40d0d.zip
Update devel/popt to latest version
Approved by: linimon (mentor)
-rw-r--r--devel/popt/Makefile10
-rw-r--r--devel/popt/distinfo6
-rw-r--r--devel/popt/files/patch-Makefile.in57
-rw-r--r--devel/popt/files/patch-configure6
-rw-r--r--devel/popt/files/patch-popt.36
-rw-r--r--devel/popt/files/patch-popt.c15
-rw-r--r--devel/popt/files/patch-popt.h11
-rw-r--r--devel/popt/files/patch-popthelp.c20
-rw-r--r--devel/popt/files/patch-test3.c11
-rw-r--r--devel/popt/pkg-plist16
10 files changed, 45 insertions, 113 deletions
diff --git a/devel/popt/Makefile b/devel/popt/Makefile
index 0ed76ad3c230..b859671cf284 100644
--- a/devel/popt/Makefile
+++ b/devel/popt/Makefile
@@ -6,15 +6,9 @@
#
PORTNAME= popt
-PORTVERSION= 1.7
-PORTREVISION= 5
+PORTVERSION= 1.14
CATEGORIES= devel
-MASTER_SITES= ftp://ftp.rpm.org/pub/rpm/dist/%SUBDIR%/ \
- http://rpmfind.net/linux/rpm.org/rpm/dist/%SUBDIR%/ \
- ftp://ftp.mirrorservice.org/sites/ftp.rpm.org/pub/rpm/dist/%SUBDIR%/ \
- http://gd.tuwien.ac.at/utils/rpm.org/dist/%SUBDIR%/ \
- ftp://sunsite.cnlab-switch.ch/mirror/rpm/dist/%SUBDIR%/ \
- ftp://ftp.sunfreeware.com/pub/freeware/SOURCES/
+MASTER_SITES= ftp://ftp.sunfreeware.com/pub/freeware/SOURCES/
MASTER_SITE_SUBDIR= rpm-4.1.x
MAINTAINER= jpaetzel@FreeBSD.org
diff --git a/devel/popt/distinfo b/devel/popt/distinfo
index c8d18a193f24..910b9b7467e2 100644
--- a/devel/popt/distinfo
+++ b/devel/popt/distinfo
@@ -1,3 +1,3 @@
-MD5 (popt-1.7.tar.gz) = 5988e7aeb0ae4dac8d83561265984cc9
-SHA256 (popt-1.7.tar.gz) = 4e75cb28793f0d44134f71fae53057d5f250805e6268fbd9c9780654b73b0dc1
-SIZE (popt-1.7.tar.gz) = 574549
+MD5 (popt-1.14.tar.gz) = 4f90a07316eb825604dd10ae4f9f3f04
+SHA256 (popt-1.14.tar.gz) = 175be17571e9af3ad622531b494a0738ae632c60c8c6329273778b2b6fbbad74
+SIZE (popt-1.14.tar.gz) = 695557
diff --git a/devel/popt/files/patch-Makefile.in b/devel/popt/files/patch-Makefile.in
index aa772242f9a7..6f0839ebec83 100644
--- a/devel/popt/files/patch-Makefile.in
+++ b/devel/popt/files/patch-Makefile.in
@@ -1,37 +1,28 @@
---- ./Makefile.in.orig Sat Aug 31 17:22:18 2002
-+++ ./Makefile.in Wed Apr 4 12:24:18 2007
-@@ -124,7 +124,7 @@
- popt.ps
-
-
--SUBDIRS = intl po
-+SUBDIRS = po
-
- INCLUDES = -I. -I$(top_srcdir)
-
-@@ -133,13 +133,13 @@
- noinst_PROGRAMS = test1 test2 test3
+--- Makefile.in.old 2009-05-07 15:17:31.000000000 -0500
++++ Makefile.in 2009-05-07 15:21:28.000000000 -0500
+@@ -70,7 +70,7 @@
+ "$(DESTDIR)$(includedir)"
+ usrlibLTLIBRARIES_INSTALL = $(INSTALL)
+ LTLIBRARIES = $(usrlib_LTLIBRARIES)
+-libpopt_la_LIBADD =
++libpopt_la_LIBADD = $(LTLIBINTL)
+ am_libpopt_la_OBJECTS = popt.lo poptparse.lo poptconfig.lo popthelp.lo \
+ poptint.lo
+ libpopt_la_OBJECTS = $(am_libpopt_la_OBJECTS)
+@@ -287,13 +287,13 @@
+ noinst_HEADERS = poptint.h system.h
test1_SOURCES = test1.c
- test1_LDFLAGS = -all-static
--test1_LDADD = $(lib_LTLIBRARIES)
-+test1_LDADD = $(lib_LTLIBRARIES) $(LTLIBICONV)
+ test1_LDFLAGS =
+-test1_LDADD = $(usrlib_LTLIBRARIES)
++test1_LDADD = $(usrlib_LTLIBRARIES) $(LTLIBICONV)
test2_SOURCES = test2.c
- test2_LDFLAGS = -all-static
--test2_LDADD = $(lib_LTLIBRARIES)
-+test2_LDADD = $(lib_LTLIBRARIES) $(LTLIBICONV)
+ test2_LDFLAGS =
+-test2_LDADD = $(usrlib_LTLIBRARIES)
++test2_LDADD = $(usrlib_LTLIBRARIES) $(LTLIBICONV)
test3_SOURCES = test3.c
- test3_LDFLAGS = -all-static
--test3_LDADD = $(lib_LTLIBRARIES)
-+test3_LDADD = $(lib_LTLIBRARIES) # $(LTLIBICONV)
-
+ test3_LDFLAGS =
+-test3_LDADD = $(usrlib_LTLIBRARIES)
++test3_LDADD = $(usrlib_LTLIBRARIES) $(LTLIBICONV)
noinst_SCRIPTS = testit.sh
-
-@@ -164,7 +164,7 @@
- LTLIBRARIES = $(lib_LTLIBRARIES)
-
- libpopt_la_LDFLAGS =
--libpopt_la_LIBADD =
-+libpopt_la_LIBADD = $(LTLIBINTL)
- am_libpopt_la_OBJECTS = popt.lo findme.lo poptparse.lo poptconfig.lo \
- popthelp.lo
- libpopt_la_OBJECTS = $(am_libpopt_la_OBJECTS)
+ TESTS_ENVIRONMENT = \
+ test1="./test1"
diff --git a/devel/popt/files/patch-configure b/devel/popt/files/patch-configure
index 3abc913ea09a..5cc555e3fef5 100644
--- a/devel/popt/files/patch-configure
+++ b/devel/popt/files/patch-configure
@@ -1,6 +1,6 @@
---- ./configure.orig Sat Aug 31 17:22:20 2002
-+++ ./configure Wed Apr 4 12:24:18 2007
-@@ -8327,6 +8327,7 @@
+--- configure.old 2009-05-07 15:24:09.000000000 -0500
++++ configure 2009-05-07 15:31:26.000000000 -0500
+@@ -19487,6 +19487,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
diff --git a/devel/popt/files/patch-popt.3 b/devel/popt/files/patch-popt.3
index 34152864f6d6..828f551f5412 100644
--- a/devel/popt/files/patch-popt.3
+++ b/devel/popt/files/patch-popt.3
@@ -1,5 +1,5 @@
---- ./popt.3.orig Wed Apr 4 12:24:38 2007
-+++ ./popt.3 Wed Apr 4 12:25:14 2007
+--- popt.3.old 2009-05-07 15:35:15.000000000 -0500
++++ popt.3 2009-05-07 15:36:09.000000000 -0500
@@ -24,7 +24,7 @@
.sp
.BI "const char ** poptGetArgs(poptContext " con );
@@ -9,7 +9,7 @@
.sp
.BI "const char * poptBadOption(poptContext " con ", int " flags );
.sp
-@@ -491,7 +491,7 @@
+@@ -497,7 +497,7 @@
good error messages.
.HP
.nf
diff --git a/devel/popt/files/patch-popt.c b/devel/popt/files/patch-popt.c
index 9ce24f0ee3b1..b1a05d654e24 100644
--- a/devel/popt/files/patch-popt.c
+++ b/devel/popt/files/patch-popt.c
@@ -1,6 +1,6 @@
---- ./popt.c.orig Thu Aug 22 18:17:44 2002
-+++ ./popt.c Wed Apr 4 12:25:14 2007
-@@ -14,6 +14,9 @@
+--- popt.c.old 2009-05-07 15:44:42.000000000 -0500
++++ popt.c 2009-05-07 15:47:12.000000000 -0500
+@@ -22,6 +22,9 @@
#include <float.h>
#endif
#include <math.h>
@@ -8,14 +8,5 @@
+#include <machine/float.h>
+#endif
- #include "findme.h"
#include "poptint.h"
-@@ -1153,7 +1156,7 @@
- /*@=nullderef@*/
- }
--const char *const poptStrerror(const int error)
-+const char * poptStrerror(const int error)
- {
- switch (error) {
- case POPT_ERROR_NOARG:
diff --git a/devel/popt/files/patch-popt.h b/devel/popt/files/patch-popt.h
deleted file mode 100644
index de901b40e1d0..000000000000
--- a/devel/popt/files/patch-popt.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./popt.h.orig Wed Apr 4 12:24:48 2007
-+++ ./popt.h Wed Apr 4 12:25:14 2007
-@@ -440,7 +440,7 @@
- * @return error string
- */
- /*@-redecl@*/
--/*@observer@*/ const char *const poptStrerror(const int error)
-+/*@observer@*/ const char * poptStrerror(const int error)
- /*@*/;
- /*@=redecl@*/
-
diff --git a/devel/popt/files/patch-popthelp.c b/devel/popt/files/patch-popthelp.c
deleted file mode 100644
index 5be18ff6ac31..000000000000
--- a/devel/popt/files/patch-popthelp.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- ./popthelp.c.orig Wed Apr 4 12:25:01 2007
-+++ ./popthelp.c Wed Apr 4 12:25:14 2007
-@@ -67,7 +67,7 @@
- /**
- * @param table option(s)
- */
--/*@observer@*/ /*@null@*/ static const char *const
-+/*@observer@*/ /*@null@*/ static const char *
- getTableTranslationDomain(/*@null@*/ const struct poptOption *table)
- /*@*/
- {
-@@ -85,7 +85,7 @@
- * @param opt option(s)
- * @param translation_domain translation domain
- */
--/*@observer@*/ /*@null@*/ static const char *const
-+/*@observer@*/ /*@null@*/ static const char *
- getArgDescrip(const struct poptOption * opt,
- /*@-paramuse@*/ /* FIX: i18n macros disabled with lclint */
- /*@null@*/ const char * translation_domain)
diff --git a/devel/popt/files/patch-test3.c b/devel/popt/files/patch-test3.c
deleted file mode 100644
index 2b145a6c1ba7..000000000000
--- a/devel/popt/files/patch-test3.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./test3.c.orig Sat Jul 20 23:04:08 2002
-+++ ./test3.c Wed Apr 4 12:24:18 2007
-@@ -9,7 +9,7 @@
- int main (int argc, char **argv) {
- char *out;
- int newargc, j, f, ret;
-- char **newargv;
-+ const char **newargv;
- FILE *fp;
-
- if (argc == 1) {
diff --git a/devel/popt/pkg-plist b/devel/popt/pkg-plist
index 2f531ac86bf3..0dc70c63c8b4 100644
--- a/devel/popt/pkg-plist
+++ b/devel/popt/pkg-plist
@@ -7,30 +7,28 @@ lib/libpopt.so.0
%%NLS%%share/locale/da/LC_MESSAGES/popt.mo
%%NLS%%share/locale/de/LC_MESSAGES/popt.mo
%%NLS%%share/locale/es/LC_MESSAGES/popt.mo
-%%NLS%%share/locale/eu_ES/LC_MESSAGES/popt.mo
%%NLS%%share/locale/fi/LC_MESSAGES/popt.mo
%%NLS%%share/locale/fr/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/ga/LC_MESSAGES/popt.mo
%%NLS%%share/locale/gl/LC_MESSAGES/popt.mo
%%NLS%%share/locale/hu/LC_MESSAGES/popt.mo
-%%NLS%%share/locale/id/LC_MESSAGES/popt.mo
%%NLS%%share/locale/is/LC_MESSAGES/popt.mo
%%NLS%%share/locale/it/LC_MESSAGES/popt.mo
%%NLS%%share/locale/ja/LC_MESSAGES/popt.mo
%%NLS%%share/locale/ko/LC_MESSAGES/popt.mo
-%%NLS%%share/locale/no/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/popt.mo
%%NLS%%share/locale/pl/LC_MESSAGES/popt.mo
%%NLS%%share/locale/pt/LC_MESSAGES/popt.mo
-%%NLS%%share/locale/pt_BR/LC_MESSAGES/popt.mo
%%NLS%%share/locale/ro/LC_MESSAGES/popt.mo
%%NLS%%share/locale/ru/LC_MESSAGES/popt.mo
%%NLS%%share/locale/sk/LC_MESSAGES/popt.mo
%%NLS%%share/locale/sl/LC_MESSAGES/popt.mo
-%%NLS%%share/locale/sr/LC_MESSAGES/popt.mo
%%NLS%%share/locale/sv/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/th/LC_MESSAGES/popt.mo
%%NLS%%share/locale/tr/LC_MESSAGES/popt.mo
%%NLS%%share/locale/uk/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/popt.mo
%%NLS%%share/locale/wa/LC_MESSAGES/popt.mo
-%%NLS%%share/locale/zh/LC_MESSAGES/popt.mo
-%%NLS%%share/locale/zh_CN.GB2312/LC_MESSAGES/popt.mo
-%%NLS%%@dirrmtry share/locale/eu_ES/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/eu_ES
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/popt.mo