aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2019-08-11 19:27:26 +0800
committersunpoet <sunpoet@FreeBSD.org>2019-08-11 19:27:26 +0800
commita6d2fa2d503b617c2596c392c6c437672eb91275 (patch)
tree419653c639517ad2b96b0cde44b655c29be34c3e
parentd335263fb9d3a8703c880b4f9ee40ab39f0d27ad (diff)
downloadfreebsd-ports-gnome-a6d2fa2d503b617c2596c392c6c437672eb91275.tar.gz
freebsd-ports-gnome-a6d2fa2d503b617c2596c392c6c437672eb91275.tar.zst
freebsd-ports-gnome-a6d2fa2d503b617c2596c392c6c437672eb91275.zip
Add rubygem-google-cloud-storage 1.20.0
Google Cloud Storage (docs) allows you to store data on Google infrastructure with very high reliability, performance and availability, and can be used to distribute large data objects to users via direct download. WWW: https://github.com/googleapis/google-cloud-ruby/tree/master/google-cloud-storage
-rw-r--r--net/Makefile1
-rw-r--r--net/rubygem-google-cloud-storage/Makefile27
-rw-r--r--net/rubygem-google-cloud-storage/distinfo3
-rw-r--r--net/rubygem-google-cloud-storage/pkg-descr5
4 files changed, 36 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 3946b0cd0b98..280792d699b6 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1257,6 +1257,7 @@
SUBDIR += rubygem-gitlab_omniauth-ldap
SUBDIR += rubygem-google-cloud-core
SUBDIR += rubygem-google-cloud-env
+ SUBDIR += rubygem-google-cloud-storage
SUBDIR += rubygem-grpc
SUBDIR += rubygem-hangouts-chat
SUBDIR += rubygem-http_parser.rb
diff --git a/net/rubygem-google-cloud-storage/Makefile b/net/rubygem-google-cloud-storage/Makefile
new file mode 100644
index 000000000000..a4e8dea4d84c
--- /dev/null
+++ b/net/rubygem-google-cloud-storage/Makefile
@@ -0,0 +1,27 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= google-cloud-storage
+PORTVERSION= 1.20.0
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Official library for Google Cloud Storage
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= rubygem-addressable>=2.5<3.0:www/rubygem-addressable \
+ rubygem-digest-crc>=0.4<1.0:security/rubygem-digest-crc \
+ rubygem-google-api-client>=0.26<1.0:devel/rubygem-google-api-client \
+ rubygem-google-cloud-core>=1.2<2.0:net/rubygem-google-cloud-core \
+ rubygem-googleauth>=0.6.2<0.10.0:security/rubygem-googleauth \
+ rubygem-mini_mime>=1.0<2.0:mail/rubygem-mini_mime
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-google-cloud-storage/distinfo b/net/rubygem-google-cloud-storage/distinfo
new file mode 100644
index 000000000000..2698c101df5f
--- /dev/null
+++ b/net/rubygem-google-cloud-storage/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1565514605
+SHA256 (rubygem/google-cloud-storage-1.20.0.gem) = c618e8f5e5b6ad87df82016012e0f450629421b879cc1b11be52fcaf0d969b77
+SIZE (rubygem/google-cloud-storage-1.20.0.gem) = 81920
diff --git a/net/rubygem-google-cloud-storage/pkg-descr b/net/rubygem-google-cloud-storage/pkg-descr
new file mode 100644
index 000000000000..fff33eef6eb0
--- /dev/null
+++ b/net/rubygem-google-cloud-storage/pkg-descr
@@ -0,0 +1,5 @@
+Google Cloud Storage (docs) allows you to store data on Google infrastructure
+with very high reliability, performance and availability, and can be used to
+distribute large data objects to users via direct download.
+
+WWW: https://github.com/googleapis/google-cloud-ruby/tree/master/google-cloud-storage