aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-01-10 20:49:00 +0800
committermaho <maho@FreeBSD.org>2007-01-10 20:49:00 +0800
commita70ddd90ac6e3f8dce52681cdf2657d0253428b8 (patch)
treed916f4c731e853b7dbdccb88ed7c029a858d3454
parent6ecb9f82679234a62a0611ea8c94023ce932b60e (diff)
downloadfreebsd-ports-gnome-a70ddd90ac6e3f8dce52681cdf2657d0253428b8.tar.gz
freebsd-ports-gnome-a70ddd90ac6e3f8dce52681cdf2657d0253428b8.tar.zst
freebsd-ports-gnome-a70ddd90ac6e3f8dce52681cdf2657d0253428b8.zip
* Migrate to gfortran.
* Bump port revision. * Use gfortran compiled atlas/blas/lapack.
-rw-r--r--math/blocksolve95/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/math/blocksolve95/Makefile b/math/blocksolve95/Makefile
index 4ea45f29e6d3..74583ac59cb6 100644
--- a/math/blocksolve95/Makefile
+++ b/math/blocksolve95/Makefile
@@ -7,7 +7,7 @@
PORTNAME= blocksolve95
PORTVERSION= 3.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math parallel
MASTER_SITES= ftp://info.mcs.anl.gov/pub/BlockSolve95/ \
ftp://ftp.irisa.fr/pub/mirrors/BlockSolve95/
@@ -32,7 +32,9 @@ MPIDIR= ${LOCALBASE}/mpich2
PETSC_ARCH= freebsd
BOPT?= O
-FFLAGS?= -O2
+WANT_FORTRAN= yes
+USE_GCC=4.2+
+FFLAGS+= -O2
INCLUDES= BMmsg.h BSdepend.h BSlog.h BSmy_blas.h BSprivate.h BSsparse.h
PORTDOCS= manual.ps
@@ -43,11 +45,12 @@ PORTDOCS= manual.ps
WITH_ATLAS= yes
.endif
.if defined(WITH_ATLAS)
-LIB_DEPENDS+= f77blas.1:${PORTSDIR}/math/atlas
-BLAS_LIB= "-lf77blas -lcblas -latlas -lg2c -lm"
+LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
+BLAS_LIB= "-lf77blas -latlas -lm"
LAPACK_LIB= "-L${LOCALBASE}/lib -lalapack"
.else
-LIB_DEPENDS+= lapack.3:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
BLAS_LIB= "-lblas -lm"
LAPACK_LIB= "-L${LOCALBASE}/lib -llapack"
.endif