aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-10-11 01:45:57 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-10-11 01:45:57 +0800
commita798b20786441a701f33c6826c2b65d9fe00ca19 (patch)
treee126d4230754cba870576d34ad3eaf1a3aec60f1
parentba30260fc30fa3aaf4d6d8f76c918174e3d72eb4 (diff)
downloadfreebsd-ports-gnome-a798b20786441a701f33c6826c2b65d9fe00ca19.tar.gz
freebsd-ports-gnome-a798b20786441a701f33c6826c2b65d9fe00ca19.tar.zst
freebsd-ports-gnome-a798b20786441a701f33c6826c2b65d9fe00ca19.zip
Update graphics/openjpeg to 2.3.0
Changes: https://github.com/uclouvain/openjpeg/blob/master/CHANGELOG.md PR: 222817 Exp-run by: antoine
-rw-r--r--comms/qsstv/files/patch-qsstv_utils_color.cpp2
-rw-r--r--comms/qsstv/files/patch-qsstv_utils_jp2io.h2
-rw-r--r--graphics/gstreamer1-plugins-openjpeg/Makefile2
-rw-r--r--graphics/gstreamer1-plugins-openjpeg/files/patch-openjpeg23163
-rw-r--r--graphics/leptonica/files/patch-configure11
-rw-r--r--graphics/mupdf/files/patch-source__fitz__load-jpx.c2
-rw-r--r--graphics/openjpeg/Makefile2
-rw-r--r--graphics/openjpeg/distinfo6
8 files changed, 183 insertions, 7 deletions
diff --git a/comms/qsstv/files/patch-qsstv_utils_color.cpp b/comms/qsstv/files/patch-qsstv_utils_color.cpp
index f0c115fc0b97..d4e8c2e505e5 100644
--- a/comms/qsstv/files/patch-qsstv_utils_color.cpp
+++ b/comms/qsstv/files/patch-qsstv_utils_color.cpp
@@ -5,7 +5,7 @@
//#include "opj_apps_config.h"
-#include "openjpeg-2.1/openjpeg.h"
-+#include "openjpeg-2.2/openjpeg.h"
++#include "openjpeg-2.3/openjpeg.h"
#include "color.h"
diff --git a/comms/qsstv/files/patch-qsstv_utils_jp2io.h b/comms/qsstv/files/patch-qsstv_utils_jp2io.h
index 3cde6783633f..6990c4c8630d 100644
--- a/comms/qsstv/files/patch-qsstv_utils_jp2io.h
+++ b/comms/qsstv/files/patch-qsstv_utils_jp2io.h
@@ -4,7 +4,7 @@
#ifndef JP2READER_H
#define JP2READER_H
-#include "openjpeg.h"
-+#include "openjpeg-2.2/openjpeg.h"
++#include "openjpeg-2.3/openjpeg.h"
#include <QString>
#include <QImage>
diff --git a/graphics/gstreamer1-plugins-openjpeg/Makefile b/graphics/gstreamer1-plugins-openjpeg/Makefile
index cb4eb2d56c4f..3a246705b1ea 100644
--- a/graphics/gstreamer1-plugins-openjpeg/Makefile
+++ b/graphics/gstreamer1-plugins-openjpeg/Makefile
@@ -10,4 +10,6 @@ DIST= bad
MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer1-plugins
+EXTRA_PATCHES= ${.CURDIR}/files/patch-openjpeg23
+
.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gstreamer1-plugins-openjpeg/files/patch-openjpeg23 b/graphics/gstreamer1-plugins-openjpeg/files/patch-openjpeg23
new file mode 100644
index 000000000000..12579a1c796b
--- /dev/null
+++ b/graphics/gstreamer1-plugins-openjpeg/files/patch-openjpeg23
@@ -0,0 +1,163 @@
+--- config.h.in.orig 2017-09-18 11:34:31 UTC
++++ config.h.in
+@@ -459,6 +459,9 @@
+ /* Define if OpenJPEG 2.2 is used */
+ #undef HAVE_OPENJPEG_2_2
+
++/* Define if OpenJPEG 2.3 is used */
++#undef HAVE_OPENJPEG_2_3
++
+ /* Define to enable openni2 library (used by openni2). */
+ #undef HAVE_OPENNI2
+
+--- configure.orig 2017-09-18 11:34:30 UTC
++++ configure
+@@ -771,6 +771,8 @@
+ USE_OPENJPEG_FALSE
+ USE_OPENJPEG_TRUE
+ HAVE_OPENJPEG
++OPENJPEG_2_3_LIBS
++OPENJPEG_2_3_CFLAGS
+ OPENJPEG_2_2_LIBS
+ OPENJPEG_2_2_CFLAGS
+ OPENJPEG_2_1_LIBS
+@@ -2043,6 +2045,8 @@
+ OPENJPEG_2_1_LIBS
+ OPENJPEG_2_2_CFLAGS
+ OPENJPEG_2_2_LIBS
++OPENJPEG_2_3_CFLAGS
++OPENJPEG_2_3_LIBS
+ OPENNI2_CFLAGS
+ OPENNI2_LIBS
+ OPUS_CFLAGS
+@@ -3281,6 +3285,10 @@
+ C compiler flags for OPENJPEG_2_2, overriding pkg-config
+ OPENJPEG_2_2_LIBS
+ linker flags for OPENJPEG_2_2, overriding pkg-config
++ OPENJPEG_2_3_CFLAGS
++ C compiler flags for OPENJPEG_2_3, overriding pkg-config
++ OPENJPEG_2_3_LIBS
++ linker flags for OPENJPEG_2_3, overriding pkg-config
+ OPENNI2_CFLAGS
+ C compiler flags for OPENNI2, overriding pkg-config
+ OPENNI2_LIBS
+@@ -48938,6 +48946,106 @@
+
+ $as_echo "#define HAVE_OPENJPEG_2_2 1" >>confdefs.h
+
++
++ which="libopenjp2 >= 2.3"
++ required="no"
++
++
++pkg_failed=no
++{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for OPENJPEG_2_3" >&5
++$as_echo_n "checking for OPENJPEG_2_3... " >&6; }
++
++if test -n "$PKG_CONFIG"; then
++ if test -n "$OPENJPEG_2_3_CFLAGS"; then
++ pkg_cv_OPENJPEG_2_3_CFLAGS="$OPENJPEG_2_3_CFLAGS"
++ else
++ if test -n "$PKG_CONFIG" && \
++ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"\$which\""; } >&5
++ ($PKG_CONFIG --exists --print-errors "$which") 2>&5
++ ac_status=$?
++ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
++ test $ac_status = 0; }; then
++ pkg_cv_OPENJPEG_2_3_CFLAGS=`$PKG_CONFIG --cflags "$which" 2>/dev/null`
++else
++ pkg_failed=yes
++fi
++ fi
++else
++ pkg_failed=untried
++fi
++if test -n "$PKG_CONFIG"; then
++ if test -n "$OPENJPEG_2_3_LIBS"; then
++ pkg_cv_OPENJPEG_2_3_LIBS="$OPENJPEG_2_3_LIBS"
++ else
++ if test -n "$PKG_CONFIG" && \
++ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"\$which\""; } >&5
++ ($PKG_CONFIG --exists --print-errors "$which") 2>&5
++ ac_status=$?
++ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
++ test $ac_status = 0; }; then
++ pkg_cv_OPENJPEG_2_3_LIBS=`$PKG_CONFIG --libs "$which" 2>/dev/null`
++else
++ pkg_failed=yes
++fi
++ fi
++else
++ pkg_failed=untried
++fi
++
++
++
++if test $pkg_failed = yes; then
++
++if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
++ _pkg_short_errors_supported=yes
++else
++ _pkg_short_errors_supported=no
++fi
++ if test $_pkg_short_errors_supported = yes; then
++ OPENJPEG_2_3_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "$which"`
++ else
++ OPENJPEG_2_3_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "$which"`
++ fi
++ # Put the nasty error message in config.log where it belongs
++ echo "$OPENJPEG_2_3_PKG_ERRORS" >&5
++
++ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
++$as_echo "no" >&6; }
++
++ HAVE_OPENJPEG_2_3="no"
++ if test "x$required" = "xyes"; then
++ as_fn_error $? "$OPENJPEG_2_3_PKG_ERRORS" "$LINENO" 5
++ else
++ { $as_echo "$as_me:${as_lineno-$LINENO}: $OPENJPEG_2_3_PKG_ERRORS" >&5
++$as_echo "$as_me: $OPENJPEG_2_3_PKG_ERRORS" >&6;}
++ fi
++
++elif test $pkg_failed = untried; then
++
++ HAVE_OPENJPEG_2_3="no"
++ if test "x$required" = "xyes"; then
++ as_fn_error $? "$OPENJPEG_2_3_PKG_ERRORS" "$LINENO" 5
++ else
++ { $as_echo "$as_me:${as_lineno-$LINENO}: $OPENJPEG_2_3_PKG_ERRORS" >&5
++$as_echo "$as_me: $OPENJPEG_2_3_PKG_ERRORS" >&6;}
++ fi
++
++else
++ OPENJPEG_2_3_CFLAGS=$pkg_cv_OPENJPEG_2_3_CFLAGS
++ OPENJPEG_2_3_LIBS=$pkg_cv_OPENJPEG_2_3_LIBS
++ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
++$as_echo "yes" >&6; }
++
++ HAVE_OPENJPEG_2_3="yes"
++
++fi
++
++
++ if test x"$HAVE_OPENJPEG_2_3" = x"yes"; then
++
++$as_echo "#define HAVE_OPENJPEG_2_3 1" >>confdefs.h
++
++ fi
+ fi
+ fi
+ else
+--- ext/openjpeg/gstopenjpeg.h.orig 2017-08-17 10:39:18 UTC
++++ ext/openjpeg/gstopenjpeg.h
+@@ -38,7 +38,9 @@
+ #define OPJ_CPRL CPRL
+ #else
+ #include <stdio.h>
+-# if defined(HAVE_OPENJPEG_2_2)
++# if defined(HAVE_OPENJPEG_2_3)
++# include <openjpeg-2.3/openjpeg.h>
++# elif defined(HAVE_OPENJPEG_2_2)
+ # include <openjpeg-2.2/openjpeg.h>
+ # elif defined(HAVE_OPENJPEG_2_1)
+ # include <openjpeg-2.1/openjpeg.h>
diff --git a/graphics/leptonica/files/patch-configure b/graphics/leptonica/files/patch-configure
new file mode 100644
index 000000000000..d071860e1651
--- /dev/null
+++ b/graphics/leptonica/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2017-01-02 21:49:40 UTC
++++ configure
+@@ -12929,7 +12929,7 @@ if test "x$ac_cv_lib_openjp2_opj_create_
+ $as_echo "#define HAVE_LIBJP2K 1" >>confdefs.h
+ LIBJP2K_LIBS=-lopenjp2
+
+- for ac_header in openjpeg-2.2/openjpeg.h openjpeg-2.1/openjpeg.h openjpeg-2.0/openjpeg.h
++ for ac_header in openjpeg-2.3/openjpeg.h openjpeg-2.2/openjpeg.h openjpeg-2.1/openjpeg.h openjpeg-2.0/openjpeg.h
+ do :
+ as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
+ ac_fn_c_check_header_mongrel "$LINENO" "$ac_header" "$as_ac_Header" "$ac_includes_default"
diff --git a/graphics/mupdf/files/patch-source__fitz__load-jpx.c b/graphics/mupdf/files/patch-source__fitz__load-jpx.c
index 2b9bc9de1175..8bb5b365185b 100644
--- a/graphics/mupdf/files/patch-source__fitz__load-jpx.c
+++ b/graphics/mupdf/files/patch-source__fitz__load-jpx.c
@@ -16,7 +16,7 @@
#define USE_JPIP
-#include <openjpeg.h>
-+#include <openjpeg-2.2/openjpeg.h>
++#include <openjpeg-2.3/openjpeg.h>
struct fz_jpxd_s
{
diff --git a/graphics/openjpeg/Makefile b/graphics/openjpeg/Makefile
index 307ee2822e97..3ac9ebed22a8 100644
--- a/graphics/openjpeg/Makefile
+++ b/graphics/openjpeg/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= openjpeg
-PORTVERSION= 2.2.0
+PORTVERSION= 2.3.0
DISTVERSIONPREFIX= v
CATEGORIES= graphics
diff --git a/graphics/openjpeg/distinfo b/graphics/openjpeg/distinfo
index f500e715785c..1b6a6b8be5e4 100644
--- a/graphics/openjpeg/distinfo
+++ b/graphics/openjpeg/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1502573051
-SHA256 (uclouvain-openjpeg-v2.2.0_GH0.tar.gz) = 6fddbce5a618e910e03ad00d66e7fcd09cc6ee307ce69932666d54c73b7c6e7b
-SIZE (uclouvain-openjpeg-v2.2.0_GH0.tar.gz) = 2847582
+TIMESTAMP = 1507191000
+SHA256 (uclouvain-openjpeg-v2.3.0_GH0.tar.gz) = 3dc787c1bb6023ba846c2a0d9b1f6e179f1cd255172bde9eb75b01f1e6c7d71a
+SIZE (uclouvain-openjpeg-v2.3.0_GH0.tar.gz) = 2207329